1. Microsoft has announced the release of the Windows 10 Technical Preview. Read more...

sigmatel STAC92XX C-Major HD Audio Driver problems

Discussion in 'Windows 7 Hardware' started by Unregistered, Feb 21, 2007.

  1. Unregistered

    Unregistered Guest

    well i downloaded the right audio driver on my pc! because i have a sigmatel STAC92XX C-Major HD Audio card
    and i have a dell pc so i went to dell and downloaded the latest driver but IT DOESNT WORK!

    although when i went to configure in my audio settings and it did the audio test it did come out my rear, center, and sub probably no one can help its probably just the driver itself... but don't go telling me its vista capable when its not... SigmaTel pulled a nVidia!

    but if anyone can give me a suggestion or a website i would appreciate it
     
  2. Unregistered

    Unregistered Guest

    Similar problem

    I'm having some issues with the same driver downloaded from Dell. I use Ventrilio voice chat for gaming and one day the input up and decided to stop working. Because the output worked fine I assumed it was an issue with the cheap headset I bought, so I went and got another...same problem. I google the problem, find the CORRECT driver from dell for the E1505, and now I have no audio what-so-ever. Anyone have any suggestions?
     
  3. Unregistered

    Unregistered Guest

    i can't even uninstall it

    the sigmatel driver on my E1505 messed up and now i can't uninstall it at all, i don't feel like doing another reformat or anything...any suggestions?
     
  4. Unregistered

    Unregistered Guest

  5. Unregistered

    Unregistered Guest

    I have the same problem on a dell xps M1530. The driver that I downloaded form dell is not working with livemeeting. Any ideas? Thanks!
     
  6. Unregistered

    Unregistered Guest

    IF YOU HAVE A SIGMETEL DRIVER YOU SHOULD GET A DIFFERENT SOUND CARD XD they dont work for squat
     
  7. disumia

    disumia New Member

    Joined:
    Aug 7, 2009
    Messages:
    8
    i just got off the phone with dell and my company works with them alot. they stated that they do not support windows 7 yet and will not have any drivers that work correctly till end of october. from what i understand they havent even started to create proper drivers for this system yet.
     
  8. ai2ez4me

    ai2ez4me New Member

    Joined:
    Oct 18, 2009
    Messages:
    2
    similar problem

    I have a dell XPS 1530 with a sigmatel audio card and the driver that I downloaded from dell is not working.
    The C-major audio driver that I need for my sound card is not working, I hope that dell will release something to fix that
    problem on windows 7.

    Meanwhile if anybody find something about this issue, he would more than welcome to post is solution over here.
     
  9. tomsailor

    tomsailor New Member

    Joined:
    Nov 5, 2009
    Messages:
    2
    Sigmatel Driver for Dell Notebooks (XPS M1530), workarounds

    I upgraded from Vista Ultimate to Windows 7 on my Dell XPS M1530 after religiously uninstalling everything that Microsoft Windows 7 Upgrade Advisor even hinted might cause trouble (Fortunately I was able to use a cloned drive with no MS beta SW installed -- no luck otherwise! ).

    Beautiful and stable EXCEPT for the Sigma Tel High Definition Audio CODEC - nothing worked even though Windows said I had the best driver for this device. DELL driver download site said otherwise so I ran their recommended R190517.EXE to install Driver Version 6.10.0.5866 (2/15/2008) - for Vista, which is all Dell tech support vouches for now (except on new machines with Windows 7 preinstalled).

    This driver upgrade fixed everything EXCEPT the headset-microphone jack input: The Jack Setup pops up with "Microphone" pre-selected instead of the correct question-mark selector, but it's clear from exhaustive analysis (going through the Manage Audio Device settings and corresponding application settings, e.g., Skype 4.1->Audio-Settings->Advanced Options) that even if you re-select "Microphone" in the Sigmatel Jack popup, all you've really accomplished is to turn off the notebook's built-in Microphone Array. At least you can unplug the mike and still use your headset with the built-in microphone array.

    Another option (for the all-headset purist with background noise) is to use a USB headset (digital i/o with built-in audio CODEC), or a USB adaptor that's compatible with your 3.5 mm audio-jack headset (pay attention to whether the mike jack is stereo or mono); at least I can vouch for the iHome Lifetalks USB foldable headset that I picked up for this test. It includes an audio headset with two 3.5 mm stereo plugs and a USB-adaptor whose mike jack does NOT work with the mono-mike-jack headset that I was using with Vista.

    That's about it for now. Otherwise I am happy as a clam with Windows 7, using Acronis True Image 2010 for cloning and backups (leaving True Image 2009 installed wrecked an earlier upgrade attempt just as Upgrade Advisor promised:).
    --When I plugged in my Windows Mobile phone to a USB port the Sync Center "driver" (replacing the pre-upgrade uninstalled Windows Mobile Device Center 6.1) was automatically downloaded and installed.
    --Ubuntu 9.10 is running on a (free) VMWare Player 3.0 virtual machine fully integrated with Windows 7 (full windows, shared folders and devices, cut and paste across guest-host). Player's Easy Setup option to create a new VM from the Ubunto-iso image in the virtual CDROM is amazing (Look Ma, almost no hands); you can even specify how many CPUs you want it to use.
     
  10. astavee

    astavee New Member

    Joined:
    Dec 21, 2009
    Messages:
    2
    Hi everyone. I had the same problem with my XPS1530 after I installed Windows 7 32bit. Fortunately, I can skype n voice chat since I bought logitech headset which came with usb connection. What really amaze me, this line in problem doesn't occur when I switch to Windows 7 64bit.
     
  11. leoman

    leoman Well-Known Member

    Joined:
    Dec 26, 2010
    Messages:
    2

    Here is the link to download correct driver for it to fix issue from dell: (even this driver is suport for windows vista but it does works for windows 7, after installation you must restart the computer to make it work:

    Drivers and Downloads

    NOTE: AFTER downloading the file done, you should right click on the download file and click on property then select compatiblility then force it run with windows vista then put the check in the box run as adminstrator also then it's ready to run installation.
     

Share This Page