6gb Corsair Dominator DDR3

Discussion in 'Windows 7 Hardware' started by Aden, May 15, 2009.

  1. Aden

    Aden New Member

    Jan 27, 2009
    Likes Received:
    Hi guys,

    Recently upgraded from Build 7000 32bit to Build 7100 64 bit. Dont ask me why i had 32 bit installed on my system haha. Well anyway. im using the Gigabyte EX58 and have all 3 ram sticks in correct slots but when i go into system properties the space were its supposed to say how much ram i have its just a blank spot. Doesnt say total ram or available ram.

    I did a msinfo32 check and sure enough it detects it all, also when i do alt cntrl delete it detects the total ram there also.

    Im getting no errors, all seems in perfect order just the blank spot in properties window. Is this a bug or has somthing gone wrong? Ive tried everything, even going through every single menu in the bios incase there was somthing wrong, also tried all 3 sticks in work pcs and also 3 other ram sticks in my motherboard all is in functioning order.

    My system specs are
    i7 920
    Gigabyte EX58
    6gb Corsair Dom DDR3 1800MHZ
    Geforce 9600GT
    1tb Western Digital Storage
    80gb Western Digital Sytem drive.

    Cheers in advance
    - Aden Priest
  2. sysmai

    sysmai New Member

    Mar 1, 2009
    Likes Received:
    Run the newest CPU-Z if that detects it, then you are using it. Good luck

Share This Page