Ad hoc network problem

#1
Hello, I have an issue with ad hoc networking in windows 7.

Basically i am trying to ad hoc network with my iphone so i can share my laptops ethernet internet thru wireless to the iphone.

This was not an issue under vista, it worked fine. I think maybe it even use to work on windows 7 for me... but im not 100% sure.

Im now using build 7100.

Basically i have enabled ICS on the network adaptor. Then created an adhoc network on the wifi. Then connected to the ad hoc network. The phone is wirelessly connected. However windows 7 is dispplaying "waiting for users" under the wireless ad-hoc. Also cannot ping or sftp into the phone or access the computers internet from the phone. (Although i can partially sftp into it, i get a welcome message then a timeout), but doesnt reply to pings.

This worked perfectly under vista and i think it may of previously worked for me on windows 7.

I will include a list of the settings.

LAN on DCHP
134.219.152.162
255.255.252.0

Then wireless connection on DCHP, As i said the iphone is connected and has been assigned
169.254.194.40 and 255.255.0.0 on dchp.

However the wireless on the computer displays waiting for users and "not connected" in the adapter page.

Hope i have included enough information here?

any ideas? thanks
 


#2
dammit. please ignore this thread completly.

Just managed to adhoc windows 7 and connect via ubuntu using ICS. So the problem lies with the iphone not with windows 7, should of checked this beforehand.
 


#3
Maybe... But I am having the exact same problem as you. In Win7 it does exactly what you described. The same laptop I have dual booting though and when I boot it to vista it connects to the iphone just fine and I can get on the internet. I don't know what to try next. I am thinking it is some IP setting buried way down in the advanced configuration somewhere, but the things I have tried have yet to work.
 


#4
just tried on vista and it worked fine as you say.

However my computer running ubuntu can connect via windows 7 ics perfectly fine.
So yes this is still a windows 7 problem.

I notice than Vista assigns the wireless adapter the address 192.168.0.1 when ics is enabled.

The iphone then picks up the following under vista on DCHP

ip 192.168.0.x
255.255.255.0
router 192.168.0.1
dns 192.168.0.1

However windows 7 does not assign anything to the wireless adapter, and gives the iphone a 169. ip with a 255.255.0.0 subnet instead. and no router or dchp.

I attempted to manually assign the wireless adapter on windows 7 to 192.168.0.1 and also manually assign the correct ips and dns etc in the iphone.

But still the same problem. You seem to be correct in there being some deep level problem i think. Strange though how i can use the windows 7 ad hoc network on ubuntu but not the iphone.

also are you using RC or beta? if your using RC was it from an upgrade or a clean install? and also do you know if it worked on beta atall? as i cant remember.
 


Last edited:
#5
I had beta and it worked just fine. I wiped the partition before I installed RC1 so it was a fresh install.
 


dam89

Honorable Member
#6
I had same, i have an atheros ar5007eg wireless adapter, i installed xp drivers under compatibility mode. I've had no problem since
Check your driver versions.
 


#7
also have atheros ar5007eg. however no cpu virtulisation in laptop bios so cant do that.
 


dam89

Honorable Member
#8
right click the installer Properties>compatibility. -> run this in compatibility for windows xp sp2.
 


#9
bammmmmmm. Cheers for the tip.

fixed it. No need for virtulisation to install the driver.

This is what i did.
Atheros driver
http://download.boulder.ibm.com/ibmdl/pub/pc/pccbbs/access_ibm_br/7kcna5ww.exe

Then device manager > update driver > select disk > select extracted dir > then select Atheros AR5007EG from the list.

works perfect :)
 


dam89

Honorable Member
#10
No problemo
 


#11
It worked for me too. Awesome! Thank you.
 


dam89

Honorable Member
#12
your welcome
 


#13
in windows 7 build 7000 ad hoc .... IPhone can conecct successfully but ...
the same problem with my laptop with windows 7 build 7100 ad hoc... IPhone can not connect to it successfully
my laptop is VGN-12MN and the wireless device is Atheros AR928X Wireless Network Adapter
 


dam89

Honorable Member
#14
if you have read any of the older posts you may have tried this, install old xp drivers in compatibility mode for xp Sp2. It seems to work for my two laptops which both use atheros wireless
 


#15
I try as you told me but still the same problem can not connect successfully
 


dam89

Honorable Member
#16
have you checked your iphone, i remember a post from another forum to that respect
 


#17
as I say my iphone no any problem with winxp with win7 build 7000 on my laptop and also with win 7 build 7100 on another laptop

I try to install another driver for wireless from internet and it is work for like 3 mintues then dissconected, I try again the same !!!
 


#18
Change Security Type

I was having the same issue and found that using WEP instead of WPA2 (the default) worked without a hitch.
 


#19
link is bad

the link for 7kcna5ww.exe is dead. I've searched all over for ths file, everything is dead.
Can anyone tell me where I can get this file right now?
 


#20
Hi, I am having a similar issue while sharing of internet connection across adhoc network between Iphone and Windows 7.
I used to successfully use it while I had Vista and was able to use the Vista's internet connection from iphone. But in Win7
the iphone detects the wifi network, connect to it, but the internet doesnt work.
I have Intel Wifi Link 5100 AGN.

I donot think there is a problem with my Iphone as I used to do this while I had Vista for several occasions successfully.

However I was able to connect Win7 and WinXP same way.

I think there is some problem with Win7.

Anyone have any suggestions.........
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.