Cannot see self-signed certificate in Windows 7

#1
I have a server with a https page with a self-cigned certificate. I start IE as administrator, press the view certificate and install the certificate and put it in the thrusted root certificate store(like described in this page). Import successfull, but I cannot see the certificate and I still get the certificate error on next visit.
This worked in Vista.
Any ideas?
 


#2
Hi Milzit,

Did you find any solution on this problem? I got exactly the same problem, have tried various approaches but none seems to work, including the Vista approach.
The certificate is never showed in the list over "Trusted root certifacates".

Best regards
 


#3
Hello
No, I have not found any solution for this..
 


#4
Thats a shame, Im wondering if any have solve this, it seems to be a big problem around on the internet.
 


#5
I have a server with a https page with a self-cigned certificate. I start IE as administrator, press the view certificate and install the certificate and put it in the thrusted root certificate store(like described in this page). Import successfull, but I cannot see the certificate and I still get the certificate error on next visit.
This worked in Vista.
Any ideas?
Hi.

Spent a frustrating half hour or so trying to do this too but stumbled across a fix that worked for me.

Install the certificate as usual but make sure you tick option to show physical stores in the Select Certificate Store dialog. Then expand and select Local Computer in Trusted Root Certificate Store.

Worked for me :) good luck
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.