Can't get Windows 7 installed from USB

D0M1N13

Senior Member
Hi forum

This topic might already be touched on here but I couldn't find anything about it.
I downloaded from the internet AIO Windows 7 ISO. I burned the ISO with RUFUS on a NTFS USB. When I inserted the USB into my computer and tried to boot from the USB it gave an error saying something that it can't find NTFS drivers. Somewhere along those lines. So I googled for further information and found out that the file system on the USB is supposed to be FAT32. So I tried to burn the same ISO with FAT32 but it wouldn't let me because install.esd is 4.2GB and unfortunately FAT32 can't transfer anything above 4GB. So I googled again and found out that I would need to split the install.esd into smaller parts and then I could burn the ISO. So I did that but it's not letting me boot. I entered my UEFI BIOS and went into boot menu and put the USB to boot first. Even though I did that, it's not even booting or anything. It just goes into the OS like there isn't an USB. I disabled secure boot. Nothing still. May someone help me with this? I'm going mad here.
 

Neemobeer

Windows Forum Team
Staff member
Windows 7 is end of life next month, so you should really be installing Windows 10. You can just install Windows 10 and use your Windows 7 product code they're pretty much all valid on Windows 10
 

RuskinF

Member
Don't install Windows 7. Instead, install Windows 10.
Here is why:
Performance tests have shown that Windows 10 is faster across the board than earlier versions of Windows. Bear in mind that Microsoft will update Windows 10 regularly, though, while Windows 7 is now essentially frozen in its current state after 'mainstream' support ended in January 2015.
 
Top