COM Surrogate Windows 7 64bit

#1
I have installed Windows 7 Ulimate 64 bit three times, and its the same thing all the time. I try to open a picture to preview it, it says COM Surrogate has stopped responding. Also I have tried installing programs like google crome which works the first time i opened it, but now it just says it stopped working and won't open or uninstall, the only I can pretty much do is go on IE and use ccleaner, speccy :/ What could I do to fix this. The computer specs are:
OS:
MS Windows 7 Ultimate 64-bit
CPU:
AMD Turion X2 RM-72 Griffin 65nm Technology
RAM:
3.0GB DDR2 @ 336MHz (5-5-5-15)
Motherboard:
Gateway (Socket M2/S1G1)
Video Card:
ATI Radeon HD 3200 Graphics
Hard Drive:
244GB Hitachi Hitachi HTS543225L9A300 ATA Device (SATA)

I really have no idea what to do, I can see reinstalling windows doesn't help, so if someone could shed some light on my situation. Thanks so much.
 


Captain Jack

Extraordinary Member
#2
Hello and Welcome to W7F !

I believe I gave you suggestion in the other forum. But still tell us what is the DEP settings set to.
 


#3
Hmm....

Try this;


  1. Click Start.
  2. In the Search Box type CMD
  3. Right click on the Command Prompt icon.
  4. Click Run as Administrator.
  5. In the Command Prompt black window type: regsvr32 %windir%/System32/vbscript.dll and hit Enter.
  6. The system will return with the following message: DLL Register Server in C:\Windows\System32/vbscript.dll has been successful.
  7. Now click Start.
  8. Click Computer on the right.
  9. Click Folder and Search.
  10. Click the View tab.
  11. Tick Always show icons never thumbnails.
See if this solves the problem.


Regards....Mike Connor
Ok well i tried this and well it didn't work, still getting COM Surrogate error, I also tried DEP settings, i try to add the dllhost.exe, but i am getting the error "You can not set DEP attributes on 64-bit executables" I don't get how I would turn DEP off though, there is only two options for turn on for essential widows programs and services or turn on for all programs and services....

Is there any other hope?? Also IE 32bit doesn't work on here no more only 64-bit one?? Google still won't load. I can watch videos and listen to music, but I can't look at photos, photos give me the COM Surrogate error :/

(This is what i posted at other forum)
 


Captain Jack

Extraordinary Member
#4
Change the DEP setting to "Turn on for essential widows programs and services" and reboot the System. Then from View Panel go to "Folder Option" there select "Always show icons never thumbnail" then test it.
 


#5
Ok well i tried this and well it didn't work, still getting COM Surrogate error, I also tried DEP settings, i try to add the dllhost.exe, but i am getting the error "You can not set DEP attributes on 64-bit executables" I don't get how I would turn DEP off though, there is only two options for turn on for essential widows programs and services or turn on for all programs and services....

Is there any other hope?? Also IE 32bit doesn't work on here no more only 64-bit one?? Google still won't load. I can watch videos and listen to music, but I can't look at photos, photos give me the COM Surrogate error :/

(This is what i posted at other forum)
For Windows 7 64 Bit go to the directory Syswow64 for adding the dllhost.exe to the DEP-list. Worked for me. Greetings
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top