"Could not reconnect all network drives" Problem

Discussion in 'Windows 7 Networking' started by Dajad, Feb 28, 2009.

  1. Dajad

    Dajad New Member

    Joined:
    Feb 27, 2009
    Messages:
    18
    Likes Received:
    0
    Hello all:

    I've found several others having the same problem as I on this and other forums but no answer yet.

    I have a home network that includes an XP-based home server of sorts. I hang my Drobo off that server and share it to my home Network. On all my other PC's I access it as my "N" drive (N for network). This has worked fine through XP, Vista and even Windows 7 installations on the same PC (discussed below) for some time. But now whenever I boot up my system with Windows 7 I get the

    "Could not reconnect all network drives"

    error every time I boot.

    When I click on the "N:" drive through Windows Explorer or a link on the desktop W7B asks me for a userid and password. I can literally type anything in the Userid field (complete gibberish works) and add a password or not. When I do, my shared drobo connects as N: (I refer this as a manual connection for the rest of this post). Thereafter all my apps can use, see, change files on N:\ . All is golden until my next reboot.

    It's important for me that the system automatically connect because a dozen or so of my apps routinely interact with my "N:" drive. For example I use the program Second Copy to automatically backup several directories and drives across my network to my Drobo on N:. That app won't work until N: is connected. My iTunes library is situated on my Drobo. iTunes won't see my iTunes library and gives error messages until I manually connect the N: drive and on and on and on from app to app. My N:\ drive is my data repository for all my devices.

    Here's the rub. When I first installed W7B (on the exact same PC) I installed it as an upgrade to my then current Vista x64 installation. After that upgrade, I had no problem. That N: drive auto connected on bootup just as it had when I was running Vista on the same PC and just as it had when I ran XP before on the same PC.

    Subsequently I chose to do a fresh W7B install on the exact same PC that I had previously installed the WB7 as a Vista x64 upgrade. That's when this problem arose.

    Despite dozens of hours of research and tinkering I have NOT been able to get my shared N:\ Drobo drive hosted off an XP computer to automatically connect when I boot up. I have changed NOTHING on the XP server. I have changed nothing on Drobo (though I did try "Unsharing" and "Resharing" the drobo on the XP server to reset / update directory permissions - this did nothing). My other networked Vista/XP PCs continue to access it as their N: drive without incident. It is only my clean-install W7B PC (and a tablet PC I did a fresh W7B install on) that cannot automatically connect to that shared network drive on boot.

    What is truly strange is that on this EXACT same PC the share worked flawlessly (as always) after an upgrade from Vista x64, but when I did a fresh/clean install on the EXACT same PC, the problem raised its head.

    - All PC's on my network are on the same workgroup.
    - The problem persists whether or not I have a homegroup activated
    - I have no problems accessing shared drives BETWEEN PCs running WB7
    - I have no problem accessing the shared Drobo on the XP PC from other XP/Vista PCs
    - all pcs are behind a NAT router so firewalls are turned off
    - no anti virus software is running on any PC (not that anti-virus software ever caused an issue here before)
    - I have tried changing most of the Advanced Sharing Settings in:

    Start --> network and sharing center --> change advanced sharing settings

    including turning on and off 'password protected sharing'

    - When I mapped my network drive to N:\ I did it using the proper '\\server\drobo' naming convention
    - I note that when I click on the "Browse..." button my networked XP server does not show up as an available network device (though I can still connect to it by manually typing \\server\drobo
    - I, of course, always check the 'Reconnect at logon' checkbox on the "Map Network Drive" dialogue box
    - Whether or not I check the "Connect using different credentials' checkbox on the "Map Network Drive" dialogue box makes no difference.
    - Under the 'Computer' item on the left side of Windows Explorer, the N:\ drive shows up (before manual connection) with a red x through it.
    - I note that under the 'Network' item on the left side of Windows Explorer, only W7B PCs show up even though W7B shows all network PC's even XP PCs in the Network Map
    - Clicking on the 'Remember my credentials' checkbox on the "Enter Network Password" screen when I manually connect makes no difference - WB7 clearly doesn't remember them.
    - NOTE: I do NOT login with the same userid and password on the server and on my WB7 machine. I never had to before (including when WB7 on this PC was an upgrade from Vista) so I can't imagine that that is the problem. Note, all other PCs on my network access the shared Drobo from ANY userid on any other PC

    Control Panel --> Network and Internet --> Network Map,

    (after manually connecting N: by clicking on it, that is)

    I am at a loss for how to proceed. Any suggestions?

    ...Dale

    ------------------------------------------------------------------------ UPDATE ------------------------------------------------------------------

    EUREKA IT WORKS!

    Folks, after spending the better part of a second day I solved it. Though I don't know how. About an hour after giving up today, after a reboot, I noticed N:\ was connecting. I really don't know how/why.

    The last thing I did (as mentioned in parenthesis above)
    (though I did try "Unsharing" and "Resharing" the drobo on the XP server to reset / update directory permissions - this did nothing)
    was to copy files from N: (after a manual connection) to my C: drive. When I connected that last time it asked me, as it does/did sometimes, though not always, for a userid and password. I entered the server's userid (different from my W7B's userid) and password and checked the 'remember my credentials' field, all as I had many times before).

    Funnily enough the system crashed when I was trying to do that transfer of files which lead me to reboot (pressing the power button to shut down and restart). The next time it started I didn't even notice that the N: had connected at first (I was on to a new project and wasn't paying attention to the boot process). About 15 minutes in I noticed there was no red x beside the mapped N:\ drive in Windows Explorer as there always had been in the past. Since I was pretty sure I hadn't done a manual connection I decided to reboot and test ... Lo and behold, N:\ automagically connected at boot and I don't know why.

    I created a save point so I can get back here if something goes awry. For now I'm just happy it works. I don't know how to replicate it.

    I NOTE THAT THE PROBLEM STILL SUBSISTS ON MY TABLET RUNNING W7B, so I am now confident the problem has nothing to do with how my XP server is configured. It has something to do with the way W7B is configured. If I solve this problem on my tablet I'll write another post. Hopefully by then I'll have isolated what worked.

    ...Dale
     
    #1 Dajad, Feb 28, 2009
    Last edited: Mar 1, 2009
  2. robmoll860

    robmoll860 New Member

    Joined:
    Mar 1, 2009
    Messages:
    4
    Likes Received:
    0
    Cannot reconnect to all mapped drives in W7B

    I had all the same symptoms you had. I found that the problem was with Windows Firewall. There are about a million settings in there and I have no idea how they work, so I just turned WD off completely and viola, no more connection problems. I suppose I could work my way back through the settings to see if I can figure out exactly which setting it is, but I am using a home network and only want to connect to internal storage drives so there is little chance of invasion. If you figure out which setting it is please let us know. I think there are alot of us that are having this issue.

    RLL
     
  3. Dajad

    Dajad New Member

    Joined:
    Feb 27, 2009
    Messages:
    18
    Likes Received:
    0
    Rob,

    I'm unclear from your post whether your problem was Windows Firewall or Windows Defender (WD). Windows Firewall is and has always been shut-off on all my PCs (Vista, XP and W7). However, Windows Defender is and always has been active on all my PCs (Vista, XP and W7). Since my primary PC is now connecting and I never futzed with firewalls or Windows Defender I can say definitively in my case that the issue was not either of them.

    I have a hunch I want to test out on my tablet when I get a chance ... If/when I get the tablet (with W7B installed) connecting to my Drobo/N: drive off my XP server I'll update this post with as good a reason as I can figure out at the time.

    ...Dale
     
  4. robmoll860

    robmoll860 New Member

    Joined:
    Mar 1, 2009
    Messages:
    4
    Likes Received:
    0
    Sorry, you are right - my message was unclear. All my issues were caused by windows firewall. Once I turned that off I had no more reconnect problems with any of my mapped drives. I have windows defender running, same as you. You may want to double check and make sure that WF is turned off on the machines you are using. It seemd like a pretty easy fix and is worth checking twice. If it is turned off as you stated, then I wish you luck finding your solution. Sorry I wasnt more help.
     
  5. Dajad

    Dajad New Member

    Joined:
    Feb 27, 2009
    Messages:
    18
    Likes Received:
    0
    Hey Rob:

    I'm certain ... believe me, Firewalls is something I checked pretty early on. And, as a rule, I NEVER turn firewalls on (or more accurately I now shut them off as a first thing when I install an OS) inside my own home office because its just me here and I feel my NAT router protects me from the outside world well enough.

    But, no apologies ... I think its important that we collect all the possible solutions on this forum because clearly people are having this problem for differing reasons. I tried to list all the things I did in the original post (one of which was to make sure firewalls were off). For the next person that comes along with the same problem, hopefully by going throug the list thye'll solve it - includig those that have the firewall issue you had.

    ...Dale
     
  6. Sampler

    Sampler New Member

    Joined:
    Oct 30, 2009
    Messages:
    2
    Likes Received:
    0
    I have a similar problem.

    I have an XP x64 server with several shares and my Vista Ultimate x64 HTPC in the living room always has the same error when you boot up:
    "Could not reconnect all network drives"
    yet when you open explorer all the drives are listed with the display bar showing how full they but a red x on them to say disconnected - clicking them though goes through to the share and browsing back the x is gone on that particular share but remains on other shares connected to the same machine.

    My desktop has just started doing this too - I upgraded to win 7 recently (signature (ultimate) x64) and everything was fine - a powercut during an office install though left me unable to re-install office after trying all kinds of registry fixes and clean-ups so I wiped the system and rebuilt it and now every time I login I get the same error and behaviour as my HTPC on my main desktop - all shares are shown as connected (as they have the content bar) but with an X and can connect straight through once clicked.

    Windows firewall is disabled on all machines (like the poster above the router should do a job of stopping anything getting in). My XP machine in the bedroom and extension do not exhibit this behaviour nor does the girlfriends machine (Win7 Ultimate).

    I find it quite bizarre that everything was fine prior to the rebuild and now, without fail, the error occurs on every boot.
     
  7. stueycaster

    stueycaster Millennium Celebration Award Winner
    Premium Supporter

    Joined:
    Feb 5, 2009
    Messages:
    1,519
    Likes Received:
    53
    This is a guess on my part. I have a 2 computer network with W7 on my desktop computer and XP Home on my wife's Laptop. For one reason or another sometimes they have a hard time connecting.

    I'm not sure but I think this is the way it works. Computer networks always have a "Master Browser". One of the computers will keep track of all the shared drives and folders on that network. In a two computer network the other one won't try. The duty usually falls on whichever one is on the most. The Master browser on a network checks to see what's going on in the network on a time schedule. From what I read they check about every 15 minutes or so. If one computer is on and another comes on the network the one that is already on has assumed the role of Master but it won't know about the other one til it makes it's check. Therefore when a computer first comes on it can't find the network because it's relying on the other computer which doesn't know it's there yet.

    I think it's pretty much normal for a network to take a little time to establish it's self.

    I've always been able to jump start the network by doing this. In the Address Bar of the explorer window type in " \\(the other computer's IP Address) ". After that it stays working til the next time my wife turns off her Laptop.
     
  8. DavidGLyons

    DavidGLyons New Member

    Joined:
    Nov 6, 2009
    Messages:
    8
    Likes Received:
    4
    Hi, I saw your post before I found a solution which I posted on the QNAP forum. I hope it helps with your tablet:

    OK, I have finally cracked some of this one (I think). (Thanks Loekf for your post, I didn't see it until I found my way to the following which you hinted at in your post).

    Whenever I mapped the drives in Windows it asked for credentials. However these credentials were then created with a persistence type of "Logon session" which is not editable.

    Having discovered this, I restarted windows and then before supplying the credentials to reconnect the mapped drives, I added credentials explicitly as follows:

    1. Goto Control Panel -> All control Panel Items -> Credentials Manager
    2. Next to the heading "Windows Credentials" click on the link "Add a Windows credential".
    3. Enter the name of your NAS server ("NAS" in my case) and the appropriate credentials.

    The result is an entry that has a persistence type of "Enterprise". This seems to do the trick. (I then restarted windows)

    Unfortunately the QNAP finder still can't find the NAS and I think that this is another symptom of the underlying problem that is preventing iTunes from finding the media server.

    BTW. In order for windows to resolve the server name I found that I had to create an entry in the "Hosts" file located in "C:\Windows\System32\drivers\etc". There's probably a better way to do this, but I don't know what it is. I also suspect that this is another symptom of the underlying invisibility problem, but I'm not sure.
     
  9. Dajad

    Dajad New Member

    Joined:
    Feb 27, 2009
    Messages:
    18
    Likes Received:
    0
    Thanks David.

    Ironically, just this week I finally migrating my entire network, including my server, to Win7 so I no longer need this solved. But I'm sure your answer will help others.

    ...Dale
     
  10. Baubau

    Baubau New Member

    Joined:
    Dec 15, 2009
    Messages:
    2
    Likes Received:
    0
    Hi David,

    I've long been bugged by this "Reconnect" problem since I used XP years ago. Tonight I followed your advice to simply add an entry in Windows Credential Manager on my Windows 7 laptop. Then all of a sudden all mapped drives are reconnected at next reboot.

    Thank you so much.

    Baubau
     
  11. fbsoft

    fbsoft New Member

    Joined:
    Apr 17, 2010
    Messages:
    2
    Likes Received:
    0
    [Solved] Could not reconnect all network drives

    Hy guys,

    After a short search, found the problem to pin point it at. As some of you mentioned above, it's the windows firewall that acts up on reconnection... what you need to do is not al that complex and hard ...
    Go to Control panel -> windows firewall -> Advanced settings ( on your left ) -> Outbound Rules ( on your left ) -> Search in the list the next items and " Enable Rule " ( on your right )

    File and Printer Sharing (Echo Request - ICMPv4-Out) --enable all of them ( usualy 2 or 3 entries ) ... you can enable the ones of IPv6 as well if your lan uses that protocol ;
    File and Printer Sharing ( NB-Name-Out ) -- this is that Samba file sharing, port 137 -- enable all of them ;
    File and Printer Sharing ( NB-Session-Out ) -- Samba again , but on 139 --enable all of them ;
    File and Printer Sharing ( SMB-Out ) -- again Samba but on 445 --enable all of them .

    After this just a small reconnect on the previously connected drives ( double click in my computer ) reboot and everything will be ok.
    This will work if you already have the user and passes set for those specific shares or they are set as anonymous, or Everyone, recently known, as M$ decided to rename it.

    P.S. do feel free to poke around with other settings but only if you know what you're doing, else keep away as you may unwillingly do a lil damage to win firewall ;D

    That's that, have phun
     
  12. bluntobjekt

    bluntobjekt New Member

    Joined:
    Sep 22, 2010
    Messages:
    2
    Likes Received:
    0
    You're a gem! That solved my problem. Thanks for posting this! My issue was actually with a USB drive that is connected to a Cisco Linksys WRT610N router (cheap NAS essentially). That drive is mapped as M: on my Windows 7 ultimate x64 machine. Every time I'd reboot I would have to re-enter my credentials to connect to M:, even if I checked the 'Remember Credentials' check box. I went into Credential Manager on the Win7 machine and deleted the entry that was automatically created for \\WRT610N. I created a new entry with the same information, but (as you said) it created it with 'Enterprise' persistence instead of "Logon Session". An now I can reboot and not have to re-enter my credentials to connect to M:. Thanks again!
     
  13. babeliak

    babeliak New Member

    Joined:
    Mar 10, 2011
    Messages:
    2
    Likes Received:
    0
    WOW,

    thank you David, today I was set up to find solution to this reconnect problem, and YOUR post helped me to do it.

    GR8 MAN!:applaud:
     
  14. st33x

    st33x New Member

    Joined:
    Mar 17, 2011
    Messages:
    2
    Likes Received:
    0
    Yes!! it works for me too. thanx $1.000.000 for this solution!
    (for the frenchs, like me, if it can helps,
    the "Credential manager" can be found in the "control panel / Gestionnaire d'identification"
     
  15. DaveC

    DaveC New Member

    Joined:
    Apr 28, 2011
    Messages:
    2
    Likes Received:
    0
    I've had this problem for the last couple of weeks. Read the post above about changing the Credentials and it worked like a charm.
    BTW - my system has never had a problem finding my QNAP NAS, so I don't know what to suggest in return. Sorry, and good luck!
     
  16. marierm

    marierm New Member

    Joined:
    May 17, 2012
    Messages:
    2
    Likes Received:
    0
    I spent 3 hours troubleshooting this problem on Windows 7 Home Premium, writing batch files, turning off firewalls, double-checking syntax, and then I tried this credential fix and it worked! Thank you!
     

Share This Page

Loading...