DDI 10.1 in DXDiag (with dx11 card) - Hotfix will NOT WORK! -solved-

Discussion in 'Windows 7 Help and Support' started by WirlWind, Oct 10, 2014.

  1. WirlWind

    WirlWind New Member

    Joined:
    Oct 10, 2014
    Messages:
    2
    Likes Received:
    0
    Howdy guys,

    I've spent the last few days scouring the internet to resolve an issue affecting my laptop. The issue came about while trying to play Shadows of Mordor, it announced that "your device isn't DX11 compatible".

    So after checking the specs of the 640m, I noted that it does infact support DX11.

    It would seem that the intel 3000 onboard chipset is causing the issue (As these apparently only support 10.1). I've tried launching the game with the 640m to no avail (via the right click menu and the drivers both).

    Then I discovered the Win 7 bug involving the DXdiag not recognising that your card could do anything past 10.1 and I went to install the hotfix, excited to finally get the game going.

    I checked that the version was correct (I run home premium x64) and tried to install it only to get a "This update isn't applicable to this computer" message. (for hotfix: /kb/975243)

    I've run into quite a few people with this issue and no solutions anywhere. People usually just say "You're doing it wrong" and not addressing the fact that the patch wasn't working.

    I'm not 'doing it wrong'. I meet the requirements, I installed the correct version of the hotfix and my graphics card supports dx11. It's the hotfix that is the issue in this case. Does anyone have any reasons why it would say that despite the fix not already being applied? Is it an issue with the "Optimus" tech the laptop uses to swap video cards?

    At this point, I'm considering reinstalling windows with hopes of avoiding the onboard entirely, but that's last resort as I don't feel like spending the next day transferring everything off the HDD for backing up (doing an upgrade install has led to issues for me before, so I prefer to do a proper reinstall.)
     
  2. WirlWind

    WirlWind New Member

    Joined:
    Oct 10, 2014
    Messages:
    2
    Likes Received:
    0
    Nevermind, seems doing a windows update fixed the issue. I'm assuming that the hotfix saw itself in the update queue and so said it wasn't going to work because it assumed I was going to download it next scheduled update.

    Game works now, so if you have the same issue as me, simply try updating.
     

Share This Page

Loading...