Windows 10 Directx 9.0 won't download


New Member
Jul 21, 2019
I have a Windows 10 laptop. I downloaded the Sims 2 on it, but I need Directx 9.0 for that. So I downloaded Directx 9.0 from the microsoft website. I ran through the installation process and everything was fine. But when I tried to start the Sims 2 again, I got the same error, telling me I needed Directx 9.0.
So I opened 'run' and typed 'dxdiag'. It said I had Directx 12. I've tried to download Directx 9.0 multiple times but it still says I have Directx 12.

Here's some info;
System: Windows 10 Home 64 bits (10.0, build 17134)
Language: Dutch
System manufacturer: Hewlett-Packard
System model: HP Pavilion dv7 Notebook PC
BIOS: InsydeH2) Version CCB.03.61.09F.21
Processor: AMD A6-3410MX APU with Radeon (tm) HD Graphics (4 CPUs), ~1.6GHz
Memory: 6144MB RAM
DirectX: DirectX 12

Please help me, I've been trying to fix this for such a long time and I have no idea what to do!

I think the issue is, you need to enable direct play in programs and features.
Top Bottom