Epson Driver Problems

#1
Hi All,

Having problems loading drivers for Epson BX300F All in One printer. Scanner software loads but printer software (6.61) does not want to play. I have contacted Epson but no response as yet.

Any suggestions

Kindest regards

Johnboy
 


reghakr

Essential Member
#2
Johnboy ,

On Epson's site. please try the following link

Epson Stylus Office BX300F

Or here:
Epson Stylus Office BX300F EasyPrintModule driver v.3.1b download for Windows Vista, Windows Vista 64-bit, Windows XP, Windows XP 64-bit, Windows 2000

This also occurred on my Windows 7 machine with a Lexmark X4270, driver not installed, but scanner worked fine.

Are you using the Vista driver?
 


#3
Hi Reghakr,

Thank you for the links ..... I had tried downloading from Epsons site but I tried again with your links. I had to configure the usb port manually rather than allowing the wizard to configure.........thanks again for your response.

Kindest regards

Johnboy
 


reghakr

Essential Member
#4
No problem,

Glad you got it:)
 


#5
Hi All
sorry to say but i am have same problems with driver for EPSON STYLUS PHOTO RX500
Running Windows7 but canot seam to get any driver to work ,any clues if you can help
thanks
 


reghakr

Essential Member
#6
Hello and welcome,

I did locate software Epson EasyPrint v3.10
Not sure whether you checked this link, but a Vista driver is available:

Unfortunately I have only located a XP driver.

When installing a new driver, make sure you go to Control Panel, Device manager and remove the printer first. Also make sure it's removed under Start > Devices and Printers

Also, you could go to the Start > Devices and Printers and follow the steps to see if Windows can locate a driver.
 


Last edited by a moderator:
#7
Many Thanks for your help, i have done all that ,but today i have had a reply from epson (uk)
saying that new WINDOWS 7 EPSON DRIVERS will be able to download in few months
Thanks Again Regards
 


reghakr

Essential Member
#8
It was a good idea to e-mail them,

I've stated that in a couple of my posts, should use it more often:)
 


#9
Drivers for Epson RX500 not working

I see these post are from before the release of Windows 7... I installed this week and everything is working great, except for my Epson RX500 printer. Get message that the drivers are being installed, but that fails. Does not give a reason, says to contact the manufacturer. The scanner driver installs fine and the scanner does work after the upgrade...

Windows website says that the RX500 is compatible, gives a link for the drivers. this link takes you to the Epson website that says the printer is compatible, but driver is only available from windows install, not from epson...

Does anyone have any suggestions??? I thought we weren't supposed to have these problems with 7... this ain't no better than vista for me right now...
 


lko

New Member
#10
Problems with IE8 printing - Epson CX7800

Hi,

I successfully downloaded the Win7 driver for the Epson CX7800 from the Epson site, and it generally seems to work fine, but I can't print in IE8 from Google Docs or Comcast e-mail. Firefox works OK in those applications. ( I can't use Firefox all the time, though, because it doesn't recognize the existence of Flash.) This is a brand-new HP computer that came preloaded with Win7, by the way.

So... is the problem the driver, IE8, or - ?? Thanks for any help,

Linda
 


#11
Hey! :)

Was looking around at the previous replies but saw that some gave suggestions as to fix the problem.

I tried out the solutions you all gave but my scanner still did not work! :(
My printer's working perfectly fine (model: EPSON CX3700) as i've download the printer driver from the epson website, but however my scanner is not working and it refuses to even start :confused:

I hope somebody out there can help me solve this problem :D
i really need my scanner soon!

PS: i'm having windows 7 home edition now.

THANKS!
 


Last edited:
#12
I see these post are from before the release of Windows 7... I installed this week and everything is working great, except for my Epson RX500 printer. Get message that the drivers are being installed, but that fails. Does not give a reason, says to contact the manufacturer. The scanner driver installs fine and the scanner does work after the upgrade...

Windows website says that the RX500 is compatible, gives a link for the drivers. this link takes you to the Epson website that says the printer is compatible, but driver is only available from windows install, not from epson...

Does anyone have any suggestions??? I thought we weren't supposed to have these problems with 7... this ain't no better than vista for me right now...
I downloaded and installed drivers from their website for my Epson SX500W everything works perfectly :)

make sure you get the 32 or 64 bit selection right ;)
 


#13
Sounds like it might not even be an issue with drivers or your computer itself, sounds like the unit.

When you turn it on and off does the light come on in the scanner? Like when it tests itself on start?

Might want to give Epson support a ring if it is still under warranty they might just give you a new one!

My all-in-one printer is working fine! It has the green light on and tests itself on start as you said!
*sigh* :(
I might try ringing Epson up then, thought i could fix it on my own.
Thanks! :D
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.