Windows 7 Games with 8-bit color modes - palette issues

Discussion in 'Windows Games' started by Lazure, Jan 14, 2009.

  1. Lazure

    Lazure New Member

    Joined:
    Jan 11, 2009
    Messages:
    62
    Likes Received:
    2
    It seems any game that runs in 256 colors (Diablo II, Starcraft, Worms: Armageddon, Eternal Fighter Zero, etc) have difficulty rendering their palette properly, resulting in garbled graphics or even unplayable situations. The only workaround I can find so far is to actually kill explorer.exe and remove my taskbar, and launch the game from task manager itself in order to fix the palette issues.

    Some games, however, such as Worms, will not restore after being minimized or alt-tabbed out of, which is another issue altogether; thus I have to kill their processes. I've tried running said games on compatibility modes for windows 2000, windows XP, and windows Vista. I also attempted the compatibility options for disabling themes, disabling desktop composition, disabling DPI scaling, and running in 256 colors. None of these provide any positive aid in fixing these issues.

    In summary, palette issues in 8-bit games seem to be caused by the new taskbar, or perhaps something in explorer in general. Killing explorer.exe results in the taskbar's removal, and fixes the issue in these games. However, if there's a better workaround that doesn't involve removing core system processes, then I would like to know.

    My Specs:
    OS: Windows 7 Professional 64-bit Beta
    MOBO: Intel DG965RY
    CPU: Intel Core 2 Duo E6400 2.13ghz ; 2MB L2 Cache
    RAM: 6gb Crucial DDR2 800mhz RAM PC6400 (2x1, 2x2 dual channel setup)
    VIDEO: 256MB MSI NX8600-GTS OC (NVidia 8600 GTS series) ; Aero enabled.
     
  2. HoLY CoMM@nDo

    HoLY CoMM@nDo New Member

    Joined:
    May 24, 2009
    Messages:
    2
    Likes Received:
    0
    Example screenshot in Windows 7 RC1 Build 7100 32bit (7127 not test)

    Error palette colors screenshot
    [​IMG]

    True palette colors screenshot
    [​IMG]
     
    #2 HoLY CoMM@nDo, May 24, 2009
    Last edited: May 24, 2009
  3. Lazure

    Lazure New Member

    Joined:
    Jan 11, 2009
    Messages:
    62
    Likes Received:
    2
    Currently, the only way to play those games with proper colors is to kill the "explorer.exe" process, which we all know is never healthy :(
     
  4. Realspace

    Realspace New Member

    Joined:
    Dec 25, 2009
    Messages:
    2
    Likes Received:
    0
    I was having this problem, but have recently a found that if you either:
    1) change the personalisation to windows 7 basic
    or
    2) have the personalisation menu open in the background
    then the palette issue is fixed entirely.
    Hope this works for everyone else..

    Yeh, unfortunately though it doesn't seem to help with some other classic games with palette issues, like worms world party and AOE2, if anyone has found anything to do with them, that'd be helpful. Thanks.
     
  5. WalkerA WinTeam

    WalkerA WinTeam New Member

    Joined:
    Feb 5, 2010
    Messages:
    62
    Likes Received:
    2
    Hi friends :)

    In case anyone still cares, or for future visitors, there's a workaround for this issue mentioned in this thread, where a user created a simple batch file to automatically kill explorer.exe when opening the game, and restart explorer.exe when closing the game. Definitely not a permanent solution but something at least :/

    Cheers,

    Walker
    Windows Outreach Team
     

Share This Page

Loading...