Hard Disk ALWAYS running

Discussion in 'Windows Vista Help and Support' started by booeyOH, Nov 28, 2007.

  1. booeyOH

    booeyOH New Member

    Joined:
    Nov 28, 2007
    Messages:
    4
    Likes Received:
    0
    Hello,
    My little hard drive is always cranking away, and often gets up to 55 degrees celsius (which is at the top end of the Hard Drive Manufacturer's allowable operating temperature). So when I go into the Resource Monitor for Vista, it shows the Disk as running at 90%+ Highest Active time a lot of the time, and there are often A LOT of either svchost.exe or SearchIndexer.exe running that takes it up.

    Is this normal?

    Thanks.
     
  2. kjanx

    kjanx Guest

    whats this hdd in, a pc or a 49 chevy??
    is the info a secret??
    are you a spy??
    details man, details!!
     
  3. booeyOH

    booeyOH New Member

    Joined:
    Nov 28, 2007
    Messages:
    4
    Likes Received:
    0
    My apologies, It is:

    120gb Hitachi HTS541612J9SA00 SATA

    in a:

    Dell Inspiron 6400 running Vista Home Premium with a Core 2 Duo 2.0ghz, with 2gb ram and a 256mb Video Card (128mb dedicated).

    My favorite color is orange, and I DO NOT enjoy long walks on the beach.
     
  4. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,840
    Likes Received:
    1,568
    Yup I'm afraid it is.. The drive is always being indexed to help your desktop search. If you don't use this feature much you can disable it but personally I leave mine enabled as after a while it does calm down and doesn't thrash as much. Rumours suggest that SP1 will improve on the thrashing..
     
  5. Trigun[sK]

    how does one go about turning it off?
     
  6. 03hdfatboy

    03hdfatboy Banned

    Joined:
    Feb 8, 2008
    Messages:
    1,416
    Likes Received:
    2
    SP1 does help :D
     
  7. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,840
    Likes Received:
    1,568
    Also turning off 'Superfetch' helps. You can do this via services although if your low on RAM I'd advise against it.
     
  8. 03hdfatboy

    03hdfatboy Banned

    Joined:
    Feb 8, 2008
    Messages:
    1,416
    Likes Received:
    2
    yeah but if you turn SF off it will make your PC a lil' sluggish :eek:
     
  9. I am just about to install SP1 to see if that fixes anything - I also just started getting this problem.
    I left my computer on all night, and in the morning it was still spinning the hard drive. How could it be simply indexing? Or did it stop and go into sleep mode? It didn't seem to be asleep in the morning.
    Does windows defragment in its spare time?

    It is pretty frustrating.

    Matthew
     
  10. davehc

    davehc Microsoft MVP
    Premium Supporter Microsoft MVP

    Joined:
    May 1, 2008
    Messages:
    5,116
    Likes Received:
    301
    Answer to your questions.
    Type Services.msc in the start.
    For the Search, scroll down to "Windows Search" Double click it and mark it as Disabled.
    The facility is not one I use. The only real things I search for are my own files, which is done more quickly, manually.

    Now scroll up to "Superfetch" and disable this.
    This is a controversial feature. It was also in XP but the mechanics of its operation have been altered. You can read plenty on the web about its use but, briefly, what it does is stores your frequently used programs in a subfolder in the "Windows" folder. Every time you start, these shortcuts are loaded into your ram so that the programs can load more quickly. If you disable it, you will find your popular programs, even Firefox or IE, will (ONLY on the first access) load very slowly. After that the normal prefetch system will be in operation and the shortcuts will be in Virtual memory until you switch off. The downside is that it does use a little ram and, of course, does "thrash" (?) you hard disk whilst rearranging everything. ( Every access)

    In your "start" menu you will find the Defrag program. If you click on it, you can disable it or rearrange the schedule. After SP1, you can also select which portion of your computer you wish to defrag.. By default, it runs every Wednesday. It has some intersting geometry, which you can also read up on. Microsoft decided (rightly, in my opinion) that it should be a back ground operation. You will find that, on the first defrag, it will take a re...ally long time. One reason is that it is shadow copying whilst defragging. After that, if you leave it on schedule, I doubt you will notice it's operation unless you are constantly installing new programs.
     
  11. sw23185

    sw23185 Guest

    Thank you, thank you, thank you. I recently installed Vista Ultimate SP1 and this constant drive thrashing (it's been going on for days and days) was getting REALLY old. Disabling the Windows Search indexing feature (and stopping it for the current session as well) seems to have fixed the problem. I can now hear myself think as the computer tower is on my desktop and the chainsaw (oops, I meant the hard drive) was right at ear level.
     
  12. mnaines

    mnaines New Member

    Joined:
    Nov 20, 2008
    Messages:
    2
    Likes Received:
    0
    I actually discovered it is better to stop all those services and set them for Manual Control, so you can use them when you need them but they will shut down when you don't.
     

Share This Page

Loading...