Help on installing with InstallShield

Discussion in 'Windows 7 Help and Support' started by Carpz, Jun 1, 2009.

  1. Carpz

    Carpz New Member

    Joined:
    Jun 1, 2009
    Messages:
    14
    Likes Received:
    0
    Im trying to install my realtek audio driver R2.25 on my windows 7 RC 7100 x86 machine
    everytime i try to run the installer i get an error message:
    and Error (-5004 : 0x80070006 ) has occured while running the setup.
    Please make sure you have finsihed any previous setup and closed other applications.

    Error Code: -5004 : 0x80070006
    Error Information:
    >SetupDLL\SetupDLL.cpp (3093)
    pAPP:Realtek High Definition Audio Driver
    PVENDOR:Realtek Semiconductor Corp.
    PGUID:f132af7f-7bca-4ede-8a7c-958108fe7dbc
    $11.50.0.42618
    @Windows (6000) IE 8.0.7100.0

    I have tried restarting computer, downloading program again, closing all programs.
    nothing seems to work.
    any help? Please.
     
  2. twincitybulldog

    twincitybulldog Senior Member

    Joined:
    May 15, 2009
    Messages:
    42
    Likes Received:
    0
  3. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    that's simply a link to Regcure so you'll have to buy their product.

    Nice scam, this occurs often with driver downloads.

    Carpz, Where duid you l;ocate the driver from?

    Are you using 32-bit or 64-bit OS?

    Did you removre the old drivers from Device Manager before attempting the new install?

    have you tried right-clicking of the file as choose "Run as Administrator?
     
  4. Carpz

    Carpz New Member

    Joined:
    Jun 1, 2009
    Messages:
    14
    Likes Received:
    0
    Hey thanks, yeah i got the dri er from the realtek website and im on a 32 bit macchine with 32bit driver and ive also tried running as admin with still no avail.
    and i have to full version of regcure and it doesnt do anything
     
  5. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    A longshot, but worth a try:

    Go to Start > Rub and type gpedit.msc

    Code signing for drivers policy under User Configuration >
    Administrative Templates > System > Driver Installation > disable Code signing for drivers
     
  6. Carpz

    Carpz New Member

    Joined:
    Jun 1, 2009
    Messages:
    14
    Likes Received:
    0
    thanks but i couldnt find that option there, theere was two there, but not the one you mentioned
     
  7. Carpz

    Carpz New Member

    Joined:
    Jun 1, 2009
    Messages:
    14
    Likes Received:
    0
    ok, sorry i went into the wrong section, i dound and disable it, but the install still gives the same error, do i have to restart computer?
     
  8. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    I should have stated this first, you need to uninstall the current driver through control panel >Device Manager.

    If you getting the same message as before I would try the above method.

    Create a Restore Point first.
     
  9. Carpz

    Carpz New Member

    Joined:
    Jun 1, 2009
    Messages:
    14
    Likes Received:
    0
    I dont have any current driver, unless the High Definition Audio device or whatever is considered a driver, becuase i havent installed any drivers on here before.
    is that what I have to unninstall?
     
  10. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    Yes, does that entry show up in Device Manager?

    If so, right-clcik on it and choose uninstall.
     
  11. Carpz

    Carpz New Member

    Joined:
    Jun 1, 2009
    Messages:
    14
    Likes Received:
    0
    I did that, restarted and windows automatically reinstalled the driver when i booted up.

    edit:
    now i disabled it, rerted and it remained disabled, then i tried witht eh install and I still get that same error message
     
    #11 Carpz, Jun 3, 2009
    Last edited: Jun 3, 2009
  12. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    I meant to say that in the post above. I had a printer that did the same thing.

    I thought that might happen.

    the .inf file is being read by the install at startup and may also being the File repository as well.

    Go to the C:\windows\inf directory, locate any oem***.inf files, look over the contents and rename the files to .in, disregard the warning, remove the Device from Device Manager again and reboot.
     
  13. Carpz

    Carpz New Member

    Joined:
    Jun 1, 2009
    Messages:
    14
    Likes Received:
    0
    the same thing happened, it reinstalled even when i changed all the .inf files to .in
     
  14. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    Did you change all .inf files or just one relating to the Hight Definition Audio driver?

    I have a search utility that searches inside of file for a specified name. I located the printupg.inf file and located the Lexmark section and removed those references.

    I also looked over the setupapi.app.log and setupapi.dev.log and found references here.

    I remover all these sections and it didn't install a driver on startup.

    I'd suggest you rename those 2 files I just mentioned and give it another try.

    Also, be sure to delete all files and folders under the C:\users\yourusername\AppData\Local|temp

    Also clean out C:\windows\temp
     
  15. marcwomack

    marcwomack New Member

    Joined:
    Jun 6, 2009
    Messages:
    2
    Likes Received:
    0
    Totally different track here. I'm running Win7RC and I'm having a similar error running install for PCI vid capture card:

    [​IMG]

    After much digging it looks like this is a permissions problem associated with InstallShield. Ran into this problem after I went back to an older restore point. Easy way to tell if this is what's causing your problems: try installing anything else that uses installshield. If you get the same error, you're fooked with the same thing I was. Not only could I not get my capture card installed, but I couldn't install ANYTHING else using InstallShield.

    Obviously there's a lot more info about this problem in the XP environment. I found a few threads with suggestions but so far none have worked for me:

    Error -5004 0x80070005 - Acresso Community
    Installshield Error 5004 : 0x80070005 - TechSpot Troubleshooting
    Ted's Complete List of -5000 Errors (LONG) - Acresso Community (breakdown of all installshield 5000s errors)
    Q108322: Update to the Latest InstallShield Installation Engines -VERY useful, steps and download links for most versions of installshield to make sure you're using the one that matches the version used on your install file.

    Now, almost ALL of that digging was useless as it was all XP-centered. What finally fixed it for me was painfully simple: go into c:\program files\common files, and toast the installshield directory. Once I did that tried running the install file again and it worked like a charm! Also all other install programs using InstallShield so far are working now!
     

Share This Page

Loading...