Help Please, Sporadic BSOD about once daily

#1
Hello experts! I've followed the guide and created a zip for all the info about my machine. Like the title says my machine has been having sporadic BSOD's roughly everyday or every other day if I'm lucky. I don't believe it's heat related as all my temps appear to be well within the safe range according to Speedfan. I haven't run a Memtest yet but I was hoping someone here could help me nail down the problem before I spend a bunch of time trouble shooting.

Thank you in advance! You guys rock!

View attachment W7F_26-04-2013.zip
 


usasma

Fantastic Member
Microsoft Community Contributor
#2
Only 133 Windows Updates installed. Most systems have 160 or more. Please visit Windows Update and get ALL available updates (it may take several trips to get them all).

You have 5 hard drives. What is the make/model/wattage and age of your Power Supply?

We've seen a number of BSOD issues with SSD's. Here's the information that I've compiled so far:
There's not a whole bunch available to test SSD's. The "easiest" test is to remove the SSD, install a platter-based hard drive, install Windows and test for stability that way.

Here's some suggestions:
- Update the SSD's firmware to the latest available version (VERY IMPORTANT!!!)
- Update the motherboard controllers drivers to the latest available version from the controller manufacturer (NOT the mobo manufacturer unless you can't find any on the controller manufacturer's website). Be sure to update ALL controllers on the motherboard! I STRONGLY suggest not using controller drivers older than mid-2012 with SSD's.
- Slow the memory (RAM) down to the next slower speed (I've only seen one person who claimed that this worked for them).
- Use any manufacturer's utilities that you may have. If you don't have any, then try this free one (I haven't used it myself): Crystal Dew World
....NOTE: Recently (Nov 2011) we had BSOD issues with the Marvell 91xx controller and an SSD. You may have to switch controllers also.
- Replace the SSD with a platter based hard drive and see if that stops the BSOD's. If it does, then it's likely that there's a problem with the SSD OR an incompatibility with your system.
06 Dec 2011 - This post tends to confirm issues with certain SSD chipsets and certain controllers - [SOLVED] cant find the cause of BSOD F4 - Tech Support Forum
05 Jan 2013 - very interesting post about difficulties with the Marvell controllers even when not connected to the SSD drives: Solved Win8 x64 PC reboots when waking from sleep
27 Feb 2013 - I'm starting to see much better reliability with SSD's using current (mid-2012 and later) storage drivers. I have withdrawn my objections to using these devices in everyday systems.
Your Broadcom Bluetooth is disabled. Is this deliberate? If so, why?

MSI Afterburner (along with Riva Tuner and EVGA Precision) are known to cause BSOD's in some Windows systems. Please un-install it immediately!

If you're overclocking, please stop the overclock while we're troubleshooting. Feel free to resume the overclock once the system has been stabilized.

I have seen problems with UltraMon in the past. Since the driver for it dates from 2008 and is present in the memory dump - I'd suggest un-installing it to see if that helps.

Analysis:
The following is for informational purposes only.
Code:
[font=lucida console]**************************Fri Apr  5 02:00:34.276 2013 (UTC - 4:00)**************************
Loading Dump File [C:\Users\Owner\SysnativeBSODApps\040513-14851-01.dmp]
Windows 7 Kernel Version 7601 (Service Pack 1) MP (8 procs) Free x64
Built by: [B]7601[/B].18044.amd64fre.win7sp1_gdr.130104-1431
System Uptime:[B]2 days 7:38:11.135[/B]
Probably caused by :[B]ntkrnlmp.exe ( nt! ?? ::FNODOBFM::`string'+36ad9 )[/B]
BugCheck [B]7A, {4, 0, fffffa800fcfe1f0, fffff8a000fe6a68}[/B]
BugCheck Info: [url=http://www.carrona.org/bsodindx.html#0x0000007A]KERNEL_DATA_INPAGE_ERROR (7a)[/url]
Arguments: 
Arg1: 0000000000000004, lock type that was held (value 1,2,3, or PTE address)
Arg2: 0000000000000000, error status (normally i/o status code)
Arg3: fffffa800fcfe1f0, current process (virtual address for lock type 3, or PTE)
Arg4: fffff8a000fe6a68, virtual address that could not be in-paged (or PTE contents if arg1 is a PTE address)
BUGCHECK_STR:  0x7a_0
PROCESS_NAME:  svchost.exe
FAILURE_BUCKET_ID: [B]X64_0x7a_0_nt!_??_::FNODOBFM::_string_+36ad9[/B]
CPUID:        "Intel(R) Core(TM) i7-2700K CPU @ 3.50GHz"
MaxSpeed:     3500
CurrentSpeed: [B]3500[/B]
  BIOS Version                  P1.70
  BIOS Release Date             01/17/2013
  Manufacturer                  To Be Filled By O.E.M.
  Product Name                  To Be Filled By O.E.M.
¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨``
[/font]
3rd Party Drivers:
The following is for information purposes only.
Any drivers in red should be updated or removed from your system. And should have been discussed in the body of my post.
Code:
[font=lucida console]**************************Fri Apr  5 02:00:34.276 2013 (UTC - 4:00)**************************
[COLOR=RED][B]UltraMonUtility.sys         Thu Nov 13 20:10:30 2008 (491CD006)[/B][/COLOR]
intelppm.sys                Mon Jul 13 19:19:25 2009 (4A5BC0FD)
MBfilt64.sys                Thu Jul 30 23:40:32 2009 (4A7267B0)
CM10664.sys                 Thu Oct  1 06:04:51 2009 (4AC47EC3)
amdxata.sys                 Fri Mar 19 12:18:18 2010 (4BA3A3CA)
netr6164.sys                Wed Apr  7 08:07:21 2010 (4BBC7579)
speedfan.sys                Fri Mar 18 12:08:46 2011 (4D83838E)
Rt64win7.sys                Tue Aug 23 09:55:41 2011 (4E53B15D)
btwl2cap.sys                Sat Aug 27 18:58:52 2011 (4E5976AC)
asahci64.sys                Wed Sep 21 05:42:57 2011 (4E79B1A1)
RTKVHD64.sys                Tue Oct 18 07:48:20 2011 (4E9D6784)
ArcSec.sys                  Wed Nov  9 22:05:33 2011 (4EBB3F7D)
lvrs64.sys                  Wed Jan 18 01:40:36 2012 (4F166964)
lvuvc64.sys                 Wed Jan 18 01:41:08 2012 (4F166984)
iusb3hub.sys                Mon Feb 27 05:56:50 2012 (4F4B6172)
iusb3xhc.sys                Mon Feb 27 05:56:53 2012 (4F4B6175)
iusb3hcs.sys                Mon Feb 27 05:58:49 2012 (4F4B61E9)
btwavdt.sys                 Thu Mar  1 16:45:18 2012 (4F4FEDEE)
btwrchid.sys                Thu Mar  1 16:46:08 2012 (4F4FEE20)
btwaudio.sys                Fri Apr 27 16:54:05 2012 (4F9B076D)
HECIx64.sys                 Mon Jul  2 18:14:58 2012 (4FF21D62)
bcbtums.sys                 Fri Aug 24 17:21:36 2012 (5037F060)
dump_iaStorA.sys            Sat Sep  1 21:01:24 2012 (5042AFE4)
iaStorA.sys                 Sat Sep  1 21:01:24 2012 (5042AFE4)
iaStorF.sys                 Sat Sep  1 21:01:27 2012 (5042AFE7)
aswrdr2.sys                 Mon Oct  8 04:23:43 2012 (50728D8F)
aswFsBlk.SYS                Tue Oct 30 18:43:04 2012 (509057F8)
aswMonFlt.sys               Tue Oct 30 18:43:09 2012 (509057FD)
aswTdi.SYS                  Tue Oct 30 18:43:16 2012 (50905804)
aswSP.SYS                   Tue Oct 30 18:44:06 2012 (50905836)
aswSnx.SYS                  Tue Oct 30 18:44:08 2012 (50905838)
btwampfl.sys                Sat Dec  1 16:50:24 2012 (50BA7BA0)
igdkmd64.sys                Wed Dec 12 19:42:26 2012 (50C92472)
nvhda64v.sys                Wed Dec 19 00:41:41 2012 (50D15395)
nvlddmkm.sys                Sat Feb  9 18:13:08 2013 (5116D804)
rzudd.sys                   Mon Mar  4 01:48:31 2013 (513443BF)
[/font]
http://www.carrona.org/drivers/driver.php?id=UltraMonUtility.sys
http://www.carrona.org/drivers/driver.php?id=intelppm.sys
http://www.carrona.org/drivers/driver.php?id=MBfilt64.sys
CM10664.sys - this driver hasn't been added to the DRT as of this run. Please search Google/Bing for the driver if additional information is needed.
http://www.carrona.org/drivers/driver.php?id=amdxata.sys
http://www.carrona.org/drivers/driver.php?id=netr6164.sys
http://www.carrona.org/drivers/driver.php?id=speedfan.sys
http://www.carrona.org/drivers/driver.php?id=Rt64win7.sys
http://www.carrona.org/drivers/driver.php?id=btwl2cap.sys
http://www.carrona.org/drivers/driver.php?id=asahci64.sys
http://www.carrona.org/drivers/driver.php?id=RTKVHD64.sys
http://www.carrona.org/drivers/driver.php?id=ArcSec.sys
http://www.carrona.org/drivers/driver.php?id=lvrs64.sys
http://www.carrona.org/drivers/driver.php?id=lvuvc64.sys
http://www.carrona.org/drivers/driver.php?id=iusb3hub.sys
http://www.carrona.org/drivers/driver.php?id=iusb3xhc.sys
http://www.carrona.org/drivers/driver.php?id=iusb3hcs.sys
http://www.carrona.org/drivers/driver.php?id=btwavdt.sys
http://www.carrona.org/drivers/driver.php?id=btwrchid.sys
http://www.carrona.org/drivers/driver.php?id=btwaudio.sys
http://www.carrona.org/drivers/driver.php?id=HECIx64.sys
http://www.carrona.org/drivers/driver.php?id=bcbtums.sys
http://www.carrona.org/drivers/driver.php?id=dump_iaStorA.sys
http://www.carrona.org/drivers/driver.php?id=iaStorA.sys
http://www.carrona.org/drivers/driver.php?id=iaStorF.sys
aswrdr2.sys - this driver hasn't been added to the DRT as of this run. Please search Google/Bing for the driver if additional information is needed.
http://www.carrona.org/drivers/driver.php?id=aswFsBlk.SYS
http://www.carrona.org/drivers/driver.php?id=aswMonFlt.sys
http://www.carrona.org/drivers/driver.php?id=aswTdi.SYS
http://www.carrona.org/drivers/driver.php?id=aswSP.SYS
http://www.carrona.org/drivers/driver.php?id=aswSnx.SYS
http://www.carrona.org/drivers/driver.php?id=btwampfl.sys
http://www.carrona.org/drivers/driver.php?id=igdkmd64.sys
http://www.carrona.org/drivers/driver.php?id=nvhda64v.sys
http://www.carrona.org/drivers/driver.php?id=nvlddmkm.sys
http://www.carrona.org/drivers/driver.php?id=rzudd.sys
 


#3
First off thank you so much for the reply John! I've read over your feedback here's what I've done/found regarding your points:

-Double checked my Windows update.And installed all available updates

-My powersupply is a 660W Seasonic SS-660XP2, I would have thought this would be enough to power my single GPU system, though now that you mention it my HDD's are daisy chained together from the PSU and it might be worth separating the cables where they get their power?

-I've double checked that I have the most up-to-date firmware for my SSD (I did), I've also installed the Intel Rapid Storage Technology driver (never bothered installing it before). It appears that my SSD uses the Marvell 88SS9187 Controller, not sure if that's important info or not.

-Double checked that I have the most up-to-date BIOS/UEFI for my ASRock Pro4, no newer versions were available.

-My bluetooth was disabled when I ran the info gatherer just because I only turn it on when I want to pair it with my headphones, otherwise I leave it off so it doesn't conflict with pairing with my (old) phone.

-Uninstalled MSI Afterburner

-I had overclocked in the past but recently I've been running at stock to try to allay the BSOD issues and it hasn't helped

-Uninstalled Ultramon

I will report back if my actions based on your feedback have helped solve the issue, one thing that I noticed that may be of interest is that if I hit the Reset button on my case after the BSOD, my mobo won't detect my SSD, but if I power down and power back up, it sees my SSD fine.
 


Last edited:
#4
New development: After installing the Intel Rapid Storage drivers my system will hang (all my programs will become unresponsive including Explorer, all I can do is move the mouse around) instead of Blue Screening.

I've also been noticing that this problem (hangs/blue screens) seem to happen consistently when I let the computer Idle for a little bit, like if I get up to go do something for say 20min to a half hour or leave it on to host a server.
 


usasma

Fantastic Member
Microsoft Community Contributor
#5
The PSU question was based on the number of hard drives that you have - I'm not a PSU expert, so I just look for a lot of hard drives as they will drain the power. While I don't suspect your PSU, it wouldn't hurt to disconnect a couple of the hard drives to see if that makes things more stable.

We saw problems with SSD's and Marvell controllers a while back. This was (IMO) due to the older drivers that Marvell supplied - and there were no more recent one's available. I think Marvell has released newer drivers recently.

While looking for info on the Marvell controller I noticed xusb21.sys - a known BSOD cause on Windows systems.
It is the USB XBox controller - and there are no driver updates available AFAIK.
Please un-install the software for this device then physically remove the device from the system in order to test it.

Just found a couple of more USB devices (to include a sound card). What (and how many) things are plugged into your USB ports?

No sign of a Marvell controller in any of the reports. Here's the link to the specs for your mobo, there's no sign of it there either: ASRock > Z77 Pro4

Not a problem disabling Bluetooth - just make sure that you have the latest drivers for it (to do that, you have to enable it, install the new drivers, then disable it). If you look at the stuff in my last post, there are Bluetooth driver in the memory dump even though the device is disabled (this isn't unusual).

Try the stuff that I've mentioned above. Once all that has been dealt with - if the system still freezes I'll ask for another set of reports (and an additional one). Although not common, it does sometimes happen that fixing a BSOD will result in other errors popping up.
 


#6
Sure thing! Another development: I booted my system into Safe Mode + Networking and let it idle for 8 hours and there was no Blue Screen or hang. (Vs. this morning when I let it idle for 45min in the normal desktop and it hanged while I was gone).

-I've gone ahead and removed the Xbox 360 controller driver, I had it disconnected at the time of several of my Blue Screens but hopefully uninstalling the driver helps

-The bluetooth adapter is an IOGEAR GBU521 Bluetooth 4.0 Micro Adapter, I skipped installing the IOGEAR drivers as I heard they were chock full of bloatware from reviews and instead opted to find the equivalent Broadcom bluetooth drivers from Bluetooth Software Download | Broadcom per one user's recommendation. This may be a cause for the problem but I'm not sure, I will try uninstalling them and see if it helps.


I have several other USB devices as you mentioned, they are as follows:

-Cyber Sniper Sonar 5.1 headset (though its driver is really old I've had this thing for a few years with Windows 7 and it hasn't caused problems, hopefully isn't now)
-HP Deskjet 3050 printer
-Logitch C270 Webcam
-Star Tech USB 3.0 HDD enclosure with 3TB Seagate HDD

-A usb hub built into my monitor, and attached to that is:
-Razer Naga Epic
-Noppoo Choc Mini USB keyboard


Another thing I noticed is that while I was poking around inside the Intel Rapid Storage Technology menus, I noticed there was an option for "Link Power Management" and that it was enabled. The description for it says that it "helps the SATA device save power during idle time when there is no I/O activity or when devices are absent and unused"

This sounds like it could be related to my computer freezing/BSODing after idling? I've gone ahead and disabled it to see if it helps.
 


usasma

Fantastic Member
Microsoft Community Contributor
#7
The only thing different that I'd suggest would be disconnecting the USB hub in the monitor - and plugging those 2 devices into the mobo instead.

How did you figure that your SSD was connected to a Marvell controller? As you associate the freezing problem with the time that you installed the Intel RST, I have to wonder what else in the mix might be acting up for you.

Good luck!
 


#8
Okay another update, I left my computer on overnight to test for stability and woke up to an unresponsive machine again, it wasn't exactly blue screened (because I set it to leave the Blue Screen up instead of restarting when it happens), but my screens were black and not responding.

I looked into the event viewer and it started throwing up warnings about 10-20 minutes after I went to bed, displaying a new warning every minute on the minute, I've attached a link to a screenshot:

http://i.imgur.com/ZhutNth.jpg



As for the Marvell controller, I believe I got confused. That controller is a hardware chip embedded on the SSD itself and isn't a SATA controller (here's where I saw the info, in the chart a little ways down):

AnandTech | Plextor M5 Pro (256GB) Review

I'm not exactly sure what SATA controller my motherboard uses but I suspect there's still a problem there from the looks of the event viewer.

I've gone ahead and unplugged the USB hub from my monitor and plugged all my peripherals directly into the USB ports on my computer.

Right now I'm at a loss as to how to fix this thing's instability. There definitely seems to be an issue between my OS, mobo, and SSD as far as idling goes, I might see if it remains stable in Safe Mode all night tonight and if I can recreate it becoming unresponsive the night after.

Thank you again for your help! Hopefully we can nail this thing down, I guess if all else fails I can reformat and reinstall if it's an OS issue, but I'm hoping not to.
 


usasma

Fantastic Member
Microsoft Community Contributor
#9
It appears that it's the Intel storage controller that's spitting out errors on you. Most likely it's a bad driver installation - but it could also be hardware issues.

Where did you download the Intel RST drivers from? Before installing a fresh copy, be sure to un-install the current copy from the system:
If you downloaded them from the AsRock site - try those from the Intel site ( http://downloadcenter.intel.com )
If you downloaded them from the Intel site - try those from the AsRock site ( ASRock > Z77 Pro4 )

Do not use the RSTe (Enterprise) version from the Intel site.
 


#10
I agree that the Intel RST driver is what is causing my unresponsiveness, I've narrowed it down to happening exactly 15-17minutes of being idle. I downloaded the one directly from Intel, so I will uninstall and try the ones from ASRock next.

Even before uninstalling the Intel RST drivers, my system was rock solid all last night and all through the day in Safe Mode w/ Networking, so I don't believe it's purely a hardware issue and that something is gummed up in the software as well.
 


#11
Installing the Intel RST that was on the ASRock site did not help, and not only does my computer hang after ~16 minutes of being idle, apparently it also does so when transferring large (>1GB) files on my SSD. I think I'm gonna throw in the towel and just format and reinstall and hope it resolves the issue (fingers crossed it isn't a hardware issue), luckily I don't keep any files worth saving on my C: partition as that's what my redundent hard drives are for, just a couple hours of downloading should get me back up to speed and should be quicker than all this troubleshooting business.

Thank you for your time usama, I greatly appreciate the help and advice you've given me but there doesn't seem to be a quick/easy answer for this problem.
 


usasma

Fantastic Member
Microsoft Community Contributor
#12
BSOD's and their consequences aren't easy - that's why there's so few of us who do this.

Don't activate the installation after you format and reinstall. It'll offer the option to activate for up to 30 days - plenty long enough to test the system.

If the problem still remains, then try a format and reinstall on a platter based hard drive also (don't activate it either) - just to see if it's the SSD.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.