Help - Windows 7 will not remember my pointer preferences after each reboot

#1
I am having problems setting my mouse pointer speed to where I desire it. I go to make the changes by:

Right Click Desktop > Personalize > Change Mouse Pointers > Pointer Options (tab) > Select Pointer Speed (sliding bar)

The changes are made and work great until after a restart. The system can hibernate and resume and still maintain the changes, but once it is powered down, the next time I boot the pointer speed is back where it was before the changes were made.

I'm running
Microsoft Windows 7 Home Premium
Version 6.1.7600 Build 7600
64 bit
Lenovo IdeaPad Y460

What should I do? Or what other information would be helpful in finding a solution? Thanks!
 


#2
Does your Lenovo have any 3rd-party mouse software that runs on startup? Could be that such a program expects to have responsibility for the settings and is overwriting them with it's own defaults when loaded (I'm just guessing here, I haven't owned a ThinkPad since they were still part of IBM!)
If you aren't sure, try this:
Go to Start --> Run (or hit Winkey+R)
type msconfig
Select the "Startup" tab
Look through the list for anything that sounds related to mouse, pointer or trackpad/touchpad.

Hope that helps,
Misha
 


#3
There is an icon in the taskbar that looks like the touchpad. It is the "Synaptics Pointing Device". However, clicking on this icon opens the "Mouse Properties" window, the same window which is opened when I Right Click Desktop > Personalize > Change mouse pointer. It does not seem to have it's own area where you can choose settings, though perhaps this mouse properties window is not part of windows 7, which I thought it was, and so is part of the synaptics program?
 


#4
I'm pretty sure that's part of Windows, it was just a shot in the dark. If your settings look like the attached screenshot, then you are seeing the windows 7 settings dialog and not a 3rd party application


On the other hand, a quick google yielded this, which seems to affect users of Logitech mice - are you using just the (synaptics) trackpad or do you maybe have an external logitech mouse? Failing that, I'm out of ideas.

Misha
 


Last edited:
#5
You are correct. I remembered after thinking about it some more that I used a bluetooth Logitech mouse for a bit a while back. I had removed the startup item for the drivers, however, but this process your article talks about does start at startup, so disabling it would likely have helped.

However, I have a new problem.

I tried simply disabling the Synaptics driver on the startup menu, thinking this would maybe clear things up. The touchpad wouldn't work, so I went digging and found the bluetooth mouse and used that to try to fix things up. I went and re-enabled the Synaptics driver, and upon reboot my touchpad worked fine. At that point I uninstalled the Logitech software (that I then remembered I had had), and hoped everything would be cleared up. The mouse preferences are preserved upon reboot (which is great!), however, now when I go into change the settings of my mouse pointer through the windows driver I receive this prompt:

"
Unable to connect to the Synaptics Pointing Device Driver.

If you have installed another PS/2 Pointing Device Driver please uninstall the Synaptics driver by clicking on the Yes button. You then need to reinstall your pointing device driver for your external device again.

Do you want to uninstall the Synaptics driver now?
"

This is a bit disconcerting to me. I have fully removed the Logitech SetPoint software (using RevoUninstaller to remove even the registry entries and temp files), and I am still getting this message. The touchpad seems to work fine, and if I say no to uninstalling the Synaptics driver I am able to customize my pointer options just fine using the windows controller. However, I am unable to use some of the custom keys on this laptop (volume up, volume down, mute, battery status, etc) that I believe the Synaptics driver controls.

My conclusion is that by disabling the Synaptics, rebooting, realizing that I had done a bad thing so reenabling the Synaptics driver and rebooting again, I have somehow caused this problem.

Any idea how to fix it? I'm hesitant to uninstall the Synaptics driver as I am not aware that I have any other drivers on here for controlling pointers, having removed the Logitech ones. Can I reinstall just this select driver somehow from Windows?

Thanks!
 


#6
Hmm, nice pickle you've got yourself into there! I think you are probably right in your conclusion, although merely disabling a driver rather than uninstalling it shouldn't have had any long term effects.
You can download the drivers you need from the Lenovo website, here. Try just installing them without uninstalling anything for now, and see if that fixes it. If not, you might try uninstalling them (having first got your logitech mouse working again - if it's USB it probably doesn't actually need drivers to work since USB mouse support is built-in to windows 7) then reinstalling.

Good luck,
Misha
 


#7
I was able to solve this issue by removing the Synaptics driver then reinstalling it (I tried just installing over the old install, but the manufacturer had used the wrong version of the driver, which was for an xp 32 bit system, whereas my laptop has windows 7 64 bit, but the correct driver was older)

Thanks for your help!
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.