How can I stop facebook from asking me if I want to turn on notifications every time I log in.

Syex

Honorable Member
This is a recent problem and I'm sorry if this is the wrong place to post such a question but I'm getting desperate for an answer and I'm going to keep asking everywhere until there's a fix.
Basically every time I log in to facebook this message box appears:
Untitled.png

As you can see there is no 'don't ask again' option. I'm tired of having to click 'not now' every time. Fb is inaccessible until I've clicked one of the options. I am not clicking on 'turn on'. Does anyone know how to fix this very annoying problem. Unless it's sorted I won't be using fb anymore. Cheers.
 


Neemobeer

Windows Forum Team
Staff member
Are you seeing this in Chrome, or any browser?
 


Syex

Honorable Member
Firefox. I've tried everything, FB Purity doesn't work, allowing it then disallowing it in the browser didn't work as was suggested. The only way I believe it can be prevented is if someone was to write some kind of script / browser add on that prevents the message, blocks it somehow.
As a result of this I'm no longer updating my fb account I will hardly be using it. I'm certainly not clicking 'Turn on' again. I think fb are are trying to gain access to my desktop. Why else would there be no 'Don't ask again' option. Or a setting that allows you to disable notifications permanently or allow them if and when I choose to.
 


Neemobeer

Windows Forum Team
Staff member
This is just push notifications. Chrome and FF have the feature so you can receive notifications from a site even when you're not at the site. It's not any attempt by facebook to gain access to your computer.

disable web notifications | Firefox Support Forum | Mozilla Support
 


Syex

Honorable Member
Wow, you could be onto something with that link. There's a lot to read through and experiment with.
Will let you know later if it works. :clock:
 


Neemobeer

Windows Forum Team
Staff member
I had to block facebook on chrome for the same thing if I recall awhile back.
 


Syex

Honorable Member
Well, the link you provided led me in the right direction to solving the problem, it was down to permissions in Firefox. Thanks so much, You saved the day as far as FB is concerned. I was going to reply on the Mozilla forum post but it's archived. I'll see if there's another post perhaps and let anyone else suffering from this know the good news. It's important to make sure 'Site Preferences' is un-selected when deleting temporary internet files. Thanks again.

ffox_permissions.png
 


Neemobeer

Windows Forum Team
Staff member
It's a bit hard to find the settings. This is the chrome equivalent chrome://settings/content/notifications
 


Mercedy

New Member
It's a bit hard to find the settings. This is the chrome equivalent chrome://settings/content/notifications
Thanks for this, I use chrome and am having the same annoying pop up.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top