Hp hdx x16-1160us

Discussion in 'Windows 7 Hardware' started by funbobby, Mar 22, 2009.

  1. funbobby

    funbobby New Member

    Joined:
    Mar 22, 2009
    Messages:
    4
    Likes Received:
    0
    I've been going through some problems getting everything working in windows 7 on my new laptop, so i thought i'd start a thread to share my experiences with others.

    first of all, i'm using build 7000. i tried 7057 at one point when i started having troubles (it detect one piece of hardware that build 7000 did not: PCI Data Acquisition and Signal Processing Controller).

    the basic install detects everything except for the fingerprint scanner, the card readers, and the IR for the remote control. the vista drivers for all of these items work in windows 7

    i have been having these problems, and i'm not sure why yet:

    aero is gone or disabled
    i receive errors about windows not being able to connect to the system event notification service
    sound is disabled

    i originally thought it was related to the drivers for the undetected hardware, but it appears to happen with only the windows update content installed.

    the undetected devices are as follows:
    "Base System Device" - the three of these are for the card reader components:
    197b JMicron Technologies, Inc
    2382 SD/MMC Host Controller
    2383 MS Host Controller
    2384 XD Host Controller

    "PCI Data Acquisition and Signal Processing Controller" - this is the Intel 82801I thermal subsystem
    This gets installed with other drivers

    "SM Bus Controller" - Intel 82801I SMBus Controller
    This gets installed with other drivers

    "Unknown Device" - Two of these
    ICH9M LPC Interface Controller - my best guess is the IR sensor for the remote
    USB\VID_138A - guessing the fingerprint scanner

    if you install the vista drivers for those 3 items it should work well (the last two are software for various features):
    sp41341 (card reader)
    sp41659 (IR for remote)
    sp42299 (fingerprint sensor)
    sp40206 (digitalpersona - to enable the fingerprint scanner)
    sp42529 (lightscribe)

    if anyone else is having the "cannot connect to system event notification service", and knows how to fix it, please let me know!
     
  2. salahmufeed

    salahmufeed New Member

    Joined:
    Apr 11, 2009
    Messages:
    2
    Likes Received:
    0
    u can get the drivers from hp web sit
    and about the digital persona this is the link for it ( DigitalPersona Fingerprint Software for Microsoft Windows Vista (64-bit) - HP Business Support Center )
     
  3. adhoc

    adhoc New Member

    Joined:
    Apr 30, 2009
    Messages:
    6
    Likes Received:
    0
    Hey bobby,
    Are you still having this issue? I'm not on my 4th clean install and keep getting this problem again and again. I've tried 3 different builds (7000, 7057, and 7100) and am getting fed up with this issue reoccurring. I also have an HP HDX 16.

    These symptoms appear all at once:

    Aero is disabled and cannot be reenabled using the aero repair wizard.
    System event notification service service error popup

    Shortly followed by a system shutdown delay (that sometimes require hard restart) and then the OS cannot boot at all and the system repair program cannot fix it. Please report your current status on this issue! I'll try to troubleshoot with you and share results.
     
  4. funbobby

    funbobby New Member

    Joined:
    Mar 22, 2009
    Messages:
    4
    Likes Received:
    0
    hi adhoc,

    based on the lack of response i was getting early on, i had to move on, so i went ahead and installed vista. i was planning on going ahead and trying RC on it, but i'm disappointed to hear that you were seeing the same problem with it. i just tried talking with HP support.....they were unhelpful - basically gave me the runaround saying that "no company will provide drivers for an OS that doesn't even exist yet". how do you argue with that? you'd have better luck trying to teach physics to a dog (sorry....frustration leaking out).

    i'm still at a dead end, and don't know what to do next.
     
  5. adhoc

    adhoc New Member

    Joined:
    Apr 30, 2009
    Messages:
    6
    Likes Received:
    0
    Problem SOLVED

    bobby,

    I solved the problem and have been running RC1 with no further complications whatsoever. It took an awful of hunting and some trial and error, but this is the fix:

    step 1: uninstall the IDT high quality audio codec drivers. W7 actually got hung up trying to do this so i killed the process and just disabled it.
    step2: restart your computer and ensure that the IDT audio codec driver is still disabled. now you should be able to uninstall it without issues (if you had them like i did)
    step 3: Allow windows to find and install its own audio drivers.
    step 4: notice all your problems are gone!

    That's it. Seriously. The audio driver causes that much havoc. The downside is that your audio buttons wont be quite as "cool", however, they will styill work. my mute button no longer turns orange when muting and the treble and bass controls don't work (general volume works fine). But I can use my computer again!


    Since you reverted to Vista anyway, just go ahead and DL the latest W7 (RC1) and set it up and don't install the idt audio crap and you're golden!
     

Share This Page

Loading...