Hung Process

Discussion in 'Windows 7 Help and Support' started by VsUK, Apr 22, 2014.

  1. VsUK

    VsUK Senior Member

    Joined:
    Jul 1, 2010
    Messages:
    254
    Likes Received:
    3
    Ever since I upgraded my HDD to a SSD I have been suffering hung process's that refuse to end. I have tried cmd prompt which says the process is not running but it shows in task manager. I've tried process explorer & that does nothing & the only way I can get the process to end so I can re launch the software is to reboot & sometimes after the reboot, nothing will load until I reboot again.

    I've installed windows 7 about 3 time's now & nothing seems to fix the problem. Everything works great at first, then all of a sudden it starts. I'm also suffering from maximized windows minimizing, watching full screen movie's reverting to the compact box & games minimising to desktop. I've never suffered these problems until I upgraded to SSD & then it all started.

    I'm an experienced PC user's so I know the ins & out but this is something I can't figure out. I don't have spyware or anything as I've checked with spybot, malwarebytes & I have Advanced System Optimizer pro that scans, remove's & maintains my system for me & nothing really of importance is found.

    Idea's?
     
  2. bassfisher6522

    bassfisher6522 Essential Member

    Joined:
    Aug 27, 2008
    Messages:
    4,884
    Likes Received:
    318
    Those so called "System Optimizer's" do more harm than good and tend to remove necessary registry strings that keep the OS running smoothly. The same for those so called registry cleaners.

    I would reinstall, set up the SSD for optimization per manufacturer instructions, install all necessary drivers, then install MS updates, install your software and leave the optimizer out and see how it runs.
     
  3. Joe S

    Joe S Excellent Member

    Joined:
    Jan 12, 2009
    Messages:
    3,785
    Likes Received:
    113
    I agree on the system optmizers. I learned the hard way in Windows 98.
    Joe
     
  4. brkkab

    brkkab Senior Member

    Joined:
    Mar 4, 2013
    Messages:
    1,393
    Likes Received:
    81
    Did you enable AHCI, instead of IDE, etc.. for the ssd in your bios or uefi ? Did you do a clean install of Windows on the ssd. Both are must do's to avoid headaches. Also, in Power Options, set the ssd under Advanced Options, click the + next to hard disks and set put it to sleep to Never.
     
  5. VsUK

    VsUK Senior Member

    Joined:
    Jul 1, 2010
    Messages:
    254
    Likes Received:
    3
    Hi, I did do AHCI at first, but I have Sata HD's connected also & the system just hung after post screen. Only way to get passed that point was to go for IDE.

    Power Options I always disable sleep. Normally I only use the system Optimizer as it detects & downloads all my driver's for me which helps & only used the reg cleaners & so forth after I started experiencing issue's.

    I will try a reinstall if someone can suggest why my system hangs on AHCI even with just SSD connected.
     
  6. brkkab

    brkkab Senior Member

    Joined:
    Mar 4, 2013
    Messages:
    1,393
    Likes Received:
    81
    It shouldn't hang on AHCI, unless if your hard drive is seriously ancient (pre-2009) and doesn't support it. I've never had any issue's with AHCI. Make sure your chipset driver's, etc. are current. Also make sure your ram timings are correct in the bios/uefi. Then do a clean install of Windows.
     
  7. VsUK

    VsUK Senior Member

    Joined:
    Jul 1, 2010
    Messages:
    254
    Likes Received:
    3
    I'll try that after I've finished some coding as reinstalling everything is so time consuming its almost depressing lol. Thanks for the help & I will update on results.
     
  8. VsUK

    VsUK Senior Member

    Joined:
    Jul 1, 2010
    Messages:
    254
    Likes Received:
    3
    Hi, I decided to upgrade in the process & got a good price on a M5A97 R2.0 AM3+ Mobo & a FX-8350 & as advised, I Enabled the AHCI, formatted the SSD, Installed to the SSD & it created 2 reserved partitions which is normal I'm told & not only am I getting better frame rates on games, my DDR3 appears to be working better & boots up in seconds.

    I had a stressful time with the Sata HDD not showing up as it was not showing up at all in the system & it was due to it being a dynamic drive, I did loads of things to make it enabled but I couldn't wipe it as its my web dev drive with all files on it, turned out all I had to do was rick click in Disk management on the drive & click import drive & it was working.

    I do have one issue though, now whenever I put my system to sleep, i get a loud static hiss from my speakers & it happens but only for a few seconds when I shut down but the hiss is constant when i put it to sleep. No idea why?
     
  9. brkkab

    brkkab Senior Member

    Joined:
    Mar 4, 2013
    Messages:
    1,393
    Likes Received:
    81
  10. VsUK

    VsUK Senior Member

    Joined:
    Jul 1, 2010
    Messages:
    254
    Likes Received:
    3
    Back again & the hung process has started again. Game's I exit normally still in the process tree & I can still hear the sound from the game's. I End process & sound stops but it continues to show in process tree. Nothing short of a restart fixes it & I never had to suffer with this until I upgraded to SSD & I installed fresh & everything correctly.

    Is this some flaw in Windows 7 or a flaw in its ability to correctly end software process's with SSD's? It's frustrating & it happens with everything every now & again from skype, Windows Live mail to photoshop & installed games.

    It's just happened again with another game I managed to remember to take a screenshot for you.

    [​IMG]
    [​IMG]

    As you can see, I have suspended, End process, End process tree, Restart & nothing works but its stuck continuing to sap resources as you can see from the core temp log. I have never had the problem until I upgraded to a good quality SSD & I'm actually starting to regret bothering now.
     
    #10 VsUK, May 10, 2014
    Last edited: May 10, 2014

Share This Page

Loading...