Optical Out S/PDIF choppy

#1
So,
I have a Sony HT-SS360 Home Theater System that's connected to the computer's optical output.
When I run a test to see what sampling rates are supported, I get full surround sound as the Windows is playing sound through all 5 speakers.

Once I'm playing a movie in VLC and select S/PDIF, the sound goes very choppy and skips, certain channels mute, can't understand anything that's being said, and sometimes completely cut out.

I tried all different settings in both the Realtek Audio Manager and the Windows one. I'm at my wits end.
Is it possible that this is a driver problem?
Anyone else have this issue?

Motherboard is Asus M3A78-EM, with Realtek HD audio driver v r2.27 installed.
 


#2
Did some reading, something with which some people had success with is to replace Windows 7's MSMPEG2ADEC.DLL file located in the system32 folder. Supposedly the Windows 7 MSMPEG2ADEC.DLL has trouble with SPDIF and a few people had success replacing said file.
Unfortunately I haven't yet figured out how to replace this file, windows says I dont have the proper permission to replace anything in the windows folder, it seems.

Any comments on this?

I should add, replace windows 7's MSMPEG2ADEC.DLL with the one from Vista.
 


reghakr

Essential Member
#3
Did this occur immediately after installing Windows 7.

I also use SPDIF out with Cyberlinks' DVD HD Blue-ray player that came with the HP computer.

Have no problems whatsoever with that program, but have had problems getting 5.1 surround in VLC.

I tried WWindows Media Player with a DTS 6.1 ES and it played fine in SPDIF surround.

Is your system DTS compatable...there is a setting in VLC for that.
 


Last edited by a moderator:
#4
k, its working now.
not sure what it is I did, but these are the settings i changed:

VLC is set to wav output
Installed Community Codec Pack
Installed Realtek HD Audio Drivers version r2.28

It's working correctly now, and when selecting S/PDIF out in VLC it will play both Dolby Digital and DTS in 5.1 Surround.

It was rather strange as SPDIF in VLC, after trying 20 times, started working one time, and then quit again. After playing around with it for a little bit longer and changing the above, it works perfectly now. It just almost seemed as if the problem went away on its own. lol.
After multiple reboots it still works.
 


reghakr

Essential Member
#5
Excellent, glad you got it.

I love surround sound, especially DTS.:)
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.