Random BSOD - Kernel Data Inpage Error

#1
This started happening last night while i was playing Borderlands 2, it has happened at idle, playing just about any game in my library, during downloads and just browsing the web. I changed all of my accessible drivers, and it continued to happen, so i moved all of my personal files onto my external HDD. I re installed windows on my SSD (did not reformat) and reformatted my HDD. I re installed my drivers, re-enabled SLI and it ran fine for about an hour, just downloading WoW, and then happened again twice.

let me know if there's any other information you could use, and how to obtain it.

Please help!
 


Attachments

usasma

Fantastic Member
Microsoft Community Contributor
#2
No memory dumps in the uploaded attachment, please follow the directions here to ensure that the system is set to generate memory dumps: Set MiniDump Also, ensure that there is a pagefile set to record the memory dumps. Once we've fixed the BSOD's, feel free to resume not using a pagefile.
No evidence of BSOD's in the WER section of MSINFO32 either - have to wonder if this is a hardware issue.

Although this step isn't required, it is strongly suggested. It's the first step(s) that we run on every computer we take in at work - and it saves us lot's of work when we do find a hardware problem.
Please run these free, bootable diagnostics: Initial Hardware Diagnostics
Post back with the results of the tests in order to let us know if they were done successfully or not.
Thanks!
Only 58 updates since SP1, most systems have 130 to 140. Please visit Windows Update and get ALL available updates

We've seen a number of BSOD issues with SSD's. Here's the information that I've compiled so far:
There's not a whole bunch available to test SSD's. The "easiest" test is to remove the SSD, install a platter-based hard drive, install Windows and test for stability that way.

Here's some suggestions:
- Update the SSD's firmware to the latest available version (VERY IMPORTANT!!!)
- Update the motherboard controllers drivers to the latest available version from the controller manufacturer (NOT the mobo manufacturer unless you can't find any on the controller manufacturer's website)
- Slow the memory (RAM) down to the next slower speed (I've only seen one person who claimed that this worked for them).
- Use any manufacturer's utilities that you may have. If you don't have any, then try this free one (I haven't used it myself): Crystal Dew World
- Update chipset and storage controller drivers to the latest available from the manufacturer of the device (not the manufacturer of the motherboard). Be sure to update ALL controllers on the motherboard!
....NOTE: Recently (Nov 2011) we had BSOD issues with the Marvell 91xx controller and an SSD. You may have to switch controllers also.
- Replace the SSD with a platter based hard drive and see if that stops the BSOD's. If it does, then it's likely that there's a problem with the SSD OR an incompatibility with your system.
It's my opinion that SSD's aren't reliable enough (with current hardware) to be used on a system that needs to work reliably. Until I see reliability I will not recommend, nor will I use, SSD's for critical applications.
06 Dec 2011 - This post tends to confirm issues with certain SSD chipsets and certain controllers - [SOLVED] cant find the cause of BSOD F4 - Tech Support Forum
29 May 2012 - The frequency of BSOD's with SSD's seems to have been decreasing over the last several months. It may be approaching time to re-evaluate my stand on their suitability for use in production systems.
10 Nov 2012 - I'm seeing an upswing in SSD errors - but most appear due to older storage controller drivers. I strongly suggest NOT using storage controller drivers that don't date from 2012 (if none are available, don't connect an SSD to that controller)

This device has problems:
Not Available USB\VID_0CF3&PID_3000\6&DF2EE03&0&7 The drivers for this device are not installed.
It is most likely your Atheros BT USB - please install the drivers for it (usually available from the PC manufacturer's website).

Ensure that your USB 3.0 drivers are updated also. The 2010 version of these drivers are known to cause BSOD's (your system is using the 2010 version of these drivers).

Good luck!
 


#3
Thanks for your help!

I've updated the SSD firmware, set my system to generate minidumps in the event of a BSoD, installed the Atheros Driver, updated my USB 3.0 driver and checked to make sure all of the updates available have been performed. I ran Memtest86 for 8 hours today for 7 complete passes. It returned no errors.

I'm going to let a download run for what's left of the night and if there is a crash, i'll upload an updated W7F diagnostic in the morning.

Thanks again!
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.