"$RECYCLE.BIN" created in all of my hdd drives

Discussion in 'Windows 7 Help and Support' started by geek123, Aug 4, 2013.

  1. geek123

    geek123 New Member

    Joined:
    Aug 4, 2013
    Messages:
    3
    Likes Received:
    0
    Hi Everyone !

    I am using Windows 7 ultimate x64. My sister plugged a memory card into my laptop some days ago. Since then, there is a folder "$RECYCLE.BIN" created in all of my hdd drives. I delete that folder but it reappears whenever laptop is restarted. Its really annoying me right now.

    Any safe solution will be highly appreciated.

    Thanks !
     
  2. geek123

    geek123 New Member

    Joined:
    Aug 4, 2013
    Messages:
    3
    Likes Received:
    0
    Also, when I connect my portable hard drive into the laptop, a folder named "RECYCLER" is found. And I am unable to delete it.
     
  3. davidhk129

    davidhk129 Senior Member

    Joined:
    May 19, 2012
    Messages:
    1,337
    Likes Received:
    99
    You probably will not agree with me. You most likely will say, " That is not what I am asking ", but I am going to say it anyway.................
    1. You shouldn't attempt to delete it. It's best to leave it alone.
    2. If its presence is annoying, hide it by unchecking " Show hidden files, folders, and drives " and checking "Hide protected operating system files"
    Start > search box, type folder options > Enter > View > under Files and Folders, uncheck " Show hidden files, folders, and drives ", and check "Hide protected operating system files" > OK when done.
     
    #3 davidhk129, Aug 4, 2013
    Last edited: Aug 4, 2013
    Mike likes this.
  4. Josephur

    Josephur Windows Forum Admin
    Staff Member Premium Supporter

    Joined:
    Aug 3, 2010
    Messages:
    1,019
    Likes Received:
    125
    Have you right clicked Recycle Bin, Properties and selected the option "Don't move files to the Recycle Bin. Remove files immediately when deleted"? After choosing this feel free to delete the hidden Recycle Bin folder on your drives, it shouldn't come back.
     
  5. Mike

    Mike Windows Forum Admin
    Staff Member Premium Supporter

    Joined:
    Jul 22, 2005
    Messages:
    8,488
    Likes Received:
    783
    Be aware that you have to perform this on every system you place the drive on, and so not just yours. Its in the nature of Windows to use whatever storage it needs for recycling. This is to allow the recovery of data. Before Recycle Bin, people wanted to know how they could undelete their files. And after Recycle Bin, they still want it, just a lot less. Be careful what you ask for. I would follow @davidhk129 and his valid suggestion - just hide protected OS and system files. There is no need to look at this if it bothers you. Mac OS also leaves trace files in directories, similar to how many folders in Windows will have Thumbs.db if there was multimedia content where thumbnails were generated. These OS-related files usually take up an insignificant amount of space or resources. Its there because Windows will use it, thats all.
     
  6. geek123

    geek123 New Member

    Joined:
    Aug 4, 2013
    Messages:
    3
    Likes Received:
    0
    @davidhk129 & @Mike: I have tried both. Unchecked "Show hidden files/folders" and checked "Hide protected operating system files". The folders are still there.

    I can try to leave them as it is but if they are not hidden folders, is there any chance of them being virus or some threat?
     
  7. davehc

    davehc Microsoft MVP
    Premium Supporter Microsoft MVP

    Joined:
    May 1, 2008
    Messages:
    5,116
    Likes Received:
    301
    I have always had a recycle.bin on all my HD's. I could be wrong, but I have always assumed it to be the default, at least since Vista (can't remember for XP) They will be recreated, if you try and delete them.
    Hiding the files, should have done the trick.
    But, it looks like the memory card has changed the attributes. Right click each in turn, and select properties. Make sure the small box, bottom left "Hidden" is ticked. The in the folder options, again make sure you are not showing hidden files.
     
  8. Mike

    Mike Windows Forum Admin
    Staff Member Premium Supporter

    Joined:
    Jul 22, 2005
    Messages:
    8,488
    Likes Received:
    783
    davehc has the correct answer here. If its still visible make sure that the properties have not been customized for this drive under Explorer. Also consider using NTFS or exFAT on the drive. These are newer formats than FAT and FAT32 and have forward-looking compatibility with Windows systems.
     

Share This Page

Loading...