"Safe remove" does nothing

#1
When I try to safe remove an SD card, I click on it and it does nothing. I never get a message that says it's now safe to remove, and it doesn't unmount. There's no error message involved, it just does nothing. Does anybody know how to fix this?
 


loathe

New Member
#2
When I try to safe remove an SD card, I click on it and it does nothing. I never get a message that says it's now safe to remove, and it doesn't unmount. There's no error message involved, it just does nothing. Does anybody know how to fix this?
Mine works fine. As long as you make sure youre not transfering files to or from the card you should be safe to remove it. Not really a fix though is it.
 


#3
As long as you make sure youre not transfering files to or from the card you should be safe to remove it
Not with SD cards. I've lost data by removing SD cards without unmounting, and there was never any data being transferred when I did it.
 


Last edited:

ickymay

New Member
#4
I don't seem to have the "safely remove" for my windows based mobile so I just pull it and sometimes it loses it's sync profile as a consequence, but I do have the icon and option with all other devices such as my SD cards :confused:

go figure :redface:
 


#5
The same problem!

Hallo, friends! I am new in the forum, so I do not have a lot of expierience... so, be patient if I do something wrong... Also I'm not a good English speaker and writer...
I have the same problem about safely removing my usb external disks. They are all WD. When I click the safely remove button no message appears! In control panel it says that the device has been prepaired for safe removal. The device really doesn't anymore appear in My Computer, but it's still truned on, with the indicator light on! Please, help with this problem and give me guidance. Thanks in advance.:(
 


Jarhead57

New Member
Premium Supporter
#6
Hallo, friends! I am new in the forum, so I do not have a lot of expierience... so, be patient if I do something wrong... Also I'm not a good English speaker and writer...
I have the same problem about safely removing my usb external disks. They are all WD. When I click the safely remove button no message appears! In control panel it says that the device has been prepaired for safe removal. The device really doesn't anymore appear in My Computer, but it's still truned on, with the indicator light on! Please, help with this problem and give me guidance. Thanks in advance.:(
Is yours USB powered? mine are and the light won't go out until unplugged from your computer.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.