Windows 11 Shell extension menu with "stuck" and missing items

KurtisLugo

New Member
Hi all,

I am on a Windows 11 PC and need assistance with the following issue.

When right clicking on a file, the shell extension menu doesn't seem to behave as expected.

It shows a menu for SOUND FORGE Audio Studio 16.1 (which I do have installed, I just want the context menu disabled) and does not show these entries for Winamp; "Enqueue in Winamp" and "Play in Winamp" which I would like to have - here's some details on why I think something is off:

SOUND FORGE:
- The program does not have a setting for enabling or disabling the context menu, but it's installation folder contains a file RemoveSFContextMenusAS.reg which can be used to remove the menu manually. I have ran it succesfully but the menu still does not disappear.

- I have then located HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Directory\shell\ in order to delete manually - this is where the Sound Forge folder should be in - but there is nothing here to delete. I think that .reg file deleted it already?

- I have then downloaded NirSoft's ShellExView and ShellMenuView but again, there are no items for Sound Forge shown in these programs. It kind of looks like I did delete the context menu's for Sound Forge but they are still displayed for some reason.

- Note: I did manage to remove another item using ShellMenuView, so, the context menu does update and react to other changes made with ShellMenuView.

WINAMP:
- I am aware that uninstalling Microsoft's Clipchamp sometimes causes Winamp context menu entries to disappear - but, I have already unistalled Clipchamp previously, so it's probably not that.

- This program has a setting for showing Winamp actions in the folder context menus. I have checked it, but the usual Winamp items are still not shown in the context menu.

- I have then, again, tried NirSoft's ShellExView and ShellMenuView to remedy this, but in there it shows that everything is all right: Winamp is displayed in the list of ShellMenu/ExView and its context menu items are shown as enabled just as they should.

- This started happening when I updated to the latest Winamp version, v 5.9.1 Dec 21 2022 (the context menu items were shown normally before that) but since there's also a similar problem with the Sound Forge entry, this could be a deeper issue. I'm hoping someone here could help me out with this.
 
Top