Windows 7 SOLVED - 32bit Windows working, x64 not


New Member

I have an older laptop from Lenovo (X201 Tablet 3113) without UEFI bios.

32bit version of Windows (doesn't matter if it's 7,8 or 10) works fine, but when I try to install a 64bit version, it gets stuck on the "loading windows" screen. I've tried to cheat this with a "all in one" DVD, installed the x64 version of Win 7, but it won't load. In normal startup mode, it hangs at the loading screen again, in safe mode it gets stuck on disk.sys.

I'm all out of ideas. So far I've tried:

different windows versions, 7, 8 and 10 either from OEM dvd or from a flash drive
3 different harddrives
4 different RAM modules
turn off almost everything in bios (except usb ports)
hdd in both AHCI and compatability mode

So any new ideas would be appreciated.
It should work fine with Windows 7 64bit. Anything beyond that there are no drivers available. I did notice that model was only sold with Windows 7 32 bit and never 64.
I've seen Win 10 on the same model. Granted, not everything was exactly working, but still, I can't even install it and have no idea why...
Hi there,
Neem is right that tablet should run W7-64bit.
Specs here show the tablet coming with an Intel i7 dual-core processor, Arrandale core design. That's a x86-64bit processor as shown in these 2 links:

Lenovo ThinkPad X201 Tablet 3113 Specs

Core i7-620LM - Intel - WikiChip

Looking at this information closely, the CPU chip (Core i7-620lm), which should be the CPU chip in your tablet, will definitely run W7 64bit.
That leaves me wondering why a 6 year old tablet came with a downgraded 32bit W7 version? Where exactly did you purchase this Lenovo tablet from? Did you get it from a brick-and-mortar store chain such as Best Buy or Micro Center, or from somewhere online such as ebay or a 3rd party Amazon store?? This is very important as there are lots of disreputable folks out there selling bastardized tablets (not that yours is, but it has happened to others here on this forum).

Lastly, I noticed from the CNET specs, that your Tablet comes with TPM v1.2 Security Chip; we've experience problems with this before; so you said you turned everything off in your BIOS, did you TURN OFF YOUR TPM AS WELL??? If you cannot turn this feature off, your Tablet Motherboard could have failed and would need to be replaced! :waah:

Don't panic just yet though if you can't disable it. Other things that could cause this could be your Windows source Media; you said you tried several versions of Windows both on DVD disc and Flash Drive? Were any of those Microsoft retail legit Media, you know the ones with the fancy Microsoft Logo & Holograms on them? If not one of those, how about a factory Recovery DVD disc or USB Flash Drive with the Lenovo Logo on it (legit Recovery Media from Lenovo)? Lots of people have copies of Windows, especially older copies, and often they were given to you as a gift from a friend, family-member, co-worker, or a friend who repairs computers. If it's not factory Media, or legit Microsoft retail media (with Holograms & Logo), chances are your source media could be to blame!! We see this all the time when people bring their broken PCs/laptops/tablets in and they try to reinstall the Windows OS (original version that came with the device or something newer) and it fails because they are using copied software (usually pirated copies!:pirate:). Not saying this is the case with you and your Windows media...but if the shoe fits...

Here's a photo of legit Win7 media from Dell in both DVD and USB flavors:

If the Windows media doesn't look like this or MS retail legit media such as this:
if your Windows media doesn't look like either of these, that's most likely your problem!! Using copies of Windows, legal or pirated from someone else that you didn't personally create is a bad idea! :noway: It's also questionable to download your ISO file that you used to create your own Windows7 64bit bootable media (DVD or USB). There are only a handful of legit sites to get this media from, as Microsoft has scrubbed the Internet clean of illegal or corrupted copies. The best 2 sources are and Digital River--any others I would have to question.:andwhat:

Lastly, if you do have legit MS retail W7 media or Lenovo factory Recovery Media (W7 64bit), and it still doesn't install, you were most likely sold a broken tablet!:waah: And that could be the reason you got it for cheap! :headache: List price on this tablet laptop was $1799; what did you pay for it, and did you buy it new or used???:andwhat:

As far as W8x or W10 media not installing, that could be due to the fact that many PCs and laptops/tablets require a BIOS upgrade? Did you check your version? If you never updated the BIOS yourself nor paid someone to do so, it's probably 7 years old, and obsolete, and therefore could be the cause of newer Windows versions from not installing. It's certainly not a CPU chip problem. Every i3/i5/i7 machine I've ever seen will easily run W8x or W10.

Not being a professional, you certainly haven't tried everything, as you can see from the extensive list of ideas I posted above.

I would recommend you check your Windows media, and if you don't have what I've delineated above, you should buy it, or give up ever getting W7 64bit on that laptop! :worry: If you do have legit Windows media as per above, and it still doesn't work, chances are as I said it's a broken Mobo and that laptop was bad from the day you bought it--especially if it came with W7 32bit on it--that sounds like a sketchy seller to me. All specs I looked up show W7 64bit OS coming from the factory on this machine. That means someone changed it, and resold it as new, and you were most likely hoodwinked! :skull: Whether it was a seller you bought it from, or a Tech you paid to work on it, or a refurbisher, no Bueno there.:rolleyes:

Best of luck,:encouragement:
<<<<BIGBEARJEDI>>>> :usa:

first of all thank you for your response and suggestions. I'll try to react to all of them.

CPU in this one i7-640lm, but that really doesn't matter. I believe it came with 32bit W7 because it originally had just 4gb ram (some of these even with 2gb). I'm not sure about it tho, since it was my work laptop and we push our modified corporate images using a custom wizard with sccm.

TPM is disabled, although it was working fine before. (we use bitlocker or safeguard on older machines)

That answers your other question, I didn't buy it anywhere, it was ordered at lenovo and I'm the one who's been using it since day 1. Now that I don't use it as my backup machine and switched to an x260 I was allowed to keep this one for myself.

I've tried to install Windows from retail DVDs, burned discs (downloaded from microsoft or all in one compilations, which I know for a fact are working) and 3 different usb sticks, created from MS images. The only thing I don't have, is a Lenovo recovery disc. We don't use them.

I haven't tried a network install yet. And I'd like to avoid that. I don't want to use a corporate image, since it comes with a lot of server-side managed policies and mainly the wizard we're using automatically enrolls the PC into AD and a few other databases.

And lastly, flashing bios was the first thing I did, but with no result.

Someone else on another forum suggested trying x64 version of linux, I'll try that and see what happens.


it's working now. Even tho I've tested 4 different ram modules (2 of them new) and they were showing no errors, for some reason none of them worked with any x64 system. That linux idea saved me, because it kept crashing with memory errors, which Windows didn't show. So I've taken a ram module from a spare laptop we have at work and it's working perfectly... I feel like an idiot now.

Anyway thank you all.
Last edited: