Windows 7 Sysprep causes BSOD. SSD fault?


New Member
Jul 8, 2013

Posted this in the Installation & Upgrade forum but might be better here.

My company has about 10 new HP 2570p laptops. These have 128GB SSD.

I have set up two of these laptops in audit mode with all drivers, updates and software configured. I then went to sysprep, selected OOBE - generalise and shutdown.

The first laptop gave me a BSOD preventing Windows from loading in any form.
Took another new laptop and configured everything. Went to sysprep as above, it took some time to sysprep but the laptop finally shut down. Created an image of this SSD in Ghost hoping it was working, but when deploying the image causes other SSD's to BSOD or windows does not load.

I have sysprep'ed our workstations with standard 250GB HDD and they work without problems.

What am I doing wrong? Is this due to SSD's? Any help/advice would be appreciated.
My suspicion is outdated storage controller drivers. It's been my experience that storage controller drivers earlier than mid-2012 are more prone to SSD issues than those released from mid-2012 and later.

Also, there is some suspicion that controller drivers for other controllers on the mobo (those NOT controlling the SSD) may still affect the SSD operation - so updating all controller drivers to mid-2012 or later is advisable. Here's my old canned speech about SSD's:
We've seen a number of BSOD issues with SSD's. Here's the information that I've compiled so far:
There's not a whole bunch available to test SSD's. The "easiest" test is to remove the SSD, install a platter-based hard drive, install Windows and test for stability that way.

Here's some suggestions:
- Update the SSD's firmware to the latest available version (VERY IMPORTANT!!!)
- Update the motherboard controllers drivers to the latest available version from the controller manufacturer (NOT the mobo manufacturer unless you can't find any on the controller manufacturer's website). Be sure to update ALL controllers on the motherboard! I STRONGLY suggest not using controller drivers older than mid-2012 with SSD's.
- Slow the memory (RAM) down to the next slower speed (I've only seen one person who claimed that this worked for them).
- Use any manufacturer's utilities that you may have. If you don't have any, then try this free one (I haven't used it myself): Crystal Dew World
....NOTE: Recently (Nov 2011) we had BSOD issues with the Marvell 91xx controller and an SSD. You may have to switch controllers also.
- Replace the SSD with a platter based hard drive and see if that stops the BSOD's. If it does, then it's likely that there's a problem with the SSD OR an incompatibility with your system.
06 Dec 2011 - This post tends to confirm issues with certain SSD chipsets and certain controllers - [SOLVED] cant find the cause of BSOD F4 - Tech Support Forum
05 Jan 2013 - very interesting post about difficulties with the Marvell controllers even when not connected to the SSD drives: Solved Win8 x64 PC reboots when waking from sleep
27 Feb 2013 - I'm starting to see much better reliability with SSD's using current (mid-2012 and later) storage drivers. I have withdrawn my objections to using these devices in everyday systems.

HP inserts all sorts of storage drivers into their images, and quite a few of them are older.
I try to remove them if they're not actually a part of that hardware - but frequently just leave them alone and hope that they don't cause any issues.

Zip up and upload the memory dumps (from C:\Windows\Minidump) so we can see if this is a storage controller issue - or something else.
Hi Usasma,

Thanks for the reply.

I originally installed all the latest chipset drivers that were available on the HP website. Would that update the controllers?

I've attempted to download the latest firmware for our Samsung MZ7PC128HAFU SSD but it's proving difficult. Used Samsung's SSD Magician only for it to say it was unable to find a Samsung SSD connected. Same with the firmware updates through HP saying incorrect SSD for the update. Therefore, it's hard to say what driver is currently loaded.

I'm sure it is a firmware update that's causing the issue but identifying the older ones is difficult.

Edit: Forgot to say that I can't access any logs as Windows would not load. It would just go round in a loop after failing to start the setup.
Last edited:
It most likely would install the latest drivers - but that depends on the actual date of the drivers.

I went to the HP website and there are 3 different 2570p models
I selected the base model, then I selected Windows 7 Professional (64 bit) for the OS

Storage drivers are a separate download from chipset drivers. Please note that the storage drivers (on the HP website) for the Intel RST date from April of 2012. IMO these are too old for SSD use. HP will most likely disagree with me :0)

You can get the latest version of the RST here:
Did you create Recovery Drives/disks before attempting to sysprep the images? If so, try reinstalling the original OS and see if it works. If the system came with the SSD, this should tell you if the problem is in the system, or in the sysprep image.

In the absence of a recovery drive, try a plain vanilla install of Win7 just to see if it works (no need to activate it). Make sure all devices are OK in devmgmt.msc and that you have all Windows Updates. Again, if this works, then it's an issue with the sysprep image and not the system.

I'd be most concerned about the firmware problems - but suspect that it's that these drives are for OEM's only.
The model number is a Samsung part - but it's not well documented on their website. There are NO downloads available for it.
I'd ask Samsung about it, but I'd expect their answer to be "Ask HP, it's an OEM part so they provide the support."

The absence of a firmware update on the HP website tells me that there isn't an update available that HP considers necessary. In most cases OEM's won't release an update unless they've verified a need for it (it costs money for them to repackage/reissue an update - even if they're using bits from Samsung). I've seen this happen in the past (AMD/Intel processor drivers issue) and it took them a while to verify the need for the fix. Meanwhile those affected had to

In short, if this is a system (hardware) issue, return them to HP and have them send you new one's. If it's a sysprep issue, contact their tech support - they may have seen this problem before (and know of a fix) but haven't gotten around to actually issuing a fix.
Top Bottom