There is no email program associated to perform the requested action

Discussion in 'Windows 7 Networking' started by galets, Sep 9, 2009.

  1. galets

    galets New Member

    Joined:
    Sep 7, 2009
    Messages:
    6
    Likes Received:
    0
    I have been using Vista's "Windows Mobile Device Center" to synchronize my phone to Exchange server using bluetooth. Cannot do this anymore, not in unattended mode. Every time I'm connecting to WMDC using bluetooth, I see following popup:


    This, of course, blocks all the traffic until someone clicks the button. Of course, email program is not needed here, since I am syncing directly to Exchange server. It was not needed in Vista, not in XP, but those two never asked for email program. It has been so annoying that I even downloaded and installed Live Mail, and even configured it as default, but this had no effect on the popup.

    Does anybody know how to fix it? I'm so irritated, it can't be said in any descent expressions
     
  2. gbrayut

    gbrayut New Member

    Joined:
    Jul 21, 2010
    Messages:
    2
    Likes Received:
    0
    I had that same issue, and it actually cause a lot of issues with troubleshooting as it doesn't block traffic but instead redirects it to the localhost (IE: Google redirects to http://localhost/)

    Anyway... The solution that I found was:

    1. Click Start
    2. In the search box enter "Default"
    3. Open the result that says "Default Programs"
    4. Select "Set Program access and computer defaults"
    5. Select Custom if it is not already selected
    6. Under "Choose default email program" select whatever program you want to use
    7. If there are no options, download the latest version of Windows Live Mail. You don't have to configure it, just install it.

    That should fix the problem. You can also change the MailTo protocol handler under the "Associate a file type or protocol with a program" menu to handle mailto hyperlinks.
     

Share This Page

Loading...