Trouble with vhosts in WAMP

#1
Ok, I've searched far and wide (mostly in forums relating to WAMP and APACHE), but I suspect this is related to Win7, so I thought I'd try here.

I've used WAMP for several years, with several vhosts set up on development machines using WinXP, then Vista, and now Win7. This *same* setup worked fine in XP and Vista, but I can't get it to work in Win7 (which is why I'm trying this forum). In this case, I installed WAMP on my new Win7 laptop and copied httpd.conf and httpd-vhosts.conf over from my other laptop running Vista. All versions used in WAMP are the same on both machines. And, of course, I set up the Windows "hosts" file the same also.

I didn't want to post the long httpd file here (unless someone asks for it), but here are my hosts and httpd-vhosts.conf files:

hosts--------------------------------------------

127.0.0.1 localhost
127.0.0.1 test

127.0.0.1 projects
127.0.0.1 webs
127.0.0.1 drupal6
127.0.0.1 stfm
127.0.0.1 abt

127.0.0.1 jdf.com
127.0.0.1 jdf.net
127.0.0.1 d.jdfowler.net
127.0.0.1 old.jdfowler.net

127.0.0.1 litdep.com
127.0.0.1 d.literarydepot.com

127.0.0.1 d.soumpholphakdy.net

127.0.0.1 d.vlfowler.net


httpd-vhosts.conf-------------------------------------------

NameVirtualHost *:80

<VirtualHost *:80>
ServerName localhost
DocumentRoot "C:/wamp/www"
</VirtualHost>

<VirtualHost *:80>
ServerName test
DocumentRoot "C:/Users/Doug/Webs/Drupal-6"
</VirtualHost>

<VirtualHost *:80>
ServerName projects
DocumentRoot "C:/Users/Doug/Projects"
</VirtualHost>

<VirtualHost *:80>
ServerName webs
DocumentRoot "C:/Users/Doug/Webs"
</VirtualHost>

<VirtualHost *:80>
ServerName drupal6
DocumentRoot "C:/Users/Doug/Webs/Drupal-6"
</VirtualHost>

<VirtualHost *:80>
ServerName stfm
DocumentRoot "C:/Users/Doug/Projects/StoryTime"
</VirtualHost>

<VirtualHost *:80>
ServerName abt
DocumentRoot "C:/Users/Doug/Projects/ABT"
</VirtualHost>

<VirtualHost *:80>
ServerName jdf.com
DocumentRoot "C:/Users/Doug/Webs/jdfowler.com"
</VirtualHost>

<VirtualHost *:80>
ServerName jdf.net
DocumentRoot "C:/Users/Doug/Webs/jdfowler.net"
</VirtualHost>

<VirtualHost *:80>
ServerName d.jdfowler.net
DocumentRoot "C:/Users/Doug/Webs/Drupal-6"
</VirtualHost>

<VirtualHost *:80>
ServerName litdep.com
DocumentRoot "C:/Users/Doug/Webs/LiteraryDepot"
</VirtualHost>

<VirtualHost *:80>
ServerName d.literarydepot.com
DocumentRoot "C:/Users/Doug/Webs/Drupal-6"
</VirtualHost>

<VirtualHost *:80>
ServerName d.soumpholphakdy.net
DocumentRoot "C:/Users/Doug/Webs/Drupal-6"
</VirtualHost>

<VirtualHost *:80>
ServerName d.vlfowler.net
DocumentRoot "C:/Users/Doug/Webs/Drupal-6"
</VirtualHost>

-------------------------------------------------

Someone in another forum said I should have all my vhosts in the C:/wamp/www folder, but I don't want to structure it that way. And, as I said, this setup was working fine in XP and Vista, so I'm really hoping to do it in Win7 as well.

I hope someone can help. I've tried so many different things from suggestions in other forums, I really don't know what else to try.
 


kemical

Windows Forum Admin
Staff member
Premium Supporter
#2
Although not my area I've sent a post to a friend who may be able to help..
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top