USB disk detected but not mounted...

Discussion in 'Windows 7 Hardware' started by neousr, Feb 20, 2009.

  1. neousr

    neousr New Member

    Joined:
    Feb 20, 2009
    Messages:
    2
    Likes Received:
    0
    Hi there,
    My problem is quite simple to explain. I have an external HDD (100 Gb size) using an USB interface. When I connect it to my laptop (Sony Vaio CR) with W7, it is somehow detected by the system... it appears in the "Safely remove hardware" application, it does appear under disk drives in the Device Manager, but it is not mounted at all (and no, it does not appear in the disk management application...)

    It is a SATA hitachi disk perfectly recognised by XP. W7 does recognised an old ATA external disk I have.


    Any experience on that? Thanks in advance! :)
     
    #1 neousr, Feb 20, 2009
    Last edited: Feb 20, 2009
  2. intwtl

    intwtl New Member

    Joined:
    Jan 14, 2009
    Messages:
    36
    Likes Received:
    1
    I have the same problem with my Dell Latitude D630 laptop. It will pick up flash drives but will not engage external HD's.

    Having said that my desktop will pick up the external HD's.

    I suspect it is a driver problem and will have to wait for the next Beta release or the final release when sony and dell put out the drivers.
     
  3. jimbo45

    jimbo45 New Member

    Joined:
    Jan 20, 2009
    Messages:
    1,208
    Likes Received:
    41
    Sometimes this is caused by lack of power in the USB slot on the laptop (if your USB drive has it's own power source ensure that it's switched on).

    I find 99% of these problems are solved by using a POWERED USB 4-port Hub-- apart from giving more (and easier access) to the USB slots --especially on small laptops you won't have any power problems abd can connect more devices.

    These hubs are very small and only cost around 10 USD / 6GBP / EUR.

    Cheers
    jimbo
     
  4. intwtl

    intwtl New Member

    Joined:
    Jan 14, 2009
    Messages:
    36
    Likes Received:
    1
    That's usually the case with using only the laptop usb ports.

    I tried 2 different external usb drives (external power) and my Dell D630 didn't want to acknowledge their existence. I tried several different flash drives and the D630 picked up on all.

    When I put my hd with vista back in with the Dell drivers it picked up the external drives. Surely seems to be lacking a driver or ..........

    Thanks
     

Share This Page

Loading...