USB unstable with some devices

amorpheus

Senior Member
#1
Stuff connected to USB on my PC:

Keyboard (G15)
Mouse (MX518)
external HD (WD Passport)

Those function perfectly and I have not had any form of error. However, my iPhone and camera (Casio Exilim) both have a very unstable connection - they will always connect and be recognized fine, but most of the time as soon as the connection is used it will disconnect in the middle of the process. The camera usually locks up and has to be reset by removing the battery.

Does anyone know how to fix it? I'm running an i7 system on an X58 chipset (Asus P6T Deluxe).
 


#2
USB instability

I am seeing this also. I purchased an external Seagate HD, and had issues where Win 7 would not keep it alive. It would forget it was there, or it would completely dissapear, or I would get a message that the hardware had a problem and was not accessable. It works fine on an XP system. Similar issue when ipod is connected via USB.. it loses it after a while or has trouble accessing it.

AMD Phenom 9500 Quad Core 2.20ghz
8 gig ram
MSI motherboard / Nvidia chipset drivers
eVga 1 gig 3D card.
 


#3
This is most likely one of those things that will be fixed by the Retail (unless of course there's a solution available already).. ;) It is definitely frustrating in the meantime though..

The only USB device I had mess up on me with Windows 7 was a mouse but I blamed that on the mouse itself as it was ancient and was problematic in Windows XP as well.. ;)
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.