Win 7 Install not finding hard drive - clean install on new hardware

Discussion in 'Windows 7 Installation' started by gbasile77, Dec 6, 2009.

  1. gbasile77

    gbasile77 New Member

    Joined:
    Dec 6, 2009
    Messages:
    6
    Likes Received:
    0
    Hi,

    I spent the afternoon putting together my new PC:

    Intel i5, GB P55-UD3, Seagate 500gb SATA, my optical is an IDE. All brand new virgin hardware (except the ide optical obviously).

    Everything went well, POST with no problems and everything is looking good in BIOS: CPU, RAM, HDD optical all showing up correctly.

    Next when I install and boot from the win 7 64-bit install disk, after a long time I get enter my language preferences, then i get the error that windows cannot find my HD or any drive suitable to install on and am prompted to install the drivers.

    I then browsed for the drivers, trying either swapping out the win 7 dvd for the mobo driver or having the mobo drivers on a usb. Unless I unselect the "hide drivers that are incompatibe with my hardware" option I fail to find the drivers even though I know they are there by browsing cd on another machine. Weird anyway coz they are the drivers that came with the mobo, and also tried downloading drivers from the gigabyte website but they don't work either.

    Ok, so with the "hide drivers that are incompatibe with my hardware" unselected I get a list of about 8 drivers on the screen to choose (either from USB or swapping cd). They all seem to have the word "RAID" in them which doesn't seem right as I am not running RAID. I have tried selecting all of the drivers buty windows doesn't like any of them.

    I have read the numerous forums regarding similar problems with XP, but none of the suggestions regarding BIOS settings have helped. In BIOS I have tried everything of the 2 SATA config options I can see.

    I had an old XP disk I tried to install that two, after about 2 hours of formatting the drive I get a similar error where I am told XP cannot format the drive.

    Any ideas where I am going wrong??

    Thanks,
    John
     
  2. persistent

    persistent New Member

    Joined:
    Dec 3, 2009
    Messages:
    4
    Likes Received:
    0
    Hi John.

    AFAIK, there are no special device drivers to select for the SATA interface during Win7 install.

    The problem might be a bad hard drive.

    Could you:

    a) Move the new Seagate 500 gig drive to another SATA capable computer, to verify it is functionally is OK?

    OR

    b) Temporarily install a different SATA drive in your virgin computer and re-attempt Win7 installation? Of course the install process would destroy all files on the temp hard drive, so use one which can be sacrificed for this purpose.

    Good luck.
     
    #2 persistent, Dec 6, 2009
    Last edited: Dec 6, 2009
  3. gbasile77

    gbasile77 New Member

    Joined:
    Dec 6, 2009
    Messages:
    6
    Likes Received:
    0
    Hi,

    Thanks for your excellent suggestions.
    One thing I did realise is that the HDD is plugged into the intel chipset controlled sata port on the mobo, rather than the Gigabyte mobo sata plugs, didn't even realise this until now (first build).

    When prompted for the drivers I had the Gigabyte drivers rather than the intel ones, could this be the cause? It is better to use the chipset controlled SATA ports? Maybe I could simply switch the sata plug over to test it.

    If the HDD was bad, would it still appear in the BIOS?

    Thanks,
    John
     
  4. gbasile77

    gbasile77 New Member

    Joined:
    Dec 6, 2009
    Messages:
    6
    Likes Received:
    0
    Figured some stuff out, but still cannot get anywhere.
    I tested my HDD in my other pc and it was fine, formatted it and everything.
    After realising the difference between on-board SATA and intel SATA I set up the BIOS to have the intel at ACH (long night, you know what I mean), and then switching the onboard to IDE (CD-ROM is IDE and plugged in there) it looked much more promising. Whilst booting, I could see it flash something about intel sata controller. Now when win 7 comes to the bit where it can't find drivers and i point it to the intel drivers on my USB it says the drivers are compatible with the hardware but when I click next it thinks for a bit and doesn't get anywhere. Stays on that screen with no drives detected.

    To eliminate problems I have read about having mixed IDE and SATA, I pulled my SATA CD-ROM from my other PC and tried that. I completely switched off the on-board SATA and switched everything to the intel sata ports. Still no luck, same as before when win 7 cannot find the drives and doesn't seem to do anything when I point it to the drivers on my usb.

    As another step I switched everything from the intel sata to the Gigabyte sata ports and adjusted bios settings, while it is booting up i can see black screen flash with something about Gigabyte SATA controller. When Win 7 still can't recognize the drive and i point to the gigabyte drivers on my PC still no luck.

    Surely this can't be that hard can it? I have pretty much tried every combination there is available.
     
  5. nitewulf

    nitewulf Honorable Member

    Joined:
    Oct 20, 2009
    Messages:
    64
    Likes Received:
    4
    Obviously your HD is ok. I think it is simply a matter of loading the right drivers at setup. I had a similar problem with an older Asus MB. None of the drivers on the MB CD or Asus' site would work. I did extensive Google searches and finally found the drivers I needed (XP drivers worked fine). In my case, I was using the onboard Promise 376/378 Fastrak controller. Once I found the correct drivers I needed, the SATA drive was immediately recognized. I may be wrong and there could be other issues here, but I think it's just a matter of finding the right drivers. Look at the MB manual and write down all the controllers that are listed
    and try to find the ones you need. You mentioned if you explore the MB cd on another pc there are drivers available. You may need to use another pc to locate the drivers and burn them to a floppy, cd or flashdrive as appropriate.
     
  6. bitumen

    bitumen New Member

    Joined:
    Jan 9, 2009
    Messages:
    48
    Likes Received:
    0
    As you mentioned Try setting the bio setting
    treat harddrives as "IDE"
    to
    treat as "AHC"

    And then installing using only the default windows drivers, see if that gets you there...
     
  7. cybercore

    cybercore New Member

    Joined:
    Jul 7, 2009
    Messages:
    15,823
    Likes Received:
    321
    If neither switching to AHC (may not be reserved in your bios) nor installing drivers helps, consider updating the bios.
     
  8. Gonzord

    Gonzord New Member

    Joined:
    Dec 13, 2009
    Messages:
    2
    Likes Received:
    0
    I have a possible solution

    Your problem sounds like a problem that I've had for the last two days. Except I was building two systems with the exact same parts and ran into the issue with the second computer. Once again involving a GB motherboard and Seagate hard drive. I tried switching the hard drive into the working computer to see if it was a motherboard issue but got no result until I deduced it must be some faulty hard drive. But you'd think the BIOS would know better than to detect a faulty hard drive. I even managed to format the hard drive using the Win 7 Cd, no luck there.

    I came across your site and countless others until I had a moment of clarity and realised the hard drive is not being recognised because it has no partition. Zilch, nada, nothing. I then immediately hopped onto the pc and entered the disk partion through the cmd line. http://www.microsoft.com/resources/documentation/windows/xp/all/proddocs/en-us/diskpart.mspx?mfr=true

    Step 1 - 'Select Disk 0' (type LIST DISK to find the disk number)

    Step 2 - 'Clean Disk 0'. I ran a clean to reset all the bits on the hard drive (it took 4 or so hours on a 1TB HDD, so you might want to try the other steps and come back to this if it doesnt work).

    Step 3 - 'Create Partition Primary'. This will instantly create the partition for you. After which you will be able to see the drive in the list so that you're able to select it, and possibly to advanced actions on it (Format, New Partion, Delete etc). you may need to delete the partition while in the list and create a new one while on that menu.

    Step 4 - Select the partition and install Win 7. WOOOOOOOOOOOOOOOOOOT.

    Anyway I thought I'd share the love even though its 4am and I should really be getting to bed.

    Let me know how you go with this.

    Cheers,
    Gonzord :razz:
     
  9. msosin

    msosin New Member

    Joined:
    Dec 22, 2009
    Messages:
    6
    Likes Received:
    0
    Hi
    I have a similar problem.
    During instalation of windows 7 64bit edition I get pass the step with language and keyboard selection and then win7 installer fails to detect any hard drives.

    I have 3 hard drives, two of them (identical) in RAID configuration connected to sata ports, other normal IDE mode conected to sata port.
    Currently I have windows XP 32bit installed on my system and everything works fine. HD are not faulty. During instalation of win XP i just had to upload RAID drivers from floppy disc to get it work.

    Of course I tried to upload SATA RAID drivers during instalation of windows 7, but none of the drivers I've downloaded seems to be working.
    I have gigabyte GA-MA790X-DS4 motherboard with AMD SB600 chipset (that's the one controling raid I guess) and i tried to download drivers from gigabyte website. I tried those for windows vista and windows 7 64bit edition and none of them works.
    After uploading drivers, win installer still fails to detect any of my hard drives.

    Can anyone help?
    I think the solution of both problems desribed here is finding the right driver but still i failed to do so.

    Marcin
     
  10. Nibiru2012

    Nibiru2012 New Member

    Joined:
    Dec 16, 2009
    Messages:
    466
    Likes Received:
    18
    I have a Gigabyte motherboard also. I have the main drive plugged into the port 1 on the Intel SATA and the DVD drive on port 6. I have set the mode to AHCI and no legacy drives. I also have the Gigabyte controller set to AHCI for my external eSATA ports.

    During boot up the Intel controller shows both the hard drive and the DVD drive. The Gigabyte controller shows the external eSATA drives. Go into your BIOS and look at the boot priority screen and see if your drives are showing up there. Be sure your main drive is the set as the first hard drive to boot. Set your DVD drive to boot first, at least during the install process.

    Are you setting up partitions? Did you notice Windows 7 sets up a 100MB partition automatically?
     

Share This Page

Loading...