Win 7 Prof - Not recognizing any IDE or Virtual Drives

#1
This topic might be a repost, please forgive me for being a noob...

Does anyone on here use Windows 7 Professional? I installed it (legally) from XP using a CD and now it wont detect any IDE CD ROM drives or any Virtual drives. I've tried using two seperate CD drives, and Windows will not update my drivers. I have tried uninstalling the devices, then restarting. When I do that, Windows tried to detect the devices but says it was unsuccessful at installing them. I can't even create and virtual drives using Daemon tools. Ive checked Windows Updates and there are no critical patches that I have failed to install.

Is this a common issue? Anyone seen this before? Any common solutions?

Thank you in advance for any answers.
 


zigzag3143

Honorable Member
Microsoft MVP
#2
Well for starts Daemon tools uses a file that is a known problem from many stand points (SPTD.sys) Second MS and most of us recommended a clean install specifically to prevent issues like this. How old are the IDE drives?


Ken J
 


#3
It looks like this suggestion from another forum worked for me...

FYI for anyone else with this problem.

If you're still having issues, try deleting the upper and lower filters from the registry. Using regedit.exe as Administrator, navigate to -

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\

and scroll down the entries in the left window until the top line in the right window shows DVD\CD ROM Drives. Now delete the entries in the right window that say Upper Filters and Lower Filters. If these aren't listed, then, well, this won't fix it...

Uninstall the drive again from Add/Remove Hardware and reboot, Windows will find the drive and update the registry, possibly fixing the issue.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.