Win7 Windows Task Scheduler, when running silent, also suppresses sound

#1
I had found that, to not have my programs visible in the TaskBar
(ie: DSNTODAY), I must, in the General Tab, select 'run whether user
is logged on or not'. Unfortunately, tho logically, this also seems to
apply to sound (ie: the Win32API BEEP and MESSAGEBEEP). When I select
'run only when user is logged on', it works properly (my NOTIFY program,
which can beep if DSNTODAY finds an executable with todays' date; I use
Audio, then Visual, cues).

Is there a way to allow sound, even just a YES or NO, perhaps via a
Registry tweak? Otherwise, I start my program via Startup which, like
any typical program, appears in the TaskBar. I'd rather do that then
pop up a brief window every 5min w/WTS; plus, I get better granularity
(ie: I can run every minute). Can I hide my program in the TaskBar
even tho it's not part of SysTray (notification area)?
 


#2
It appears that running under the GUEST logonID also suppresses sounds, as my program works
properly (ie: audio beeps) ONLY when run under an ADMIN logonID!?
 


MtheK

New Member
#3
Interesting that Windows' own ECHO also FAILS to beep under the GUEST logonid,
but sounds fine under my ADMIN logonid: ECHO Ctrl-G ENTER

Under GUEST, Control Panel/Sound/Sounds/Default Beep/test works properly.

What Registry tweak/whatever? is blocking ECHO, and therefore, my program?
 


MtheK

New Member
#4
FINALLY!!! I was able to get a sound by using PLAYSOUND over BEEP and MESSAGEBEEP,
so, at least MY program NOW has sound under the GUEST LID, unlike ECHO !!!
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.