WIndows 7 64 bit wont boot without CD in drive!

Jynx

New Member
#1
So installed Windows 7 64 bit without issues. Everything is running great. When I reboot the computer however I recelive errors that the BOOTMGR is missing and it wont boot. If I insert the DVD and reboot then Windows 7 loads fine.

This was a clean install. I am not dual booting any other OS.

How can I fix this?

Thanks a bunch.
 


Last edited:

davehc

Essential Member
Premium Supporter
#2
Maybe that is a laptop with one of those leading partitions on it? Load up from your DVD and then download and install EasyBCd. It gives you the option to rewrite the boot manager, with any parameters you wish
 


Last edited by a moderator:

Jynx

New Member
#3
Its a Desktop. I went ahead and booted to the DVD and started the repair options. I ran repair on startup and it found the errors "Boot Manager Unable to Locate OS" and it ran through a lot of repair options but it didn't fix the problem. I'll try BCDedit.

I installed EasyBCD.

Here are the current settings. I don't see the problem.


Entry #1
Name: Windows 7
BCD ID: {current}
Drive: C:\
Bootloader Path: \Windows\system32\winload.exe
Windows Directory: \Windows
 


davehc

Essential Member
Premium Supporter
#4
Go to "Manage bootloader" and see if you can reinstall it. Take the option to backup your old manager, just in case! But, I remember from earlier Vista days, that for some reason, if I did it from the install disk, I usually had to do it a couple of times, rebooting between each, before it seemd to "grab" the correction.
 


Jynx

New Member
#5
I tried that. No change.

Now though it boots up to an error page that says

"Windows Failed to start" and then says something about \boot\bcd
 


Jynx

New Member
#6
I think I found the problem but I don't know how to fix it.


C:\Windows\system32>bcdedit /enum
Windows Boot Manager
--------------------
identifier {bootmgr}
device partition=H:
description Windows Boot Manager
locale en-US
inherit {globalsettings}
resumeobject {9732c2ac-b5cc-11dd-b78d-e3d049e8cf05}
displayorder {current}
toolsdisplayorder {memdiag}
timeout 3
Windows Boot Loader
-------------------
identifier {current}
device partition=C:
path \Windows\system32\winload.exe
description Windows 7
locale en-US
loadoptions DDISABLE_INTEGRITY_CHECKS
inherit {bootloadersettings}
recoverysequence {9732c2ae-b5cc-11dd-b78d-e3d049e8cf05}
recoveryenabled Yes
osdevice partition=C:
systemroot \Windows
resumeobject {9732c2ac-b5cc-11dd-b78d-e3d049e8cf05}
nx OptIn



Some how the Boot Manager is on Drive H:\ and not on C:\
 


davehc

Essential Member
Premium Supporter
#7
Go to "Change settings"
In the "Drive" box, change to C:\
Save settings.
If that does not work, try "Diagnostics centre"
Recreate the missing/deleted boot files.
 


#8
I think I found the problem but I don't know how to fix it.


C:\Windows\system32>bcdedit /enum
Windows Boot Manager
--------------------
identifier {bootmgr}
device partition=H:
description Windows Boot Manager
locale en-US
inherit {globalsettings}
resumeobject {9732c2ac-b5cc-11dd-b78d-e3d049e8cf05}
displayorder {current}
toolsdisplayorder {memdiag}
timeout 3
Windows Boot Loader
-------------------
identifier {current}
device partition=C:
path \Windows\system32\winload.exe
description Windows 7
locale en-US
loadoptions DDISABLE_INTEGRITY_CHECKS
inherit {bootloadersettings}
recoverysequence {9732c2ae-b5cc-11dd-b78d-e3d049e8cf05}
recoveryenabled Yes
osdevice partition=C:
systemroot \Windows
resumeobject {9732c2ac-b5cc-11dd-b78d-e3d049e8cf05}
nx OptIn



Some how the Boot Manager is on Drive H:\ and not on C:\
i have the same exact problem. i originally installed the OS on the wrong partition (the 460GB partition) instead of my OS partition (40GB). so i went in and installed it again on the correct one. then i noticed that when i started the computer it told me i had two OS to choose from (both were called Windows 7). i tried formatting the large partition. it was then that i noticed that i couldnt start the computer without the disc in the tray or i would get the "BootMNG" message. so i formatting all partitions and starting fresh. i installed it on the correct partition and still the same message without a disc.

i suppose i can try this EasyBCD thing, but i really dont know how to use it. ill update with anything i find.
 


reghakr

Essential Member
#9
EasyBCD is very easy to use. I've used it in the past to fix somone's computer.
 


#10
EasyBCD is very easy to use. I've used it in the past to fix somone's computer.
-.- thanks, thats helpful.

anyway, ive noticed something else weird. the small drive is now called C: where it used to be O: because all it had was the Operating System. now it has the OS as well as the usernames, my documents, ext. so now D: (which used to be C:) is completely empty. how do i fix this, both the BOOTMNG problem and i want the OS to be on the small partition and my profiles and usernames, ext to be on the C: drive.

EDIT: i just realized something that might be important. i forgot that i had installed a 40GB IDE drive inside my computer over a year ago and ive just ignored it and forgot about it. im pretty sure thats were the OS is installed now. ill be on later today to update
 


Last edited:
#11
Possible Fix

Hi, I just fixed same/similiar issue by (I found, that you are missing 'path' setting too on enums):
bcdedit /set {bootmgr} path /bootmgr

Concrete issue was, that system halted without any action.

Now I am able again to boot.

I am not sure about reason - Enable administrator password / Install sw / Standby restore.

Another symptom was, that:
bootrec /RebuildBcd
Did not find any instalations. :confused:

EDIT:
Finally the problem seems as HW + Win update related, sorry for OT.
And the correct solution was command bootrec /fixboot
 


Last edited:
This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.