Windows 7 and XP Networking

Discussion in 'Windows 7 Networking' started by Penguin, Jun 8, 2009.

  1. Penguin

    Penguin New Member

    Joined:
    Jun 8, 2009
    Messages:
    12
    Likes Received:
    0
    I have viewed many other threads here but none of them have solved my issue. Anyway, I have a lappy with Windows 7 and a desktop with XP. Both are on the same router. When I go to network view on the Win 7 computer I can not see the computer but I can see the Windows Media Player sharing item. I cannot see the folders I have shared with everyone on the XP nor the Win 7. Any suggestions? :confused: I thought I was fairly good at networking but I guess not. :frown:
     
  2. BurrWalnut

    BurrWalnut Extraordinary Member

    Joined:
    Nov 14, 2008
    Messages:
    97
    Likes Received:
    13
    If you want everyone to have access, this procedure will make the computer a little less secure but it works because no passwords are used and everyone is allowed access. There are three basic steps; put the computers in the same workgroup (discretionary), select the folders that are to be shared and ensure the firewall allows access. Repeat this on all the computers, use the same workgroup name but, of course, different, meaningful computer names.

    XP
    1. Add an XP computer to a workgroup by right-clicking My Computer > Properties > Computer Name and change the default Workgroup Name and Computer Name. The computer should reboot.
    2. To share an XP folder, right-click it and select Sharing & Security > Sharing Tab > and put a check mark in Share this folder on the network and optionally, Allow Network users to change my files. Type in a Share Name > Apply > OK. A little hand should appear on the icons of the folders that are shared. Alternatively, drag the folders you want to share to the Shared Documents folder. In XP Professional you may have to turn off Simple File Sharing in Folder Options > View Tab > Advanced Settings at the end.
     
    WIN 7
    1. Add a Windows 7 computer to a workgroup by going to Control Panel > All Control Panel Items > System > Advanced System Settings (in the left pane) > Computer Name Tab > Change, type the Computer Name and Workgroup Name. > OK. The computer should restart.
    2. First of all, go to Control Panel > All Control Panel Items > Network and Sharing Center > Change Advanced Sharing Settings and make sure you have Network Discovery, File and Printer Sharing and Public Folder Sharing all set to ‘On’ and Password Protected Sharing to ‘Off’.
    3. To share a Windows 7 folder, right-click it > Properties > Sharing Tab > Advanced Sharing > Share this folder > Apply, OK > Close. Two little people should appear on the icons of the folders that are shared. An alternative way of sharing is to drag the folders you want to share to the Public folder.
    4. As you don’t have Password Protected Sharing turned on, you have to change the security permissions on your folder(s) to allow Everyone access. Right-click the shared folder > Properties > Security Tab > Edit > Add and type ‘Everyone’ (not the quotes) into the box and OK. Tick the boxes next to the permissions you want to allow (e.g. Read or Write, etc.) then Apply > OK, etc. You may see some screens coming up with message 'An error occurred while applying ……..'. This is not unusual and can be ignored by clicking Continue.

    BOTH
    Windows firewall is normally set to allow file and printer sharing but if you have a third-party firewall make sure file and printer sharing is enabled so that each machine can talk to the other(s). Don’t disable the Windows firewall if it’s the only one you’re running.
     
  3. Penguin

    Penguin New Member

    Joined:
    Jun 8, 2009
    Messages:
    12
    Likes Received:
    0
    Gosh, I did all of that and nothing changed. Both computers are on the same newsgroup. I have my firewall set on office/file sharing (Ive always used that and it did not give me an issue when networking XP and Vista). I do not know what to do. :frown:

    EDIT: Ok, now I got it to show public sharing folders on the XP but still nothing on the Win 7 computer expect the WMP sharing item.
     
    #3 Penguin, Jun 8, 2009
    Last edited: Jun 8, 2009
  4. BurrWalnut

    BurrWalnut Extraordinary Member

    Joined:
    Nov 14, 2008
    Messages:
    97
    Likes Received:
    13
    In Network and Sharing Center, does it show as a Home network and Ready to create for Homegroup? Remember Homegroup will only work between Win7 computers.
     
  5. Penguin

    Penguin New Member

    Joined:
    Jun 8, 2009
    Messages:
    12
    Likes Received:
    0
    Yes, it says Ready to create a Homegroup. :)
     
  6. BurrWalnut

    BurrWalnut Extraordinary Member

    Joined:
    Nov 14, 2008
    Messages:
    97
    Likes Received:
    13
    Does it show as Home network in the main window under your network name?
     
  7. Penguin

    Penguin New Member

    Joined:
    Jun 8, 2009
    Messages:
    12
    Likes Received:
    0
    That it does. :)

    What the heck!? Its working now...
     
    #7 Penguin, Jun 8, 2009
    Last edited: Jun 8, 2009
  8. BurrWalnut

    BurrWalnut Extraordinary Member

    Joined:
    Nov 14, 2008
    Messages:
    97
    Likes Received:
    13
    Straw-clutcher - try rebooting.

    Remember that some AV programs have a mini firewall, which one are you using?
     
  9. Penguin

    Penguin New Member

    Joined:
    Jun 8, 2009
    Messages:
    12
    Likes Received:
    0
    F-Secure on both PCs.
     
  10. BurrWalnut

    BurrWalnut Extraordinary Member

    Joined:
    Nov 14, 2008
    Messages:
    97
    Likes Received:
    13
    That’s not one I’m familiar with, have you looked at their forum regarding Windows 7?
     
  11. BurrWalnut

    BurrWalnut Extraordinary Member

    Joined:
    Nov 14, 2008
    Messages:
    97
    Likes Received:
    13
    I'm missing your replies as you are editing the posts rather than writing new ones.

    Is it perfectly OK now?
     
  12. Penguin

    Penguin New Member

    Joined:
    Jun 8, 2009
    Messages:
    12
    Likes Received:
    0
    Its working now (like I said earlier) so I better count my blessings and quit messing with that. Thank you for the help BurrWalnut. :)
     
  13. BurrWalnut

    BurrWalnut Extraordinary Member

    Joined:
    Nov 14, 2008
    Messages:
    97
    Likes Received:
    13
    I'm glad it's working, well done.

    I was beginning to doubt my 'Everyone' approach, which works on XP onwards.
     
  14. stueycaster

    stueycaster Millennium Celebration Award Winner
    Premium Supporter

    Joined:
    Feb 5, 2009
    Messages:
    1,519
    Likes Received:
    53
    It's normal for networks to take time to start up.
     

Share This Page

Loading...