Windows 7 Constant Activity

I just bought a new computer a few days ago. This computer was loaded with Vista originally, and while I had Vista for the FEW days I had it (I had to get off!) I noticed that the CPU was constantly being used in a process called SearchIndexer.exe. My laptop's activity light was constantly flashing no matter what I was doing.

Let's just say I'm a little activity light OCD -- when I'm doing nothing, I want the light to not be blinking.

I've noticed, that since I've upgraded to Windows 7, the light is constantly blinking too, which is something I'm not used to coming from Windows XP. Is this normal? It seems SearchIndexer.exe is still running, but not as hard. Also, a host process alway seems to use a lot of memory.

I have enclosed a picture(s) of my running processes via task manager. Any help I can get regarding this issue will be greatly appreciated!

(Note: I know I have firefox, digsby, iTunes, and other personal processes running, but this happens even when Windows 7 starts up and I have no personal processes running).


Extraordinary Member
Any programs you have installed which require updates, will cause activity. But these will also be seen on your internet connection light.
What is causing your activity, in this case, as you have said, is the search index.

This is considered a top feature by most users. The activity will die down to a minimum after some use, but will always reactivate when you are using the hard disk, in order to reindex new items. The usefullness of the feature is that it gives you alomost instant access to any item on the hard disk - if you know what you are looking for! For example, you could type "Paint" in the Start box, and the program would open instantly.

I have little use for it, with my own method of searching, so I have disabled it in the services. This means that it defualts to the obsolete and clumsy, original XP search. Your choice.

If you really want to disable it,:
1. Click on Start button, type Services in Start Search box.
2. If User Account Control asks for permission, click Continue.
3. Scroll down to Windows Search. Right click on Windows Search, and then select Properties .
4. Click on Stop button to stop the indexing service immediately.
5. On the Startup Type dropdown box, select Disabled.
6. Click on OK button.

You can reenable it by changeing back the Startup Type.

As a preerence,you candisable indexing on certain portions of your computer. Be warned, though, that it takes a long time to apply new attributes to all files, folders and sub-folders.

1. Open Windows Explorer from Accessories.
2. Right click on the drive (or drive letter) that you want to turn off the indexing.
3. Select Properties on the contextual menu.
4. Unselect (untick) the Index this drive for faster searching option.
5. Click Apply or OK button.

To re-include the drive, select the option again.

HD always working ? disable "SearchIndexer.exe", disable Defrag, disable Windows Denfender... no more HD working all the time :)


Extraordinary Member
Woh there. Take it easy. We are dealing in these forums with users at all levels. It really bad advice to suggest turning off Windows defender, (or Defrag for that matter) without qualifying your comment.

if he's using an anti-virus then there's no reason to keep Windows Defender running.
About the defrag, this app always sucked ass in Windows. Better to use an third-party defrag. There are at least a couple freeware defrag apps out there.

... update ...
I'm sorry for anything I've said.

if he's using an anti-virus then there's no reason to keep Windows Defender running..
Windows Defender isn't Anti Virus it's anti spyware software. If you remember back to your first install of Vista or Seven when windows first starts you are hit with warnings about anti virus even though Windows Defender is enabled by default.

This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.