Wired Internet was working. Not connects to "unknown public network" with no internet access.

Discussion in 'Windows 7 Networking' started by MrActuary, Apr 9, 2010.

  1. MrActuary

    MrActuary New Member

    Apr 9, 2010
    Likes Received:
    I have an Acer Aspire M5800-U5801A desktop purchased in late 2009. Onboard Intel® 82567 Gigabit Ethernet Controller. Originally came with Vista and upgraded to Win7 through Acer's free upgrade program. All features of the system were operating without noticeable issues until recently.

    I put the computer to sleep/hiberate every night. Woke up one morning a few days ago and noticed there was a bland screen I'd never seen before which simply read that there was a "fatal error" and that the system could not come out of hibernate and instead was rebooting. Don't know if this is relevant but figured it could be more than a coincidence. Note that pretty much right after this (maybe with 24 hours) was when the internet stopped working. Also I noticed that since this error, the system takes noticeably longer to boot up. I believe a screen appears briefly saying something about Eagle BIOS with a message saying something like NOT AUTHORIZED TO DISMANTLE/ASSEMBLE that had never appeared before. After this the normal Acer screen appears that I had been used to seeing on bootup. Again, this may be unrelated but I'm trying to give every possible bit of info I can think of to fix this problem.

    So when Win7 loads, it searches for a network and instead of my normal homegroup, finds an "unknown public network" with no internet access. Diagnosing says that the system cannot connect to the gateway device and says to reboot cable modem. This leads to no success. Checking the driver shows it's up to date, the device is working properly, etc. Running IPConfig shows that it's connected to Comcast, there's a default gateway(4 sets of numbers), shows "MEDIA DISCONNECTED" on two lines, there is an ipv4 address. I thought my modem might have broken since it was from 2003 so I went to Comcast and got a brand new Motoralla and new wires/cables and the problem remains exactly the same, so I'm totally out of ideas now.

    One other issue that may have relevance. when I went into BIOS, the Onboard LAN Option ROM was disabled and grayed out with no ability to enable it.

    Does anyone have any ideas what went wrong? Seems so strange that the internet would be working 100% fine and now cannot connect. Is it possible the onboard card itself died? I'd think if Win7 could detect it and says it's working properly then no, but I'm not an expert.
    #1 MrActuary, Apr 9, 2010
    Last edited: Apr 9, 2010
  2. qazdawg

    qazdawg New Member

    Apr 23, 2010
    Likes Received:
    heres what i did when my ethernet and wireless stopped working, and it fixed it.
    Go to Network and sharing center.
    Click "change adapter settings"
    It should show your wireless and LAN (Local Area Network) connections.
    Right click LAN and click on "Properties" (Make sure you are using an admin account)
    Click on internet protocol version 6.
    At the bottom, a new option called "Properties"
    Click on that.
    Make sure that the cicles "Obtain ipv6 address automatically" for both.
    Hit ok and then click on "Internet protocol version 4"
    Go to properties.
    Make sure that those same cicles are marked.
    Click ok and close out of LAN, but not Adapter settings.
    Right click on "Wireless Network"
    Click properties and do the same thing that you just did for LAN.

    This should work, depending on if that was the problem or not.
    It worked for me, so i hope i helped
    -ChriS, ComputeR WiZ In TraininG

Share This Page