x64 Slow Resume From Sleep

#1
I have been trying to find a solution to this problem on a number of forums, but I haven't had much luck.

Recently, my computer has been very slow to resume from S3 sleep. Specifications of my desktop can be found here: TechComet: My Gadgets.

I updated my BIOS and this may have caused the problem, however I updated to a more recent "beta" version and it is still taking a fairly long time.

Before, I would hit the power button and my desktop would resume in a couple of seconds. Now, on average, it takes about 30s.

I have tried disabling ALL running applications and pulling out all my peripherals (external HD, keyboard, mouse, etc.) and it still takes a long time.

I recently re-installed Windows 7 and it is still taking about 30s.

I have a feeling that the problem is either with the BIOS or some drivers. However, as far as I know everything on my computer is up to date.

Any suggestions?

Thanks!
 


zvit

Honorable Member
#2
First, try without any external devises or drives connected to the computer.

This is something that was written by someone else but I'm not sure it applies to you:

Turns out that the problem was caused by the SATA driver acoustic management mode. When I enabled the AMM using the checkbox in the driver page, there was always some sort of delay when booting, and a really long delay when waking from S3 sleep.

When I unchecked AMM, the problem went away and everything seems to work fine now.
 


#3
Thanks

Have tried pulling out ALL external devices and terminating all running processes - no effect.

I did an extensive search for AAM, but came up with nothing similar to that on my computer.
 


zvit

Honorable Member
#4
There are SO many solutions to this problem, instead of posting tons of solutions here, you can look at the list and try some. If you need more help, tell us what you did so far:
Let me google that for you
 


#5
Well I did go through everything and I have tried everything:

1. Updated all drivers (including BIOS) - I reformatted my PC so everything is up to date.
2. I pulled out ALL my peripherals (i.e. no USB drives were plugged in)
3. I terminated all running processes
4. I defragmented both my HD and my SSD and ran a "chkdsk" scan.
5. I ran anti-virus scans.
6. I checked my power options - I turned off hibernate and "hybrid" sleep.

I understand that many people post on these threads without first looking for answers themselves, but I can tell you that I have tried everything that I could possibly find. There may easily be something that I missed, and I would appreciate it if someone could point it out to me, but right now I have no idea what I need to do.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.