📎 AI Summary:
A user reports that after successfully running XAMPP, their MySQL server stops unexpectedly shortly after startup, with error logs attached. Attempts to resolve the issue include suggestions like changing configuration settings, but the problem persists, prompting the user to seek further help. Community members recommend examining the error logs and posting the issue on the official XAMPP support forum for more targeted assistance.

webdeveloper

New Member
Member details
Joined
Jul 24, 2022
Messages
6
Thread Author #1
I had recently installed XAMPP on my laptop and everything was working fine till today even I had created also started creating my website on localhost, but today when I opened XAMPP and started Apache Server then it was started normally but when I tried to start MySQL then it was started but after 5 seconds it stopped suddenly and now it was not starting. See the image below for more information about the error and you can find error logs in the below attached file:

An image from 'MySQL not running in XAMPP'. XAMPP panel shows Apache running but MySQL failed to start due to an unexpected shutdown.
 

Attachments

Last edited by a moderator:

Mike

Windows Forum Admin
Staff member
Premium Supporter
Member details
Joined
Jul 22, 2005
Messages
9,269
Try removing

innodb_rollback_on_timeout=ON

from your config

or set it to OFF

Possible solution
 
Solution

webdeveloper

New Member
Member details
Joined
Jul 24, 2022
Messages
6
Thread Author #4
I had recently installed XAMPP on my laptop and everything was working fine till today even I had created also started creating my website on localhost, but today when I opened XAMPP and started Apache Server then it was started normally but when I tried to start MySQL then it was started but after 5 seconds it stopped suddenly and now it was not starting. See the image below for more information about the error and you can find error logs in the below attached file:

View attachment 40589
I tried many things and lastly, I found solution to it, but that solution does not seem to be permanent solution, the error appears again n again, I request you all to pls suggest some sure shot solution for this
 
Last edited by a moderator: