Windows Defender randomly turns off..

Discussion in 'Windows 7 Help and Support' started by ooja3k, Feb 17, 2009.

  1. ooja3k

    ooja3k New Member

    Joined:
    Jan 10, 2009
    Messages:
    16
    Every once in a while I get a notification the the action center saying that Windows defender is turned off and to click here to turn it on.

    I turn it back on every time, but it still seems to turn itself off randomly.


    Is anyone else having this issue??
  2. iroken22

    iroken22 New Member Premium Supporter

    Joined:
    Nov 10, 2008
    Messages:
    1,654
    go to start and in the search box type services.msc and hit enter. Now search for the windows defender service and ensure that it is set to automatically start on startup.
  3. KnickKnack

    KnickKnack New Member

    Joined:
    Nov 27, 2009
    Messages:
    4
    I also have this problem. Whenever I reboot my computer an error message saying windows defender is not turned on pops up. I click turn on and it does so. But it keeps coming up every time I reboot. I think it all started after an update to windows defender failed. The service is set to automatic. Is there any way to suppress this error message or get windows defender to stay turned on?

    Edit: Even though I set the service to automatic it keeps switching back to manual. I tried to to start it from the services panel and it popped up an error message saying that the service started and stopped. Are there other services that Windows defender might depend on that somehow got turned off?
    Last edited: Nov 27, 2009
  4. Saltgrass

    Saltgrass Excellent Member Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    14,224
    Are you folks running any other type of anti-virus or spyware. If so, that may be turning Defender off.

    Also, go to the event viewer and see if anything is showing up there.
  5. KnickKnack

    KnickKnack New Member

    Joined:
    Nov 27, 2009
    Messages:
    4
    I'm running AVG Free 9.0, but it hasn't conflicted with defender before this. I never use defender so I wouldn't mind figuring out a way to just make this error message stop instead of getting defender to turn on. Not much to report from event viewer other than defender being enabled and disabled several times.

    Edit: Solved my own problem, since I don't need it to work I just stopped defender from running on startup.
    Last edited: Nov 27, 2009
  6. RAK

    RAK New Member

    Joined:
    Jul 6, 2009
    Messages:
    2,502
    I am not sure if stopping it at startup, will avoid the popup, but it seems to have worked for you. But if you wish, it is easy enough to turn off the popups. They are mostly being generated by the Action centre. I do not have any use for this facility, and have it also turned off. But if you open the "Notification Area" you can select the Action center and click " Hide Icon and Notification"
    Alternatively, you can open the action centre in the Control panel and change the options for notification.

    edit later. I didn't address the thread title. Several Antimalware programs are turning off Defender by default. The latest AVG, is one of such. Microsoft security essentials turns it off also, by default. If you are running a third party anti-malware, you do not really need defender and best to totally disable it through "services.msc"
    Last edited: Nov 28, 2009
  7. Mitchell_A

    Mitchell_A Windows Forum Admin Staff Member Premium Supporter

    Joined:
    Feb 7, 2009
    Messages:
    5,108
    Location:
    Nova Scotia
    Just set it to disabled in services.msc, it doesn't do much anyways/
    Or download Microsoft Security Essentials which replaces both your anti-virus + windows defender.
  8. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,221
    Location:
    Erie, PA
    If you have a good spyware protector,. you don't need it.

    When I installed my software,. Windows said to turn Windows Defender off.

Share This Page