Access XP "Workgroup" share from W7 "Domain" machine.

Discussion in 'Windows 7 Networking' started by Nang, Jan 22, 2010.

  1. Nang

    Nang New Member

    Joined:
    Jan 22, 2010
    Messages:
    2
    Likes Received:
    0
    This question or a similar one has ben asked on here and other places but no one seems to have any idea. So this will probably go unsolved like many other windows 7 issues but here goes. I'm happy to award 8 internets to anyone who has any ideas about resolving this issue.

    Have a windows 7 pro machine which is part of a domain. User ONLY has domin login. ONLY admins have local machine access. When user takes windows 7 machine home and connects to network at home they cannot access any files on their XP "Workgroup". On the XP pro machines browsing the network shows the domain (Because the domain joined machine is now on the same network) and also shows the domain joined machine. All machines can ping each other. When attempting to connect to an XP machine that is sharing both folders that require a login and those that dont (everyone full access) the user is greeted with a login prompt. User has a login in lusrmgr.msc on the XP machine attempting to be accessed. This login works from the other XP machine. Does not work from the domain joined windows 7 machine. No login in lusrmgr on the windows 7 machine or the windows xp machines work when attempting to access that xp machine. Tried various login incarnations as the users login is automatically tried (DOMAIN\User(which is in the xp machines lusrmgr users list)) Tried XPMACHINE\User, .\User, \User, IP.ADDRESS\User \\XPMACHINE\User \\IP.ADDRESS\User. All obviously to no end. Using an XP machine joined to the same domain, with the same login credentials, logging onto the same "Workgroup" works perfectly everytime using the users domain login credentials. At this point I'm assuming that microsoft has removed all ability to acces a workgroup share from a domain joined W7 machine and I should possibly be advising the company to roll back all W7 machines to XP so basic required functionality is restored.

    BACKSTORY: User works for an accounting firm whose staff visit several customer sites to perform assorted tasks with the customers accounting "company files". Internet access is used at all sites so laptops are joined to the network. easiest option would be to use the same network to access the "company files" as opposed to copying to portable media and then back again once changes are made. The moving process also halts any other users from making changes whilst the accountant is editing their version of the file as the restored file will not have the changes made to the original during that period.

    1 fix given was to rename the "Workgroup" to the same name as the domain. This is not practical accross serveral "Workgroups" especially if they are not owned by the user.
    link-> Sharing "domain" & "workgroup"

    A few similar questions asked on this forum never resolved or answered
    Link-> http://windows7forums.com/windows-7-networking/7094-work-domain-screwing-up-home-network-attempt.html
    Link-> http://windows7forums.com/windows-7-networking/1315-damn-you-microsoft-2.html
    Link-> http://windows7forums.com/windows-7-networking/7075-switched-domain-workgroup-can-longer-log-onto-computer.html

    /rant
     
  2. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    OK, I've read this four times now, and I'm not sure why the XPmachine\Username and password doesn't work and without knowing what domain environment these machines are actually in and what possible array of associated group policy objects / OU memberships may be impacting their ability to avail themselves of external (not domain) network resources by way of alternate (not domain) credentials I really don't have an answer. But I might suggest a not so elegant and possibly not so desireable work around. Would it be possible for these users on these particular travelling laptops to have a local login to resolve to a local user account on the local Windows7 laptop with the necessary permissions to locally stored files and folders. I believe that would take the laptops domain membership out of the equation and allow these users to still get their respective work done when out of the office. Like I said, probably far from a preferred solution but a possible option. I know that I have a Windows 7 pro machine joined to my SBS 2003 domain and I can still logon to my wife's XP pro(non domain member) machine from the Win7 machine using the XPmachine\username without issue. However, I cannot say that this resolves because her workgroup name is the same as the actual domain name or rather because I have no GPOs or complex OUs outside of the default domain policies.
     
  3. davezor

    davezor New Member

    Joined:
    Feb 11, 2010
    Messages:
    2
    Likes Received:
    0
    Possible fix for your problem

    I don't have a Windows 7 machine but I have had similar problems with Vista in the past. It could be related to NTLMv2 authentication that comes with Vista and Windows 7. XP still uses v1. I had to make similar changes to get a vista machine to work with a Samba share running an old flavor of linux.

    Here's one of many links that come up when you search on it.

    Vista NTLM Setting
     

Share This Page

Loading...