Ad Hoc Internet Connection Sharing?

Discussion in 'Windows 7 Networking' started by istosevski, Jan 10, 2009.

  1. istosevski

    istosevski New Member

    Joined:
    Jan 10, 2009
    Messages:
    2
    Likes Received:
    0
    Help Setting Ad Hoc Internet Connection Sharing?

    It was easy for me to share my wired internet connection in Vista SP1 through ad hoc network. (see screen shot)
    But in Windows 7 the internet sharing option is gone...
    Any ideas how to share Internet connection over ad hoc in W7?
    I'd would be grateful for any feedback on the subject...
     
    #1 istosevski, Jan 10, 2009
    Last edited: Jan 11, 2009
  2. cocaine

    cocaine New Member

    Joined:
    May 16, 2009
    Messages:
    4
    Likes Received:
    0
    1. Go to Control Panel > Network and Internet > Network and Sharing Center

    2. Under Change your networking settings, click Set up a new connection or network

    3. Select Set up a wireless ad hoc (computer-to-computer) network

    4. Enter your Network name, and enter a Security key if wanted

    5. Check the box for Save this network and click Turn on Internet connection sharing on next page


    I hope this helps as it worked perfect for me.
     
  3. Schnoeddel

    Schnoeddel New Member

    Joined:
    May 17, 2009
    Messages:
    2
    Likes Received:
    0
    Good morning!
    I did exactly as described in the last post but i dont have any "turn on internet connection sharing" on the "next page" .

    I have set the ICS option at my Broadbad connection and chosen my wireless lan as network, as i know it from winx.

    I have created a Wireless Ad-Hoc Network to my laptop and the connection works. The only thing that does not work is the ICS, i just cannot connect to the internet from my laptop. I tried to create new wlans, tripplechecked all settings. I go crazy guys :(
     
  4. cocaine

    cocaine New Member

    Joined:
    May 16, 2009
    Messages:
    4
    Likes Received:
    0
    After the first time I clicked it, it no longer shows for me either. This might be the same thing that has happened, or somehow yours was already enabled?
     
  5. Manic

    Manic New Member

    Joined:
    May 29, 2009
    Messages:
    10
    Likes Received:
    0
    hmmm weird mine shows up allright.. im using a belkin wireless as the second connection and it shares it ok to my vista machine.
    The only weird thing is that although the belkin supposedly supports WPA, windows only offers WEP encryption (which is crap if you didnt know already)... anyone has similar issues? even in normal situations with no ICS enabled etc?
     
  6. Manic

    Manic New Member

    Joined:
    May 29, 2009
    Messages:
    10
    Likes Received:
    0
    nevermind, it seems that the problem must lie with the 64bit drivers for the belkin, as when I create a WPA-personal adhoc on my laptop, w7 cant connect to it saying that theres no hardware capability.

    Btw.. have you guys tried turning on ICS by right clicking on the internet connection (e.g. the ethernet) on the host machine, and enabling ICS there? this is actually the official way of doing it according to MS.
    On 7 you go to control panel->network & internet ->network and sharing center->change adapter settings and right click on the internet adapter (meaning the adapter that pumps internet to the host machine, not the adapter used for the adhoc.)->properties->sharing and tick the relevant box.
    It will then reconfigure the adhoc adapter (e.g. your wireless usb or whatever) to have a LAN address, and then you should be able to connect to the adhoc and the net. If not, check your firewall FIRST before blaming windows.
     
  7. m107

    m107 New Member

    Joined:
    Aug 6, 2009
    Messages:
    4
    Likes Received:
    0
    I have the same problem , after more than 5 hrs googling, did not find any ...
     
  8. sinnerman

    sinnerman New Member

    Joined:
    Aug 15, 2009
    Messages:
    2
    Likes Received:
    1
    I had the same problem.
    This is the solution I implemented.

    1) Open Network and Sharing Center
    2) Go to Change Adapter Settings
    3) Find the adapter for the default internet connection (it was a PPPOE in my case)
    4) Right click on that -> Cancel as Default Connection
    4) Right click -> Properties -> Sharing tab
    5) Uncheck "Allow other network users to connect ..." if it is not
    6) Setup the ad-hoc as cocaine explained in the previous post, the Turn on Internet connection sharing should appear

    Hope it works for you
     
    1 person likes this.
  9. m107

    m107 New Member

    Joined:
    Aug 6, 2009
    Messages:
    4
    Likes Received:
    0
    Thank you, but i did all and my problems did not solved :(
    As i said before i did all the standards ways to share, but it does not works
     
  10. mayankiny

    mayankiny New Member

    Joined:
    Aug 19, 2009
    Messages:
    2
    Likes Received:
    0
    thxx

    hey i did what u say, & it works just fine......!!
    thx....:p
     
  11. msnslag

    msnslag New Member

    Joined:
    Oct 6, 2009
    Messages:
    2
    Likes Received:
    0
    Just turn on ICS as maniac do and then check that the network adapter on the computer(s) that you want to use the
    shared internet connection is set to "Obtain an IP address automatically". That worked for me.
     
  12. Archangel

    Archangel Honorable Member

    Joined:
    Aug 22, 2009
    Messages:
    130
    Likes Received:
    4
    I just thought I should point out that this issue was fixed between the 7100 and 7600 builds of the RC and RTM respectively. This is one of those things that we need to consult the build logs for... ;)

    It might be helpful in the future for everyone to point out what build version of 7 is being used.
     
  13. houtman

    houtman New Member

    Joined:
    Nov 7, 2009
    Messages:
    2
    Likes Received:
    0
    hi guys i wanna ask you something
    my windows 7 is the host
    and there is no option
    "Set up a wireless ad hoc (computer-to-computer) network"


    there are only 4 other option
    "connect to the internet","setup a new network","connect to a workplace","setup a dial up connection"

    would someone give me the complete instruction for LAN and ICS
    windows 7 as a host and windows vista as the client...
    thanks before
    maybe you can send me at archiemaru_ritsu@yahoo.com

    i'm using a simple ethernet cable between 2 pc
     
    #13 houtman, Nov 7, 2009
    Last edited: Nov 7, 2009
  14. yoshy262

    yoshy262 New Member

    Joined:
    Nov 18, 2009
    Messages:
    4
    Likes Received:
    0
    Hello, everybody.

    I try the solution posted below but after I restart my pc wireless connection is not working till I delete old ad-hoc connection and reconfigure like below.

    Any solution for this error?

    I've tried with firewall enable/ disable and windows defender disable = same issue.
    After reboot the ICS is not working and wireless is not active till I remake the settings.

    Thank's in advance.


     
    #14 yoshy262, Nov 18, 2009
    Last edited: Nov 18, 2009
  15. yoshy262

    yoshy262 New Member

    Joined:
    Nov 18, 2009
    Messages:
    4
    Likes Received:
    0
  16. Cab

    Cab New Member

    Joined:
    Nov 23, 2009
    Messages:
    12
    Likes Received:
    0
    I have the same problem. Works when I set it up, but when I needed it a day later it's not sharing the connection, and it doesn't say why! And I thought network sharing was hard to set up in XP, that it had become easier with Vista/7. Well well...
     
  17. Archangel

    Archangel Honorable Member

    Joined:
    Aug 22, 2009
    Messages:
    130
    Likes Received:
    4
    Now, now, now folks. Let's not get fast on the start and start blaming an operating system for a problem that could mistakenly end up being an "Operator Error".

    From what I'm understanding, people are setting up an ADhoc connection, enabling connection sharing, disconnecting from the connection. Then when they try to connect again, it's not working? There's a number of problems with this, most of them needing more information to solve the issue:

    • In Windows 7, ADHoc connections are not automatically saved unless you click, "Save Connection" as you are creating it. When you restart your computer, you will need to make the connection again if you did not previously save it.
    • The connection, although saved, is not meant to automatically resume everytime you and the other computer are in range - this functionality is currently only available for infrastucture connections. This means you'll have to reconnect everytime you want the connection to be shared again, i.e. after each restart, etc. (I say currently because this feature may be added with time and service packs, per customer interest and input.)
    So I guess my question is this: Which builds of W7 are you using? As I've posted before, some of these bugs and issues have been fixed in more recent builds. :confused:
     
    #17 Archangel, Nov 29, 2009
    Last edited: Nov 29, 2009
  18. Cab

    Cab New Member

    Joined:
    Nov 23, 2009
    Messages:
    12
    Likes Received:
    0
    I am using Windows 7 Ultimate, the final version. Regarding the first point, heh, yes. The thing is that IF you save the connection, next time you will have to delete it and recreate it, so it is better NOT to save it. As for the second point, that is not what is happening. The network is waiting and then I explicitly connect to it on my other device, and it does recognise the other machine. The problem seems to be with internet connection sharing, at least for me. I am beginning to think it's some stupid IP assignment error and the OS is so kind as to not report such a thing to me. I will continue investigating this issue.

    Oh, and using the task scheduler does what I do, but automatically, so that is a workaround.
    *waits for win7sp1
     
    #18 Cab, Nov 30, 2009
    Last edited: Nov 30, 2009
  19. Archangel

    Archangel Honorable Member

    Joined:
    Aug 22, 2009
    Messages:
    130
    Likes Received:
    4
    Okay I see. Are you using W7 Ultimate Final on the host or the client machine? What OS is the other machine using?
     
  20. Cab

    Cab New Member

    Joined:
    Nov 23, 2009
    Messages:
    12
    Likes Received:
    0
    I'm using W7 on the machine that is supposed to share the broadband connection. Then I have tried both with my laptop (Windows Pro XP SP3) and my mobile (Symbian). I still suspect it's the IP assignment on the host machine though, as somehow recreating the network each time always work, but by simply using a saved network say next day, will let me reach the host but the internet connection sharing is not working. Manually doing the IP assignment might work... will have to try that.
     

Share This Page

Loading...