Ad Hoc Internet Connection Sharing?

Archangel

Honorable Member
#21
I'm using W7 on the machine that is supposed to share the broadband connection. Then I have tried both with my laptop (Windows Pro XP SP3) and my mobile (Symbian). I still suspect it's the IP assignment on the host machine though, as somehow recreating the network each time always work, but by simply using a saved network say next day, will let me reach the host but the internet connection sharing is not working. Manually doing the IP assignment might work... will have to try that.
Understood. Yes, please try setting up the IP's manually, that might work. Perhaps you've discovered a bug that they might be able to squeeze into the next service pack.
 


#22
this thread has been a life saver for me and my room mates but now there seems to be a glitch
before i could easily set up an ad hoc connection with the internet sharing option by following the steps outlines by sinnerman

1) Open Network and Sharing Center
2) Go to Change Adapter Settings
3) Find the adapter for the default internet connection (it was a PPPOE in my case)
4) Right click on that -> Cancel as Default Connection
4) Right click -> Properties -> Sharing tab
5) Uncheck "Allow other network users to connect ..." if it is not
6) Setup the ad-hoc as cocaine explained in the previous post, the Turn on Internet connection sharing should appear

now i am able to set up a wifi ad-hoc connection between the laptops (and iphone) but am unable to share the internet.

previously i could see a "sharing" tab in the properties of my Ethernet adapter (Marvell Yukon 88E8057 PCI-E Gigabit Ethernet Controller) for ICS control which i didnt actually fidget with
by following the instructions on this thread but now i'm stuck.

each time i set up an ad hoc connection the wizard takes me right through on to the usual steps (password set up etc) but skips the "sharing internet connection" dialog box directly to the end informing me about sharing my public folders. this with the missing "sharing" tab makes me think there has been some screw up in the sharing options but i have no clue how to fix it.

any help on the matter would be most appreciated!

btw i'm on a vaio with windows 7 home basic (if that helps).

thanks
 


#23
hi all,

i found a way to auto connect (via cmd) to adhoc networks in windows 7 :p

* create a profile like you do for a hotspot
* after that ->
* start cmd. enter netsh goto wlan
* export profile "yourcreatedprofile"
* edit the exported profile in notepad.exe
* replace
* <connectionType>ESS</connectionType>
* with
* <connectionType>IBSS</connectionType>

*
* back in netsh type ->
* add profile "yourcreatedprofile"
* connect "yourcreatedprofile"
* voila ;)

now you can use the commandline to connect like in Vista

have fun
inteks
 


Last edited:
#24
If you don't see the button "Turn on Internet Connection Sharing", that mean the ICS is turned on before.
To see the Button again:
- go to the Network an Sharing Center >Manage Network Connections,
- Right click on the Wireless Adapter chose Propertise
- In the Sharing tab, uncheck the box "Allow other network users connect...." then Click OK.(Sometime I don't see the Sharing tab, I don't khow why , but when I Uninstall/Reinstall the Wireless driver, it appears :D)
- Recreat new Ad-hoc and you'll the button "Turn on Internet Connection Sharing" again
 


#25
Yes it seems that the solution is to first UNCHECK internet connection sharing

Yes it seems that the solution is to first UNCHECK internet connection sharing, thanks.
 


#26
I had the same problem.
This is the solution I implemented.

1) Open Network and Sharing Center
2) Go to Change Adapter Settings
3) Find the adapter for the default internet connection (it was a PPPOE in my case)
4) Right click on that -> Cancel as Default Connection
4) Right click -> Properties -> Sharing tab
5) Uncheck "Allow other network users to connect ..." if it is not
6) Setup the ad-hoc as cocaine explained in the previous post, the Turn on Internet connection sharing should appear

Hope it works for you

Thank U so much. It's successful
 


liridonk

Well-Known Member
#27
About Ad Hoc or Virtual AP

Hi everyone

in my email i have atached an advanced software for sharing any internet connections to unlimited computers,
through Wireless USB Adapters, Lan Cards 10/100 mbps or bluetooth etc...
it's a 1 MB software and it is so easy to configure also i have keygen for this software
anyone who need this software you can email me at [email protected]
this software costs 20 euros
i am online at GMT+1 ( Central European Time) for helping remotely to any users ;)
you can pay me by Western Union or my Swift Code Bank
thanks
 


#28
That was the perfect answer. I was struggling with this for months. Kudos! Just make sure that you give sharing to the host computer, in my case the broadband connection. then the laptop connected perfectly. You're brilliant. Thank you.
 


#29
[langtitle=ru]Re: Ad Hoc Internet Connection Sharing?[/langtitle]

Вот я решел это проблема очень простой способом:
Например в ноутбуки1 стоит Windows 7 и выходить интернет через 3G модемом. Ему надо сделать общие доступ для WI-FI или для LAN. модемные подключение>свойства>доступ>разрешать доступ>применить!
Теперь подключаем другое ноутбук2 через WI-FI на этот ноутбок1. Думаю в предидущие сообщиних есть решение как подключить.
Теперь нужин интернет на ноутбук2 через подключение WI-FI от ноутбук1.
Надо узнать DNS address от провайдер. например MTS.RU вот здесь оттуда перезодим на на эту адрес и в этом страницы есть такое надписы:
DNS servers
ns.mts.ru. 194.54.148.129
ns2.mts.ru. 194.54.148.5 (можеть узнать с один звонками на провайдер)
вот эти ip адресы нам ОЧЕНЬ надо их надо записать для wi-fi подключиние.
Состояние > Свойства > Протокол Интенет версие 4 (TCP/IP4)> Свойства
напишим ip адресы в строки DNS серевер. а потом ОК и веселемся за подключении интенет на ноутбук2
PS. это решение можно использовать для все машины и ОС.
 


Attachments

Last edited:
#30
HI,
I have the same problem... everything works fine but in the next page im not getting "turn on internet sharing'' ....
i went through the whole thread and googled too but couldnot find any solution...
please somebody rectify it....:(
 


#31
[langtitle=ru]Re: Ad Hoc Internet Connection Sharing?[/langtitle]

[lang=ru][QUOTE = vikrama87; 226611] HI, у меня такая же проблема ... все работает нормально, но на следующей странице им не получить "свою очередь на интернет-обмена''.... я прошла через всю нить и Гугл тоже, но couldnot найти любое решение ... пожалуйста, кто-то ее исправить ....:([ / QUOTE]

Именно какое проблема подробно напишите. было бы хорошо с рисунками[/lang]
 


#32
Sorry to bring this up again but I've been having the same issue for a while. To describe the problem, I have my Win7 computer sharing the internet (ICS) on its wireless adapter. I also have a WinXP computer that would like to connect to the Win7 wireless adapter, obtain an ip address, and surf the net. Every time I try to do this there are problems and it has gotten to the point of just not working. The first time I set this up Win7 did great and asked me what adapter the wireless adapter should use for its internet source. It also asked me whether I like like to enable internet sharing on the device as I setup the ad-hoc network through the wizard. I though wow this is freaking easy. So it works until the computers get shutdown and for whatever the reason the Win7 computer seems to forget its settings. So now (months later) the Win7 computer doesn't ask me anything when setting up the network as it did before. And it seems it doesn't matter if I have ICS on and enabled for that device it still doesn't send out an ip address.

Things I have done. On the Win7 computer I setup an ad-hoc network with the proper security settings and got everything up and running OK network wise. Internet sharing is enabled in the service manager and on the device. Automatic DHCP is also enabled on this device. Is this correct?

I have also disabled my firewall as a precautionary measure but still a no go.
 


#33
Forget it. I just ended up buying a hub/switch and I'll play with that.
 


#34
If you don't see the button "Turn on Internet Connection Sharing", that mean the ICS is turned on before.
To see the Button again:
- go to the Network an Sharing Center >Manage Network Connections,
- Right click on the Wireless Adapter chose Propertise
- In the Sharing tab, uncheck the box "Allow other network users connect...." then Click OK.(Sometime I don't see the Sharing tab, I don't khow why , but when I Uninstall/Reinstall the Wireless driver, it appears :D)
- Recreat new Ad-hoc and you'll the button "Turn on Internet Connection Sharing" again
This didn't work in my case, am I doing something wrong?
 


#35
Re: thxx

Hello Frnds

I M use Windows 7 Prof.
i have NETGEARE Adapter

How to make wireless connection using netgare adapter

PC TO Mobile
 


#36
Re: thxx

Hi,

I have just read the first page and Internet Connection Sharing ICS works just fine.

Thanks.
 


#37
i'm having the same problems but I may have partially figured it out. when i go to the sharing tab inside the properties of my internet connection it says as the Home networking connection a different name than the one that the ad hoc connects to and i can't change it to the right one.
 


#38
ok, I'm not too sure as to how I did it but I'm now getting the option to allow ICS when setting up an adhoc, I'll try to explain it but its a bit vague. So I went to the network connections page and right clicked on the internet connection and chose diagnose. after the program finished checking for problems it said something about not finding the original gateway, something like that. I'm sorry I can't be more specific than that.
 


#39
Re: thxx

Thanx mate tat worked just fine :)
 


#40
I had the same problem.
This is the solution I implemented.

1) Open Network and Sharing Center
2) Go to Change Adapter Settings
3) Find the adapter for the default internet connection (it was a PPPOE in my case)
4) Right click on that -> Cancel as Default Connection
4) Right click -> Properties -> Sharing tab
5) Uncheck "Allow other network users to connect ..." if it is not
6) Setup the ad-hoc as cocaine explained in the previous post, the Turn on Internet connection sharing should appear

Hope it works for you
This fix works just fine!!
Thanks a ton!! :)
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.