Administrator, part of Administrators group, somehow lost admin access!

Discussion in 'Windows 7 Help and Support' started by marvelousdan, Mar 8, 2010.

  1. marvelousdan

    marvelousdan New Member

    Joined:
    Mar 8, 2010
    Messages:
    4
    Likes Received:
    0
    Hi everyone,

    ------------------------------------------------------
    Edit: by the way it's my first time posting on these forums, so hello everyone, nice to meet you. Hopefully someday I can be on the other side of the support role for this OS ;). Thank-you in advance for reading my post and offering any help!
    ------------------------------------------------------

    I'm sure you've heard of this one before, but after following threads from multiple forums and all their suggestions, I'm still no closer to a solution -- in fact I'm farther from it if anything (I recently lost access to even view the properties of My Computer). It all started the other day, after a night of Office 2007 updates the next morning my msn wouldn't sign in, I didn't have access to load Windows Explorer from the quick launch bar, and I couldn't do any admin task. I use this PC as a development machine at work, and use IIS 7.5, Visual Studio 2005, and Visual Studio 6. These were all installed at least a full day and I still had admin access, so I don't think the installation of these caused a problem.

    I've tried multiple things as I've said from many different sources, included changing registry settings to re-enable the UAC (just clicking the UAC in the Start Menu, it won't load...) I've ran the secedit command, I was even going to chance the Owner of the C:\ from TrustedInstaller to Administrators (and add TrustedInstaller there just to be safe) - but I lost access to view properties of My Computer this morning. I'm at wit's end here, and am very close to uninstalling windows 7. Can anyone offer any suggestions to how to debug my problem, or at the very least how to actually gain control over my C:\! I don't even care what caused this issue to begin with anymore, I just want it resolved.

    If you need anything to help me with this problem please let me know. I can get you a view of my EventVwr, any other log files you think will help, etc.

    Is it possible a Windows Update caused this?? And no I don't have a virus scanner installed so this isn't an issue. Also I'm very limited in my debugging options right now: As Administrator I can't even check Disk Management.
     
    #1 marvelousdan, Mar 8, 2010
    Last edited: Mar 8, 2010
  2. marvelousdan

    marvelousdan New Member

    Joined:
    Mar 8, 2010
    Messages:
    4
    Likes Received:
    0
    I've lost hope for Windows 7, I can't seem to solve this issue and from what I've read there hasn`t been a conslusive and consistent solution to the Administrator no-access issue. I`ve tried running the repair utility from the Windows 7 disc, I`ve rebooted to Safe mode and ran the TakeOwn command to try and set the Administrators group as owner, I`ve tried Disabling and mucking with the UAC local security policies in the Local Security Policy snap in. I`ve created new Admin access accounts under the Computer Management. On top of it, the problem is inconsistent in what it denies access to: for instance, I can`t right click Computer and click properties. I get an access denied message. But I can open Computer and click System Properties at the top to load the same window fine. And any icon with a Shield next to it, meaning a need for admin rights, most times nothing happens when I click it. and Yes the Administrator (who I`m logged in as), and my Admin account (another administrator account) are both in the Administrators group. Oh well, back to Windows XP for another few years I guess! They`ve made Windows 7 far to needlessly complex in my opinion. Thanks anyway for anyone who read this, and hope you manage to somehow fix this problem if it occurs to you. good luck

    Edit: I know there`s only 6 hours between my first post and this one, but I was trying to fix this issue for days before making the first post (wanted to make sure I tried what there was to try myself first).
     

Share This Page

Loading...