Advanced boot options does not start.

Discussion in 'Windows 7 Hardware' started by mar6, Apr 15, 2016.

  1. mar6

    mar6 New Member

    Joined:
    Apr 14, 2016
    Messages:
    3
    Likes Received:
    0
    Hello, i have hp/compaq dc7800 pc and win7 ultimate 32bit. I try to go to advandced boot options (hitting f8 at startup), but i only get keyboard error. (42 301 keyboard error) In windows it works ok.
    I have tested this pc with 4 keyboards and results are all same. Other win7 computer boots ok to that menu with those keyboards. I have 100mb system reserved partition and c partition. Do i need some other recovery partition to get it working?

    Thank you.
     
  2. holdum333

    holdum333 Banned

    Joined:
    Mar 27, 2016
    Messages:
    1,244
    Likes Received:
    147
  3. holdum333

    holdum333 Banned

    Joined:
    Mar 27, 2016
    Messages:
    1,244
    Likes Received:
    147
    #3 holdum333, Apr 15, 2016
    Last edited: Apr 15, 2016
  4. mar6

    mar6 New Member

    Joined:
    Apr 14, 2016
    Messages:
    3
    Likes Received:
    0
    That solution didnt work :(

    F9 goes to boot device selection menu
    F10 goes to bios. If i push that button, then sometimes (but not always) about 1 second it shows that keyboard error again and then goes to bios.
    F12 goes to network, but i dont know how to use it.
    F11 does nothing, goes to windows without error.
    Other F keys are showing that error.

    In windows other keys are working normal, have not seeing something unusual.
    In event viewer are only some wifi startup problems, no other info there.
    It is very strange problem.
     
  5. holdum333

    holdum333 Banned

    Joined:
    Mar 27, 2016
    Messages:
    1,244
    Likes Received:
    147
    Hi You say "That solution didn't work"?? Which one didn't work? How many did you try??
     
  6. mar6

    mar6 New Member

    Joined:
    Apr 14, 2016
    Messages:
    3
    Likes Received:
    0
    Sorry i was sleepy. :)
    I talked about that link from Your second post. I tested that space bar button pressing, but it didnt work. Other things from that post i have tryed earlier with no good results.

    Edit: msconfig work, but i still need that "F8 menu."

    Edit2: I tryed again with F8 and it worked. Then tryed second time and worked again.
    After that i tried 10 more times and same keyboard error. I pushed F8 same time and same speed as earlier but nothing.
    It seems like somekind of hardware problem.

    Edit3: Okay, i putted in usb keyboard and f8 worked ok. (Tested atleast 15 times)
    So conclusion is that problem is in ps2 port ?
    But if problem is in ps2 port, then how other buttons are working ok?
     
    #6 mar6, Apr 16, 2016
    Last edited: Apr 16, 2016
  7. BIGBEARJEDI

    BIGBEARJEDI Honorable Member
    Premium Supporter

    Joined:
    Jan 28, 2013
    Messages:
    1,805
    Likes Received:
    219
    It could be that the windows driver for your ps/2 keyboard has become corrupted, and that's why it works in windows but not on startup. There are a couple of ways to fix this; usually run the SFC /SCANNOW command in an elevated Command Prompt window as Administrator. That's the System File Checker; it's good to run that first to see if the default ps/2 keyboard driver in windows has been compromised somehow. SFC can make that determination and repair the file by overwriting with a fresh copy. You may not care about fixing that since you got it working with the usb keyboard, but that's an answer to your question. That problem is usually repairable through software. If not, it's quite likely that the one ps/2 port or both *that model PC seems to have 2 ps/2 ports as was standard on older hardware* is or are bad. Since those ports are hardwired into the Motherboard; the fix at that point requires complete Motherboard replacement.

    <<<BIGBEARJEDI>>>
     

Share This Page

Loading...