Cannot access existing XP network

Currently I have an internal network (no internet access), with a few XP workstations conencted via a hub, working fine. When I added a Win 7 computer, it cannot connect to the network. It says "unidentified network" and when I run troubleshooter, result is "does not have a valid IP configuration." Note that all the XP computers are using the NetBIOS protocol; TCP/IP is not selected.

For the Win 7 computer I have done the following steps:
It is NOT on homegroup.
It is named the same workgroup as the other computers.
I disabled both Windows and McAfee Firewalls.
I tried enabling and disabling Net BIOS over TCP/IP.
I cannot ping the router IP
I cannot ping any of the other XP computers.


Noob Whisperer
This is likely the result of your network adapter failing to communicate with whatever (on your network) is providing DHCP, (probably your router?).
use a command prompt on the problem computer and type
ipconfig /all
and hit enter
you are probably going to see an APIPA address something like 169.254.nnn.nnn with no default gateway.
You have a couple options
1. Let us know what adapter you are using for this connection (model name, model number, version number) and make sure you have the latest driver from the card manufacturer. (Not from Windows Update)
2. Assign the ip addressing scheme manually to static values in keeping with those present on other machines on your network. If you need some help with that post back with the IP addressing scheme of a working computer on the network and we can help.
Welcome to the forums.

ipconfig of Win 7 computer shows:
Gateway: blank
Adapter: Realtek PCIe GBE Family Controller (driver date 3/4/2010, version 7.17.304.2010).
That's the one thing I didn't do was update the adapter driver; should've done that before I troubled you guys! I'll try that.
As far as the static address, another working computer has an IP add of

Last edited:


Noob Whisperer
I have that same adapter and am currently using (1/26/2011) seems OK but I think there is even a newer one than that. Check RealTek's site and see for sure.
You may still have an issue even after the driver update, depending on you router firmware. So if you still seem to be having the same problem even after the update of the driver, Post back and we can try a couple other things.
Additionally, if you want to go the static route
you'll need to determine what the other machines are using for a default gateway and a DNS server address (maybe the same address).
Then use that information as a template. Keep everything the same except the actual IP address, it has to be unique on the network so as to avoid conflicts.
Subnet mask
Default Gateway
DNS servers prerferred and alternate should be the same across network nodes.
Probably something like will probably work it just must be unique on the network.
Keep us posted.
P.S. That is an APIPA address ( and the missing default gateway is causing the "unidentified network" issue.


Noob Whisperer
Link to latest driver for that card.
7.46.610.2001 (6/10/2011)

Hi. The updated driver didn't work. Also, all my other XP computers have blank for the default gateway but they are all working fine. So what should I enter for the Win 7?

Another update. I have also swapped out the ethernet cable, no avail. Then I thought it was the NIC itself, but I can use it to access the internet (when I cable it to our internet router).
So, after typing in various sets of IP addresses, I have some network access but:
1. It still says Unidentified Network/ Public Network. So I have to manually change it to Work Network.
2. Then all of a sudden I can see the other computers, but then when I refresh the other computers are gone.
3. Troubleshooting doesn't identify any problems now (no longer says IP add not valid).
I used:
IP Add:



Noob Whisperer
Without a default gateway computers are restricted to traffic on their own subnet so if all of your computers are currently using an APIPA addressing scheme on a 169.254.nnn.nnn subnet with a clase B mask. Then you should be alright as long as you don't want to access the internet or anything outside your network.
Enable NETBios over TCP/IP under the wins tab, in the properties of IPv4, in the properties of your network adapter and then
services.msc into the search or run dialog box and hit enter
scroll as needed and find
double click it
set the startup type to automatic
and start it.
I'm kinda confused because in your original post you said that you couldn't ping the router. What's that there for if it's not providing a default gateway nor evidently DHCP?
And I could have sworn that in a subsequent post you noted a normal private resevered class C address of 192.168.1.nnn, but it seems that that post was edited and now your claiming at least one other network node with an APIPA address. So which is it, is everything 169.254.nnn.nnn with a class b subnet mask, or is it just one other, you can't ping outside your subnet without a default gateway, however you should be able to ping any other computer with a similar 169.254.nnn.nnn address as long as both are masked the same (Class B mask)
I need you to straighten me out here, because I'm missing something somewhere.

Sorry for the confusion. In my original post I mention that it is an internal network, no internet access, and another post I said that the XP computers do NOT have TCP/IP enabled, only Net BIOS. I accidentally listed a 192.168.1.nnn address but quickly changed it to the APIPA (I was reading the wrong NIC during ipconfig/all). I didn't mean to say pinging the router; I guess I meant pinging another computer on the network, which doesn't work either by the way.

I tried your suggestion, but TCP/IP was already enabled in IPv4. I looked it up in services.msc and it's already started automatically.

For some reason the Win 7 is not getting a correct APIPA address so I've manually entered the addresses (as shown in my above post). I must still be using all the wrong addresses.......Any other ideas? HELP!!!:(:confused:


Noob Whisperer
How many machines are we talking about here? Too many to manually assign static values for IPv4 on all?
Since the APIPA solution doesn't seem to be working reliably for you, I would suggest maybe adopting your own IP schema to resolve your issues.
Try testing one XP machine and the Win7 machine using something like and respectively
both with a subnet mask of (class C)
default gateway (not a real default gateway, just an unused ip address on the subnet which may help Win7 locking as unidentified)
Then see if you can ping from one to the other by IP and then by NetBIOS name.
The upside of this technique is speed and reliability, you're in control and you know what IP belongs to which computer and accessing shares by IP address should overcome any issues with DNS or WINS/NetBIOS name resolution.
\\\ShareName should work dependably.
If you are using Windows 7 Professional or above you can use the Group Policy editor to set how windows 7 handles unidentified networks. See attachment.
Type gpedit.msc into the search or run dialog box and hit enter
Expand Computer Configuration
Expand Windows Settings
Expand Security Settings
Select Network List Manger Polices
In the right pane double click Unidentified Networks
Select Private
Select User can change location
OK your way back out of there and reboot.
See if that helps
If you are running Windows Home Premium or below the Local Group Policy Editor will not be available to you.

Last edited:


Noob Whisperer
Additionally you may be able to use this article to overcome the Unidentifed Network issue that you are currently having.
Disregard the fact that it involves a crossover cable and it's for Vista, just see if steps 2 thru 5 work for you and I would recommend the
"No, make the network that I am connected to a private network" recommendation in step five
Connect two computers using a crossover cable
Here's the one for Windows 7 slightly different
tested it myself and I had to temporarily turn off DHCP from my router and disable my other network adapters but it did work as advertised. The network still says Unidentified but it effectively changes it to "Work" and "Private". Hope some of this helps.

Last edited:
There are only 5 XP computers, plus the Win 7. And I also disconnected ALL the other computers from the hub, so ONLY the Win 7 was connected to the hub. And it can't see itself listed on the network. Isn't that odd?
The network is still working fine for the XPs, so I wonder if I should start playing around with all the other computers if just the Win 7 is having issues?


Noob Whisperer
check the link I added in the post above and see if that helps.

I tried the article, but still no luck. If I want to try static APIPA on the Win 7. What should I try? One of the XPs has IP add and subnet
So, what should I enter for the win 7:
IP: 169.254.38.????
Gateway: leave blank
DNS address: 169.254.38.?????


Noob Whisperer
After trying the steps in the article specific to Windows 7 and turning on network discovery and file and printer sharing for the unidentified network, did the properties of your connection change as indicated in the before and after images attached and is the Win7 machine able to see itself in the Network Map?

With regards to trying to statically assign an APIPA address, refer to this article How to use automatic TCP/IP addressing without a DHCP server
as you can see with a standard class B subnet mask of
The APIPA schema supports an IP address range of thru (excluding the network and broadcast addresses)
So you should have a wide range to choose from just so it remains unique and is not duplicated somewhere else on the network.

By the way, does Win7 have to run network over TCP/IP? My XPs can run fine on the internal network through NWLink NetBIOS only.

Also, after trying all the above steps, everything is the same. I only have Win7 home, but when I manually change the network to "Work", the icon in the network map changes from park bench to a computer, but still says "Unidentified Network" . Plus if I disable and then reenable the connection, it goes back to public again. I've played around with static IP add and no luck! So I'm beginning to consider stepping the computer down to XP. I did on another of the computers because I couldn't stand Vista when that came out.....:sosad::mad:
But last thing I will try in the afternoon is switching out the 8-port switch with another one.....maybe this one is too old and not Win7 compatible.


Noob Whisperer
Also, after trying all the above steps, everything is the same. I only have Win7 home, but when I manually change the network to "Work", the icon in the network map changes from park bench to a computer, but still says "Unidentified Network" . Plus if I disable and then reenable the connection, it goes back to public again.
The unidentified network is not the problem, the problem is when the network is public or reverts back to public. The windows built in provisions for public networks is "No network Discovery" and "No file and printer sharing", you can adjust this by opening the Network and Sharing Center and adjust "Change advanced sharing settings" and expanding the "Public" menu and turning them both on. Not recommended, but if this is a desktop that never leaves your personal subnet, then it probably won't hurt anything, especially if you have no internet access on this machine. But if it's a laptop that you use in public hotspots those changes to the public profile will expose you to network intrusions.
Additionally, in your OP, you mentioned McAfee. Remove it completely using the programs and features applet in the control panel and follow that up with the vendor specific removal tool found in this list here. Consider replacing it with

But last thing I will try in the afternoon is switching out the 8-port switch with another one.....maybe this one is too old and not Win7 compatible.
That's unlikely as there is not much difference between one unmanged switch and another, unless there is some physical damage or other problems preventing the proper functioning of a particular port, in which case you would probably be getting information regarding the media state (disconnected) in the properties of you adapter or when you do an ipconfig /all. Make sure that your Win7 machine can ping itself by IP and NetBIOS name.
command prompt
ping localhost
ping IP address of machine
ping NetBIOS name of machine.
Just to make sure there is no problem with the local TCP/IP stack and or WinSock.

Sorry it took me a while to get back to this. Still having issues! Here's my current setup: TCP/IP enabled over NetBIOS. All IP addressing set to automatic. So, the IP address for the Win7 computer is and subnet The XP computer is and

Per your suggestion, when I ping localhost: good. ping IP address of machine: good. ping NetBIOS name of machine: good.

When I ping the XP address of, says "Request timed out". When I ping the NetBIOS name of the XP (which is "sales") it says "Ping sales []". Then "Request timed out".

So looks like the Win7 knows the IP address of the XP!?!

And when the XP pings the IP add of the Win7 computer, it goes through!!!

This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.