Can't disconnect a peripheral device properly anymore

#1
Hi to all!

Windows 7, new install.

Can't disconnect a peripheral device properly anymore. When I click on the icone, nothing happens.

boguer.jpg

On another forum, someone gave me that line to execute :
%SystemRoot%\System32\RUNDLL32.EXE shell32.dll,Control_RunDLL hotplug.dll

It makes open a window for doing this, but the fonction made to disconnect a peripheral device still doesn't work.

As I insert pretty often an external disk, I find this annoying.

Thanks for you help!
 


#2
I don't know why the USB Icon quit working for you as a disconnect. Have you tried right-clicking on the icon and going from there? If you do then a little window pops-up and you can disconnect from there.

You can also go to the Start Orb, click on Devices and Printers, you will see your external drive in the Devices section, right-click on the icon there and you can choose Eject from there.

Let us know how it works out for you.
 


Joe S

Excellent Member
#3
Some antivirus programs can cause the problem. NOD32 was just mentioned a while ago on WD forums and Avast build 5.1.889 has caused this and other strange sporadic problems also.
Joe
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#4
Win 7 works differently than XP. You may not see the same indications as you did earlier. For example, my flash drive light would turn off if I removed it in XP, but in Win 7 all I get is a message saying it is safe to disconnect, but the light stays on.

In Device Manager, you may have options as to how the device is set up if you look at the properties.
 


#5
Thanks to all!

I forgot to mention that the first days, it was working.

Yes I tried the right click, and still nothing happens.

I found that, as you say, I right click on the disk icone (explorer) and I can eject.

It seems I'll have to get use to that way. ;)
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#6
So you went to the Device Manager, right clicked and selected properties. Then the Policies tab and checked or unchecked one of those options?

If it really will not let you remove it, perhaps something is using it for temporary storage, or it is shared.
 


#7
Enable safely remove disk is enable. I don't know why it doesn't work anymore.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.