By registering with us, you'll be able to discuss, share and private message with other members of our community.

SignUp Now!

Windows 8 Can't see real pics when opening in apps such as Adobe Photoshop??


New Member
Apr 18, 2013
When selecting FILES and OPEN in apps such as ADOBE PHOTOSHOP (and others) all I can see is silly little fake pics instead of the real one. Very maddening and am unable to figure out how to change it in WINDOWS8. Seems to be a default fixed feature but I surely hope not. Anyone else experience this? and come up with a fix? Thanx.
Can you view an image by double clicking on it and using the default Windows Photo Viewer? If not, right click the image and choose/select a default program to view all files of that type:
Link Removed

Now, if the previous suggestion works OK, is it just the Adobe Photoshop that is displaying this behavior? If not, what other apps are exhibiting this behavior?
Are we talking about an actual app or software? Does Adobe make an app for viewing photos?
Here's the deal: Once I select a pic, it shows up normally. The problem is if there a many pics to select from, then there's only silly faux photos with a filename below each one. Here's another example: Say I want to attach a pic to an email. When I attempt to do so, all I get is a window with lots of those silly false pics and filenames. Hope that helps to explain my dilemma, and thanx for the response.
It's still unclear to me, that we are talking about an actual app or just some software. That being said, it sure sounds like some form of corruption, whether it be with the OS or some software. First lets scan the OS for corrupted or missing files...open cmd prompt and run sfc /scannow. Just type sfc /scannow in the cmd prompt and hit enter.
I appreciate the response but I'm savvy enough to say there's no corruption. This issue has been apparent since the Windows8 OS installation. I don't know how to describe the issue any better than I already have but here's one last effort. It seems to be an issue with the OS. Like I have said, were I to use windows explorer and navigate to my pictures sub-directory, all I see is silly false images, all the same, with individual filenames below each one. Once I select an individual pic, it opens up to reveal the actual picture, but until that happens, I have no idea of which picture I'm selecting. If this is still confusing to you I'm afraid I can't make it any clearer. Sorry.
Did you upgrade from 7 to 8 or did you do a clean install of 8?

Ah....What is your default setting for opening your pictures. The little icon is different for each program that views your pictures. Follow pagroundhog suggestion for changing the default program to view your pictures. I use Photo Gallery from MS Essentials. Once you do that, that silly icon thing will change so you will be able to view them.

Also, when you open your picture folder, what view do you have it set to...I'm using large icons...with list or details it shows an icon that doesn't allow you to see the picture until you open the actual picture. That might be your problem right there, the view selection with in the folder itself.
Hmmmm, doesn't work for me. Here's what I see: I start WINDOWS EXPLORER...and highlight the LIBRARIES list option on the left side of the window... I double-click on PICTURES (from the right side of the window) and get multiple folders listed....one folder is labeled MY PICTURES and I double click on that....I then have additional folders of pics categorized so I select one of them and double click...it's at this point that I see the silly pics that I can't identify until I open an individual picture. Changing the default program to view the picture doesn't make a difference, once a picture is selected it opens fine, regardless of what program is used. It's not having the ability to preview the pictures before selecting an individual one that's not happening.
OK . . . . here's the fix:

select the VIEW tab...
under FILES AND FOLDERS, UNCHECK the first item ; Always show icons, never thumbnails.


WHY microsoft decided to make this a default simply escapes my ability to comprehend their thinking process.

Thanks to all who responded, and I hope this helps others.
You don't have to got to the control panel to do this. Like I said in the previous post....you can do that with in the pictuer folder itself.

You have to change the view of the folder itself, the Pictures folder. See picture. Open the picture folder, then click view, then select large icon.

Link Removed

But glad you found a fix!
Last edited by a moderator:

I didn't read through all of the posts so if you already got the answer, or you're not talking about displaying thumbnails for Photoshop files in Windows Explorer, well it's getting late.

You have to download a piece of software to make Photoshop and PDF file preview in Windows 8.

I'll see if I can find it tomorrow, I haven't done it on my new computer yet.
But I did have to do the same thing in Windows 7.

Link Removed

Thanks Mike but I eventually did figure out the problem. WINDOWS 8 defaulted to using a simple icon rather than viewing the actual pics. Go figure. Now, any program I set too default for viewing pics shows the actual picture for selection. Thanks.