DPI Scaling and Autostarting Programs

Discussion in 'Windows 7 Help and Support' started by Cab, Nov 23, 2009.

  1. Cab

    Cab New Member

    Joined:
    Nov 23, 2009
    Messages:
    12
    Likes Received:
    0
    Hi,
    Anyone out there using a higher DPI value? I am, and have encountered a problem. First of all, I need relatively large text in all programs, so I have disabled XP-style scaling in the advanced DPI properties dialog. Doing this will make non-DPI-aware applications larger. This works fine, however, some programs that I have set to start automatically with Windows, like Google Talk, does not get enlarged! If I close the program dna starts it again it will be enlarged, but it appears that programs (at least those non-DPI-aware ones) that are set to autostart don't scale. If that's the case I'd guess it's because they get loaded too early in the chain, before the scaling thing is started.

    Anyone experiencing this? Any suggestions? I could of course disable autostart for those applications and launch them myself (or via a script) but I hope there is a fix for this.

    Regards,
    Daniel
     
  2. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    I do not have the program you are using, but you might check the start icon and right click and choose properties. Under the compatibility tab there is a Disable Display scaling. Have you tried that, but I really don't know what it is supposed to do.
     
  3. Cab

    Cab New Member

    Joined:
    Nov 23, 2009
    Messages:
    12
    Likes Received:
    0
    Unfortunately I do not have a compatibility tab in start menu properties, and display scaling is really what I want, so I would not like to disable it. It works perfectly, except for the programs that are set to auto-start. I close them and fire them up again, and they are scaled.
     
  4. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    Are you are starting the programs using the startup folder? If so, go into the startup folder and right click on the program icon. Then choose the option I mention. If it isn't working now, it doesn't hurt to try something else if you can change it back.
     
  5. Cab

    Cab New Member

    Joined:
    Nov 23, 2009
    Messages:
    12
    Likes Received:
    0
    I see which option you are referring to. If you tick that box, it will actually DISABLE scaling, which is not what I want. Thist most likely is a bug in WIndows 7.
     

Share This Page

Loading...