Dual Boot Vista 64 / Win 7 64 - 0xc000000D on win7 boot

Discussion in 'Windows 7 Installation' started by RyanEricW, Aug 19, 2009.

  1. RyanEricW

    RyanEricW New Member

    Aug 17, 2009
    Likes Received:
    I've been going at this all day searching, trial and error, and it's all very frustrating at this point.
    I wanted to try Windows 7 since it has been released in the RC status (because I had aquaintances try 7000 beta, and no one liked it). So I want to have it on my machine to tinker with and test it out.
    I ended up taking my 300GB drive, and removing about 60GB from it, creating a logical partition, formatting it, then booted into the win7 dvd I have. (win 7 - 7100?, straight off ms)
    Firstly, it takes about a couple minutes just to load the files. Then once it finally gets to the splash* screen and the cursor appears.....it takes about 5-10minutes for the "install" window to appear which seems VERY odd since my machine is VERY fast.
    It takes quite a bit of time to accomplish installing from loading to finished (40minutes maybe)...
    When I go to choose the Windows 7 option on the boot menu, I get this black SOD
    \Windows\system32\winloader.exe error 0xc000000D
    Something about the file being missing or corrupt.

    I took my disk, and entered command prompt (which takes at least 5 minutes due to loading time to get to each time).
    I ran DISKPART, then did LIST VOL, so it would tell me the partitions and letters.
    Then I took another window, and entered bcdedit. The letters matched up and the file DOES exist.

    Heres the result when I run bcdedit in vista.

    Microsoft Windows [Version 6.0.6001]
    Copyright (c) 2006 Microsoft Corporation. All rights reserved.
    Windows Boot Manager
    identifier {bootmgr}
    device partition=C:
    description Windows Boot Manager
    locale en-US
    inherit {globalsettings}
    default {default}
    resumeobject {e1043224-8aed-11de-9058-d11f80b880c8}
    displayorder {default}
    toolsdisplayorder {memdiag}
    timeout 30
    Windows Boot Loader
    identifier {default}
    device partition=Y:
    path \Windows\System32\winload.exe
    description Windows 7
    locale en-US
    inherit {bootloadersettings}
    osdevice partition=Y:
    systemroot \Windows
    resumeobject {e1043224-8aed-11de-9058-d11f80b880c8}
    nx OptIn
    detecthal Yes
    Windows Boot Loader
    identifier {current}
    device partition=C:
    path \Windows\system32\winload.exe
    description Windows Vista - 64 bit
    locale en-US
    inherit {bootloadersettings}
    osdevice partition=C:
    systemroot \Windows
    resumeobject {fb585640-deec-11dd-9abd-e055351ad8d4}
    nx OptIn

    I've tried 3 different sources on 3 different DVD's to see if perhaps I had a bad image (1xmicrosoft/2xtorrent), but that's not the case.
    I've tried setting the path's again to make sure there was no data corruption in the settings, and that was not successful either...

    So when I need to figure is out why it tells me the file "winloader.exe" is missing or corrupt, when in fact it is pointing to the right harddrive, on the right partition, on the right location.

    I have VISTA 64 on my primary SATA HDD with no other partitions.
    Then I have another 300GB SATA HDD, which has two partitions: 1 - misc, 2 - Windows 7.

    Yes, they all show up on the BIOS post, yes it recognizes both drives in the setup without extra drivers. I've tried google, and there was only two listings I seen with similar problems. One ended with a random "Tech" flaming the poster saying its basically retarded to run both os's on the same HDD (which I'm not and still have the same problem), and telling the person to go buy another hdd. The other listing has no responses...
    Then I tried at sevenforums.com but they were just rude about everything claiming I had illegal software because I downloaded 2 off torrent, and would not help me. Which is why I tried the one from microsoft because before that, I couldn't get microsoft's dl link to work for me for some odd reason.

    Here's the error though.
    winloader exe error 0xc000000D on install restart

    I'm just wondering if anyone has any insight to what to do now. I'm a bit lost and hopefully someone knows something more than I do on this haha.

    Thanks in advance

Share This Page