Everything Microsoft related is crashing

Discussion in 'Windows 7 Help and Support' started by himself567, Jan 12, 2011.

  1. himself567

    himself567 New Member

    Joined:
    Jan 12, 2011
    Messages:
    12
    Likes Received:
    0
    So I've been having this really strange and annoying problem where numerous programs crash immediately after I start them, and so far, all of them have been made by Microsoft. So far the list is up to Windows Explorer, Gadgets, Internet Explorer, Word, Powerpoint, Publisher, Windows Media Player and System Maintenance. In addition (I don't know if it's related) I can't install certain programs like Avast! Antivirus or CCleaner. I've run a virus scan with Avira and it didn't find anything and I did a system restore back to the furthest point I could and nothing happened. Another thing is that my Gadgets work, but only if I use the ones that came with Windows. I can't use any of the one's I downloaded after the fact. The only thing I can think of is at one point I had AVG 11 and updated it, which cause the endless loop startup crash, but I was able to fix that. I'm just not sure if that cause additional problems in some files somewhere. If anyone has any idea why this is happening it would be very helpful! Thanks!

    I submitted a thread on the microsoft forums but nobody is on those, here's the link:
    Everything Microsoft related is crashing
     
  2. Elmer

    Elmer Extraordinary Member

    Joined:
    Mar 5, 2010
    Messages:
    3,873
    Likes Received:
    284
    You mention AVG and Avira. Both have caused issues in one way or another with Windows 7.
    I take it you now only have the one installed. I'd be tempted to uninstall the present set up, run the AVG and Avira AV Uninstallers, preferably in safe mode, to clear up any remnants. Then install Microsoft Security Essentials and see if I was still getting the same problems.

    I'd also download and install Malwarebytes, update, run a scan.
     
    #2 Elmer, Jan 12, 2011
    Last edited: Jan 12, 2011
  3. himself567

    himself567 New Member

    Joined:
    Jan 12, 2011
    Messages:
    12
    Likes Received:
    0
    So I uninstalled the software you told me to, but when I went to download the Microsoft Security Essentials the installer crashed just like all my other Microsoft related products are doing. I also ran Malwarebytes and it found nothing.
     
  4. Basher

    Basher Honorable Member

    Joined:
    Mar 15, 2009
    Messages:
    367
    Likes Received:
    12
    Hi,

    Silly question but is your windows 7 and office legit?

    Basher
     
  5. Elmer

    Elmer Extraordinary Member

    Joined:
    Mar 5, 2010
    Messages:
    3,873
    Likes Received:
    284
    Does sound odd.

    If you'd said you couldn't download / install Malwarebytes I'd have immediately suspected a virus / trojan.
     
  6. himself567

    himself567 New Member

    Joined:
    Jan 12, 2011
    Messages:
    12
    Likes Received:
    0
    Yeah, both my windows 7 and office are legit. As for Malwarebytes, I already had it on the computer so I didn't need to download it.
     
  7. Basher

    Basher Honorable Member

    Joined:
    Mar 15, 2009
    Messages:
    367
    Likes Received:
    12
    Hmmm intresting one...
     
  8. Captain Jack

    Captain Jack Extraordinary Member

    Joined:
    Mar 6, 2010
    Messages:
    1,952
    Likes Received:
    139
    DEP setting setting might cause the programs to crash. To check those settings
    1. Click on Start and Right Click on Computer and go to Properties
    2. The click on Advance system settings.

    [​IMG]
    3. There click on Advance Tab and click on Settings under Performance session.

    [​IMG]
    4. Click on Data Execution Prevention.
    [​IMG]

    5. Make sure you have selected “Turn on DEP for essential Windows programs and services only
    6. Then click Apply and click OK and reboot your system
     
  9. himself567

    himself567 New Member

    Joined:
    Jan 12, 2011
    Messages:
    12
    Likes Received:
    0
    Captain Jack, I tried what you suggested by my settings were already on "Turn on DEP for essential Windows programs and services only".
     
  10. Captain Jack

    Captain Jack Extraordinary Member

    Joined:
    Mar 6, 2010
    Messages:
    1,952
    Likes Received:
    139
  11. Elmer

    Elmer Extraordinary Member

    Joined:
    Mar 5, 2010
    Messages:
    3,873
    Likes Received:
    284
    Damn my one finger typing, the Cap'n beat me!!

    @himself No dispersions matey

    it has to be asked!
     
  12. himself567

    himself567 New Member

    Joined:
    Jan 12, 2011
    Messages:
    12
    Likes Received:
    0
    Awesome, I think you might be on to something Captain Jack! When I ran the SFC /SCANNOW it said it found corrupt files but was unable to fix some of them. It then gave a log of it in C:\Windows\Logs\CBS\CBS.log which at the bottom there was a very long list of things from 1/13 that the scan tried to repair but was unable to. They look something like this:

    2011-01-13 16:35:14, Info CSI 0000058f [SR] Cannot repair member file [l:24{12}]"viewprov.dll" of Microsoft-Windows-WMI-View-Provider, Version = 6.1.7600.16385, pA = PROCESSOR_ARCHITECTURE_INTEL (0), Culture neutral, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral in the store, hash mismatch
    2011-01-13 16:35:14, Info CSI 00000590 [SR] This component was referenced by [l:202{101}]"Microsoft-Windows-Foundation-Package~31bf3856ad364e35~amd64~~6.1.7600.16385.WindowsFoundationDelivery"
    2011-01-13 16:35:14, Info CSI 00000591 Hashes for file member \??\C:\Windows\SysWOW64\wbem\viewprov.dll do not match actual file [l:24{12}]"viewprov.dll" :
    Found: {l:32 b:ZhuWbMjx/nB0UpouuW1OXEEKPOJ8Dw06tHdt6uaE3kQ=} Expected: {l:32 b:wpK7+YiOW+XHqQ7DjluzOb3VP13lpi7L8RUgP10Z+pQ=}

    There were a few hundred of these...
    In the instructions it said if it was unable to repair the files I should do a system restore, which I did but it didn't go back far enough. Does this mean I need to re-install windows?
     
  13. Captain Jack

    Captain Jack Extraordinary Member

    Joined:
    Mar 6, 2010
    Messages:
    1,952
    Likes Received:
    139
  14. himself567

    himself567 New Member

    Joined:
    Jan 12, 2011
    Messages:
    12
    Likes Received:
    0
    Yes! The repair install worked and everything is back to normal. Thanks!
     

Share This Page

Loading...